Audio dropouts 4k Atmos on m2ts and mkv

long time user of Vero4k+ and Vero 5… fantastic pieces of kit and using it for mainly Blu-ray 1080 and 4k copies. Using Kodi 20.5 at the moment. It seems there is still an issue with seamless branching in 4k Atmos soundtracks and audio drop outs or complete audio loss. From the Kodi discussions it would appear they are aware of the problem and have maybe fixed this in Kodi v21.

Is there an update to the OSMC release to allow the new version of Kodi to be installed? If its just a matter of time I am going to hang on.

I only started to notice this in the new 4k releases of The Abyss and Aliens. Both are superb remasters and look amazing on the Vero 5.


I’m running Kodi 21 on an Ugoos AM6B+ via CoreELEC and I noticed a couple of dropouts on the extended version of The Abyss (mkv), so it doesn’t look like this is fixed in K21 as yet.

Thanks for confirming its not just me. I can watch the films but I have to play around with stopping, pausing and rewinds to get it to start the audio again.

A nuisance indeed and detracts from the films. I was also watching the extended Abyss version and it always seems to occur “branch” at critical moments.


I’ve not experienced anything like that, just a very small number of audio stutters, most of the film played fine. I’ve not yet tried the Vero V on this yet. Having done some searches, this may not just be a Kodi issue, though it seems it’s being worked on. TrueHD Atmos Dropouts/Cutouts on Kodi 20.5 (assuming only seamless branched sources) · Issue #24944 · xbmc/xbmc · GitHub

I couldn’t see an obvious relationship with branch points, but the mkv is sourced from a seamless branching disc, and I’ve watched many hours of Atmos content from non-branching sources and the audio has been faultless, so the seamless branching must have something to do with it, possibly a glitch in makemkv? I’ll get around to Aliens at some point and see if that has the issue as well.

Is this a remux or the full UHD in a folder?
I noticed this same issue, and others, with the seamless branched UHD of Aliens.
I have yet to watch the UHD of Abyss but they appear to be authored exactly the same.
If you remux the movie you probably won’t get a drop out.
That’s what I found.
For some reason the Atmos drops at certain branches in the disc.

This is a MKV rip of the main feature from a bluray disc. I don’t copy the whole UHD folder structure as its just too big. I am sure in the dim distant past it wasn’t an issue.


my mkv of The Abyss is straight from disc via makemkv v 1.17.6

I will probably be watching this sooner than later myself, if you want to provide approximate time stamps of the areas where your audio dropped out I will see if it happens on my setup as well.
And please specify if this is on the theatrical or special edition.
I understand that it may happen on both versions but your timestamps will be different depending on which version you are watching.

As a side note, when I attempted to watch Aliens Special Edition from my full UHD rip I had audio drop outs, but when I remuxed it with MakeMKV I did not, so that was my experience with that title.
So if you experienced drop outs with Aliens Special Edition remux, I didn’t.
We’ll see what The Abyss does.

Hiya … I am away at the moment and will check next week. This was in an mkv of the extended version. From memory one of the dropouts was close to 1:20 but again … will verify when back from my trip.


very interesting post here. From what I gather, a workaround in the meantime would be to output 7.1 PCM, but obviously not ideal if you have a full Atmos system.

ActiveAE: compensate error for TrueHD passthrough by thexai · Pull Request #25229 · xbmc/xbmc · GitHub

Would that be 1 minute and 20 seconds or 1 hour and 20 minutes?

I haven’t got around to The Abyss yet since I have been working through the Alien movies.
I just finished watching my Alien Covenant UHD remux and there were three separate times where the Atmos audio dropped out and came back within a second.
So I’d have to think that there is something going on here with the drop outs again.
I’ll be watching The Abyss soon now that I’m done with the Alien movies.

1hr 20 mins give or take a few mins … I didn’t get the exact time … I am back from my trip now so have a bit more time.

Will do another watch at the end of the week.


I just finished watching the movie and boy was it a mess.
Everything was fine before the 1 hour and 20 minute mark, but then the issues were often.
I recorded drop outs at the these approximate times:

At first the audio recovered within a second, if I skip back and watch the same scene it doesn’t drop out again, but then at the drop out pass the 2 hour mark the audio would not come back on until I skipped backwards to rewatch the scene.
Then at the very end after the 2 hour and 36 minute drop out I started getting high pitched chirps after skipping backwards to recover the audio.
The scene where she is reading back Bud’s transmission to the people on the surface was full of chirps.

I’m going to look at the original UHD and see where the branching points are to see if they collate at all with the issues.
If so, then it may be something to do with the remuxing process with MakeMKV, it wouldn’t be the first time something like that has happened with TrueHD audio, especially Atmos.

I’m also going to try demuxing it with eac3to since that program has been know to repair “gaps” in TrueHD streams with branching.


is it also a mess if you set audio output to PCM? I’ve been looking at this on a Kodi 21 device, and with the extended version of The Abyss the first audio dropout (with Atmos passthrough) comes around 4mins 50s when the submarine is flooding. However, if I rewind and play the sequence again, there is no dropout. I’ve tried stopping and re-starting a minute before and sometimes I get a dropout, sometimes I don’t. Starting playback from the beginning gives me a reproducible dropout at ~4mins 50s with passthrough TrueHD/Atmos, but if I set audio to 7.1 PCM there is no dropout at all when starting playback from the beginning. So does this support the discussion elsewhere (see link above) that there is a Kodi bug with TrueHD passthrough?

Atmos is delicate, just like HDR, and your devices (TV, AVR, etc) will switch modes entering into and out of HDR or Atmos.
This problem is also present on TrueHD without Atmos, but your AVR doesn’t switch when it loses non-object based audio.
So it’s obvious when it happens on Atmos, not so much on plain TrueHD.
But if it happens enough on a TrueHD track it will cause lip sync issues over time.
I demuxed the Atmos track from The Abyss using eac3to, which is supposed to be better at correcting gaps and what not at seamless branches, then remuxed it back in with the video using MKVToolNix.
I have it playing now, waiting for the 1 hour 20 minute mark to come up and see if it still does it.
I sure wish I could just skip ahead to test but that doesn’t always reproduce the issue, as you have noticed.

I made it through the 1 hour 22 minutes and 1 hour 36 minutes marks with no drop outs.
I went back to the beginning to check the 4 minute and 50 seconds mark mentioned by @ac16161 because I wasn’t looking for that spot initially and I got nothing there either.
I played my original remux that had issues at 1:22 and beyond and it didn’t give me any issues at 4 minutes and 50 seconds either.
I can’t reproduce a drop out at the flooding submarine scene on either remux.
I checked the BDMV folder and both versions of the movie use 00677.m2ts for that scene and there are no branches at that scene on either version.
Sorry @ac16161 I can’t find any reason why you would have a drop out there and I can’t reproduce it by watching the whole UHD by folder or either remuxes I made.

So it appears that demuxing the audio with eac3to fixes the issue for this specific UHD.
For those who are interested, I used MakeMKV to remux the movie with just the video, subtitles, and chapters, NO AUDIO.
Then I used eac3to to demux the Atmos and DD 5.1 tracks.
Then I used MKVToolNix to put them all back together as one remux.
If you are new to eac3to, this page should have enough information to get you through what I did:

So my conclusion is that MakeMKV is not handling the Atmos track on this UHD properly.
And that doesn’t surprise me at all since this has been an issue before with MakeMKV.

1 Like

It seems that I have a little bit of work to do when I am back at home with my PC :slightly_smiling_face:. I really appreciate the work you put in @Kontrarian