Audio output from Pi 3 to AVR

Hi

I’m a new user of OSMC so please be gentle :slight_smile:

I installed the latest release of OSMC on a Pi 3 on a micro SD card. Install went perfectly. Connected the device to my local NAS using the wired connection, again easy. Allowed OSMC to scan my movie content, all went well.

I’ve now connected the Pi to my Onkyo AV receiver using HDMI and tried a movie with a DTS 5.1 soundtrack. The Onkyo is receiving the sound as PCM. What I expected to see is the Onkyo showing DTS in it’s display.

I’ve tried the same movie with my popcornhour a-100 (very old but it works!) and that outputs sound as expected, e.g. allowing the Onkyo to do the decoding.

I have tried setting the passthrough to enabled and disabled on the Pi but this seems to have no impact to the audio output.

Ideal scenario is that the Onkyo does all the decoding and the Pi just sends the audio untouched to the Onkyo. Any pointers would be welcome, thanks in advance.

Just an idea: See this post TrueHD / DTS-HD Vero 2 - #27 by JimKnopf

So, for DTS passthrough you need to have the right settings at

Settings -> System -> Audio
and
Settings-> Player -> Video (disable “Sync playback to display”)

Thanks @JimKnopf

Here is what I did:

Read through that article and enabled Expert settings
Went into Settings>System>Audio
Enabled all three settings in Audio Passthrough, AC3, E-AC3 and DTS
Also disabled Sync playback to display

Not sure if it is mentioned anywhere but those settings seem to be disabled as default. Enabling them allows full passthrough.

I tried 5 different movies and all audio is passed through to the Onkyo as expected! Result!

Thank you for the quick reply. Very happy.