Audio pops and clicks

I occasionally get loud pops and clicks from various audio channels when playing a local mkv file. This happens with only some files, and even then it’s not consistent: if I jump to a different part of the same video, the clicks might get worse, or be gone completely.

Below sample log entries.

2019-08-04 22:16:04.482 T:4071600128 NOTICE: VideoPlayer::OpenFile: smb://filename.mkv
2019-08-04 22:16:04.649 T:3969037024 NOTICE: Creating InputStream
2019-08-04 22:16:04.723 T:3969037024 NOTICE: Creating Demuxer
2019-08-04 22:16:04.848 T:3969037024 NOTICE: Opening stream: 0 source: 256
2019-08-04 22:16:04.848 T:3969037024 NOTICE: CVideoPlayerVideo::OpenStream - Creating codec: 27
2019-08-04 22:16:04.848 T:3969037024 ERROR: CDVDVideoCodecAmlogic::Open - InstanceGuard locked
2019-08-04 22:16:04.849 T:3969037024 NOTICE: Opening stream: 1 source: 256
2019-08-04 22:16:04.849 T:3969037024 NOTICE: Finding audio codec for: 86056
2019-08-04 22:16:04.849 T:3969037024 NOTICE: Closing stream player 3
2019-08-04 22:16:04.849 T:3969037024 NOTICE: Opening stream: 2 source: 256
2019-08-04 22:16:05.036 T:3373265632 NOTICE: CVideoPlayerVideo::OpenStream - Creating Codec: 27
2019-08-04 22:16:05.051 T:3373265632 NOTICE: CAMLCodec::OpenDecoder - using V4L2 pts format: 64Bit
2019-08-04 22:16:12.197 T:4029674208 WARNING: ActiveAE - large audio sync error: 7351.030791
2019-08-04 22:16:12.241 T:4029674208 WARNING: ActiveAE - large audio sync error: 7351.034541
2019-08-04 22:16:12.241 T:4029674208 WARNING: ActiveAE - large audio sync error: 7351.128916
2019-08-04 22:16:12.283 T:4029674208 WARNING: ActiveAE - large audio sync error: 7351.011541
2019-08-04 22:16:12.326 T:4029674208 WARNING: ActiveAE - large audio sync error: 7351.066791
2019-08-04 22:16:12.368 T:4029674208 WARNING: ActiveAE - large audio sync error: 7351.044417
2019-08-04 22:16:12.368 T:4029674208 WARNING: ActiveAE - large audio sync error: 7351.044791

We need complete logs generated with grab-logs -A or the MyOSMC addon please. A snippet is not terribly useful here.

Is there a way to de-anonymize the log? It includes IPs and other personal data.

Yes.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks!

Here it is:
http://paste.osmc.io/urepodubov.coffee

Please describe what hardware is connected and the video and audio paths in use.

Please update OSMC first.

Sam

1 Like

Audio going via HDMI to Onkyo TX-SR705, 5.1 output from the AVR via standard speaker cables.

I had these same pops and clicks when I had RPi 3 with Kodi as my media center so might be hardware related, but thought maybe it’s related to Kodi as it’s not consistent, only happens with some files and only with this source.

See if turning on Settings > Player > Adjust display refresh rate to On start/stop helps. That’s the normal recommended setting for the 4K.

I never followed up here. No, that setting didn’t help, i still get those clicks and pops.

Have you tried playing with settings>system>audio>keep audio device alive setting? If that doesn’t make a difference I would suggest you submit a new log as your old one has been deleted from our system.

That didn’t help, either.

Here updated log
http://paste.osmc.tv/gododahura.xml

I have been having exactly the same issue when pausing, rewinding of ffw. One speaker will emit a loud click/pop. Not always the same speaker.

It sounds like your AVR is having a bit of an issue when kodi has to resync the audio. Setting the adjust refresh rate as bmillham suggested above should have gotten rid of the need to resync the audio for most content, but you said that had no effect. All I can think of here is to either try to route the audio over Toslink (same signal but your AVR might handle it better) or just turn off passthrough. Since your connected directly to your AVR the sound should be the same as without passthrough.

Toslink doesn’t do multi-channel audio IIRC, certainly not DTS HD-MA or TrueHD. I have an old Onkyo SR-SX705 which I’m planning to upgrade this year when HDMI 2.1 AVRs are finally released, but would be nice to find a solution before that as AVR manufacturers have been dragging their feet with HDMI 2.1

Are there any other settings to play with?

Toslink does multichannel via bitstream but those two formats do require more bandwidth than it can supply. If you enabled AC3 transcoding then they would both still output in surround but in reduced quality (only actually needed for the TrueHD as DTS will output the core DTS stream). If you turn off passthrough and allow the Vero to decode the stream you should get full quality to your AVR via multichannel LPCM.

As far as other settings to play with keeping it configured the way you have it I think your just down to the “send low volume noise option” but if the “keep audio device alive” option had no affect I don’t have a lot of confidence this would make a difference. Maybe try a complete stab in the dark and try turning hpd lock on?

I tried all those options together including HPD lock on, and didn’t help, unfortunately.

I have an extra Toslink cable lying around, and will test with that. Thanks!

Your connected audio device is able to process full 8 channel audio! Why not let this device remap the audio signals to the existing speaker configuration instead of the Vero? Is suggest you set

  • settings->system->audio->number of channels to 7.1

and

  • settings->player->video->adjust display refresh rate to start/stop

in any way.

I don’t know if the Onkyo receiver contains the TI DSP chip mentioned in this post?

It happens to be in my two Yamaha RX 673 receivers and now I finally know what’s causing audio drops… :unamused:

This chip has been used in many (older) receivers and due to a design fault started failing. When it happens it takes a while before you realise it’s your receiver and not your source.

But as far as I know it doesn’t result in pops and clicks so it’s probably something else.

2 Likes

Yes, my AVR can process eight channels, but I have a 5.1 setup so I have set it to 5.1 in Kodi settings. Not sure if it makes a difference to do that in Kodi vs AVR?

But more importantly, I noticed there was another setting, “output configuration,” which was set to Optimized. I set it to Fixed, and the clicks are gone! I have to do further testing to see if that fixes the issue for good, but this looks really promising!