Audio via Bluetooth - is it possible?

I found a HowTo. Pairing is impossible. I get »org.bluez.Error.AuthenticationFailed«. That’s all. It simply doesn’t work.

Are you on the latest OSMC version? If you want to troubleshoot please upload logs so that we can check.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

I’m on the latest version. Yes. How can I upload the logs?

Complete logs via grab-logs -A
Also would be interesting are you using the buildin Bluettooth or an external adapater?
Have you rebooted before trying to pair?
When was the bluez error shown? When scanning or pairing?

»Complete logs via grab-logs -A« I don’t understand.

I use the builtin Bluetooth adapter. I have rebooted. The error was shown when pairing:

[bluetooth]# pair EC:66:D1:A1:DF:CB
Attempting to pair with EC:66:D1:A1:DF:CB
[CHG] Device EC:66:D1:A1:DF:CB Connected: yes
Failed to pair: org.bluez.Error.AuthenticationFailed
[CHG] Device EC:66:D1:A1:DF:CB Connected: no

You asked how you can upload logs. If you execute on the command line grab-logs -A the logs will be uploaded and you will be shown an URL that you can share here.

Which speakers are using? Are they having a PIN?

No. They have no PIN. Bowers&Wilkins PX. On all other devices they work without any problem.

The logs: https://paste.osmc.tv/ehecelicov

Well not sure whats gone on here? Seems you uninstalled a2dp at the current moment!

Also seems you are using the buildin bluetooth, or?

Start-Date: 2018-05-16  16:01:16
Commandline: /usr/bin/apt-get-real purge a2dp-app-osmc
Requested-By: osmc (1000)
Purge: a2dp-app-osmc:armhf (1.1.3)
End-Date: 2018-05-16  16:01:21

I installed a2dp because somebody told me this will help. I didn’t, so I uninstalled it. But the main problem is that there is no connection to my headphones. and if I can’t connect them there can’t be any sound, I believe.

I use the builtin adapter yes.

without the a2dp package this will not work, so I suggest you install it and then use bluetoothctl to pair (report your findings).

The builtin adapter is know to give issues therefore I use external adapter. So that may explain differences in success

I installed it. It doesn’t work. It’s just the same. OK. That’s it. (But I don’t understand why MyOSCM shows the headphones as paired although this is not true. On the other hand: I didn’t pay for OSMC, so it’s OK. Bu now I know better why I’ll not buy a Vero…)

Hope the grass is greener on the other side :wave:

1 Like

There is no other side. It doesn’t work. That’s all.

The built-in adapter causes problems. Use an external adapter, as recommended, and your problems will likely go away. We made it quite clear that it’s still experimental though. If LibreELEC works, for you, then use that.

We will put A2DP in the App Store soon; but we can’t fix the problems with the internal adapter on Pi 3 that have been widely reported.

laughmeme

3 Likes

You have to trust the device first.
But the recommendation as always is to use an external adapter on Pi and disable the internal.

Can I connect my Bluetooth speaker JBL GO to a Raspi?
I tried to pair and connect in MyOSMC -> share -> bluetooth menue.
I got the message ‘Bluetooth Connection to JBL GO failed.’
Here’s the log

Model: RPi 2B
Display: official 7" Touchscreen
Internet: Lan cable
no CEC
Sound: JBL GO Bluetooth Speaker # INFO: 3.5mm plug speaker works
OS: OSMC with skin Estouchy
Bluetooth: Bluetooth USB Stick

osmc@osmc:~$ cat /etc/os-release
PRETTY_NAME=“Open Source Media Center”
NAME=“OSMC”
VERSION=“April 2018”
VERSION_ID=“2018.04-1”

# osmc has no lsusb command, I used another raspi with raspbian
osmc@osmc:~$ lsusb
Bus 001 Device 006: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Before you tell me to use ‘a2dp-app-osmc’, that is not possible:
osmc@osmc:~$ sudo apt-get install a2dp-app-osmc
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package a2dp-app-osmc

Did you run sudo apt-get update first?

I’m ashamed, now I hear sound from the bluetooth speaker. Thanks a lot.
Solution was:
sudo apt-get update
sudo apt-get install a2dp-app-osmc

One more question, you are running pulseaudio:
osmc@osmc:~$ pactl list sinks short
0 alsa_output.platform-soc_audio.analog-stereo module-alsa-card.c s16le 2ch 44100Hz SUSPENDED
1 bluez_sink.78_44_05_48_B0_77.headset_head_unit module-bluez5-device.c s16le 1ch 8000Hz RUNNING

With raspbian stretch they use bluealsa proxy for bluetooth. Osmc is based on stretch, are you planning to exchange pulseaudio with bluealsa?

There’s been some discussion about this.

BlueALSA is independent of Debian’s distribution, as Debian upstream doesn’t specifically provision for Bluetooth audio streaming in any way.

Unfortunately there are limitations with BlueALSA, so while we’re watching it, and have pinged the developer, we don’t think it’s suitable for OSMC at this time. We do want to get rid of PulseAudio at the earliest opportunity however.

Thank you Sam, I can live with that answer