Pi3 getting bluetooth audio output working

Hi,

I am trying to get bluetooth audio ouput working on my Raspberry Pi3 running OSMC (using built in bluetooth, no external dongle).
First I tried https://osmc.tv/wiki/general/connecting-a-bluetooth-device/ but connecting always failed, trying out every bluetooth speaker I had available.
Then I installed a2dp-app-osmc as suggested here: https://discourse.osmc.tv/t/audio-via-bluetooth-is-it-possible/72800/27. After that I was able to connect to bluetooth speakers using the first method I tried.
But when I set audio output to ALSA or Puleseaudio in OSMC nothing can be heard through the connected bluetooth speakers…

Then I proceeded as described here (https://kofler.info/bluetooth-konfiguration-im-terminal-mit-bluetoothctl/ ), pairing the speakers with bluetoothctl and setting the sink with pactl but again pairing works just fine but no sound over the speakers…

What am I missing?

Stefan

Well you know have done quite a few changes which might influence each other.
Havin enabled Bluettooth several times due to new installations what always worked for me was:

  1. sudo apt-get install a2dp-app-osmc
  2. Use bluetoothctl -> agent on, scan on, pair, trust, connect
  3. Switch in settings to ALSA sink

When you don’t hear anything through the speaker is the sound still coming through HDMI (TV)?

Suggest you backup via MyOSMC and try on a clean install or if you have a second SD Card do it on a second SD Card.

The only issue I know (and that is when pactl is needed is when it’s a Headset profile and not a plain single sink speaker profile

Ok, I’ll try a fresh install following the steps you mention.
How about the bluetooth settings in OSMC (settings->system->bluetooth) - I assume nothing to configure there?

Not aware of that setting. Or you mean in MyOSMC?

Sorry, I meant in MyOSMC as described here https://osmc.tv/wiki/general/connecting-a-bluetooth-device/.
Do I have to do anything here when proceeding the way you described?

You may have to enable the bluetooth controller in there in case bluetoothctl doesn’t find it.

Well, still no sound coming from the bluetooth speaker…
Connecting works fine, but when I set the audio output in OSMC to ALSA: Playback/recording through the PulseAudio sound server I hear a short crackling sound in the bluetooth speaker but after that nothing. Switching back to PI: Analogue has no effect after that, there is no sound through the speaker connected to the analogue jack. Only after rebooting I hear sound again over the analogue output.
Anything else I could try?

So when you have

Configured you don’t get sound through Bluetooth nor TV (HDMI) even if you switch off Bluetooth

Exactly. Only if I disconnect the speaker using bluetoothctl the playback switches back to analogue and I can hear sound over the analogue output again.

Disconnect via bluetoothctl, I guess switching of the Bluetooth speaker would have same outcome.
So it is the expected behaviour. So need to figure out why they don’t play.
Suggest to upload journalctl logs

Well, I’ll try the official OSMC bluetooth dongle first, just ordered it…
If that doesn’t work I’ll dig in the logs…:smiley:

1 Like

Now I am trying to get the official dongle working but I am a little lost right now. Do I have to disable the internal bt (dtoverlay=pi3-disable-bt seems to disable bt completely)? Any drivers to be installed manually? I remember that in my old Pi 2 the edimax dongle worked just by plugging it in and powering up…

Have you installed the A2DP package?

Sam

Yes, I have installed the a2dp-app-osmc package.
After plugging in the dongle stays dark (assuming it should do some blinking)…

Can you upload kernel log grab-logs -K-J

Now I am quite sure that the dongle I recently ordered is broken. Why?

  1. I have attached the dongle to my Win 10 desktop computer and I got the message that the recently attached USB device was not identified and thus would not work.
  2. I remembered that my SAT-receiver had quite similar dongle attached (https://www.technisat.com/de_DE/USB-Bluetooth-Adapter/352-2714-10261/) and so I tried this out - and it worked (also on my desktop computer)! The sound quality is very poor, it sounds like through an old telephone line…

Now I am using the analog output again, the sound quality is much better then and I need the other dongle for my TV…
@sam_nazarko: How to proceed with the broken dongle? Could I expect a better sound quality with a functioning one? Any switch I missed to change the quality?

Stefan

Hi,

Sorry to hear the dongle is not functioning as expected.
Can you please send an email to support@osmc.tv with your order details so we can look in to this?

Unfortunately I don’t know much about the TechniSat dongle.

Sam