Audio wow and flutter at beginning of videos [Solved]

I’ve got two Pi2’s in the house, one upstairs and one down. Both running OSMC. I’ve noticed something odd lately, possibly since the last update. When I start playing a video from my smb share, for the first couple of seconds the audio suffers from what I can only describe as wow and flutter. Only noticeable if there’s music playing, it sounds like somebody has their finger on a record turntable, causing the sound to slow down and speed up slightly. It only lasts a couple of seconds, but if you pause or stop and then resume the video, it happens each time. I wondered if it might be a problem with the Pi or OSMC, so I fired up a quick version of OpenELEC. No issue there at all. Then the wife pointed out that it was on the upstairs one as well.

It’s not really a big issue, and I’m making a guess that it’s some kind of sync issue between the audio and video streams on the start of playback and like all bugs I bet it disappears with a future update, but I’m curious. Has anyone else noticed this?

Is it like a ‘whooooosh’ noise?

Do you have passthrough enabled?

It would be good if we could find out more about the file you are having issues playing. Please see this Wiki resource for further help

A whoosh sound? Ha ha no. I’m old enough to remember tape decks and record players, so I understand the concept of sound running unevenly. This first minute of this youtube video probably provides the best example.

One of the video files is a 1.4Gb H264 MPEG-4 AVC, resolution 1920x1048, frame rate 23.9, audio codec MPEG AAC sample rate 48000 Hz. The other is the same codecs but 720x418 resolution.

No I don’t have passthrough enabled.

Oh and your link gives me a 404.

The information was moved, check out the ‘Playback related issues: using MediaInfo’ in this wiki How to submit a useful support request - General - OSMC

This is a known issue with dvdplayer in Kodi - I get the exact same thing on some video files on my Mac Mini, so it’s not OSMC specific.

However there are some settings you could try changing that may help - one is to re-enable omxplayer, which has been off by default in the last few versions of OSMC on the Pi 2. This is in settings->Videos->Acceleration, make sure omxplayer is enabled. (omxplayer does not suffer from this wow and flutter issue)

Other options you could try are in Settings->Videos->Playback, try changing sync playback to display to off, or try changing A/V sync method to Adjust PLL. (You might need to try these options in conjunction with omxplayer)

Let us know if any of those help.

omxplayer off for the last few versions does tie in with when we noticed this. I have re-enabled it through Settings as you suggested, and played a video file that demonstrates the issue. The issue is gone. Thanks for that. I shall monitor progress.

EDIT: Jan 10th. No further issues. omxplayer is the fix.

This problem was one of my playback issues, i named “pitchbend”, described in this topic: Crackling Surround Sound with USB DAC

I changed the A/V sync method to Adjust PLL an now video playback starts fine (besides the crackling noises mentioned in my thread). Thanks a lot, DBMandrake!

Adjust PLL (whatever that means) worked for me. I’d call the problem ‘pitch bend’ at the start of playback. Embarrassing demoing a movie for a friend but fixed now.

Hi all - I know this is a very old post but I’m experiencing the same issue (i.e. audio flutter in the opening seconds of video playback) today - however I can’t find the “Adjust PLL” setting in the latest Kodi UI. Any ideas how I can address this issue today please?

I’m running the latest version of OSMC on a Vero 4K+, serving videos from a QNAP NAS using SMB (since every time I try to get NFS working I fail dismally).

Many thanks,

The adjust PLL option was only on Raspberry Pi. It’s not applicable or needed on the Vero.

I would suggest a new post with logs and a description of your audio setup so we can advise accordingly.