August update is totally incompatible with Plex and PlexKodiConnect

This is crazy. I am angry at myself for downloading it, and angrier that you guys turned this loose. I only bought the Vero 4K+ for Plex, and it has done a great job using PlexKodiConnect, not the dreary Plex add-on. I just tried that, installing the 3.3 version from the kodi repository, and it wouldn’t play a 4K film. Plex server is up to date, the Vero is hard-wired to the network.

I want the PlexKodiConnect working again, not the horrible Plex app. I thought you guys knew better than this. If it sounds like I’m angry, it’s because I am.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Might be wise to count to 10 before making your next post.


Thanks for the etiquette tip. Might be wise for you guys to count to ten before you unleash a disaster like this on your customers.

I counted to ten. Then I bought an Nvidia Shield TV Pro.

I downloaded the update because I had developed a sense of trust over the last couple of years. Your support was always timely, and good. I touted the Vero 4K+ on dozens of forum posts. But this messed up what was a very nice Plex client, and made it unusable for the purpose I bought it for, which was the ability to play movies on my Plex server in 4K with full HD audio with Atmos.

No doubt that you guys will get through this transition, and maybe PlexKodiConnect will work again, but I’m done.

1 Like

Although I can understand your frustrated I think your issues are with the Kodi add-ons and the upgrade process, both of which are external to us. Throughout the testing process I’ve tested the Plex official add-on and Composite and never ran into an issue. I see that there has been a couple people who have posted now about problems they ran into but there is nothing we can do about issues until we become aware of them. As for PKC I believe their recommendation has always been a clean install on major Kodi revisions due to their unofficial, non-standard way they edit Kodi’s library database. I just now dumped my userdata and installed their Matrix repo and installed the Matrix PKC add-on. I just picked all the default options and it appears to be working exactly as it should. It populated the library and files in the library are streaming from my Plex server including 4K HDR files.

I suspect that if you dumped your Kodi userdata and installed these add-ons on the now clean system then it would work as you expected it to.

I can’t speak for Plex but I’ve upgraded a few Vero 4K systems running the Mezzmo addon and it was totally seamless including database, settings and similar migration activites. Just had to install the Kodi 19 version of the addon over the top of the Kodi 18 version and it was running instantly. I was streaming right away from my Mezzmo server.


I’ll give it a try. Thanks for the response.

I dumped the userdata, installed Matrix PKC add-on, but that’s as far as I can get. The installation instructions on github may be out of date, because I can’t find where to get the settings page for PKC. I am stuck here:

If PKC does not offer you a prompt and nothing happens after installation:

  • navigate to Add-ons -> Video Addons -> PlexKodiConnect --> Settings. Then choose Choose Plex Server from a list in the Connection section

Help, please. If we can get this going again, I’ll return the Nvidia.

I followed the instructions from here…

and I just downloaded the zip file that adds the repository then in Kodi’s settings allowed 3rd party repositories and then in add-ons install from zip. After installing that you install from repository, choose the new PKC Matrix repro and install the add-on from there. Once installed you open that add-on and it has a walkthrough for setup.

As we speak I’m prepping a new Kodi 18 install that I’m going to load up with the Plex add-ons and do the upgrade again so I can see what issue I run into. Hopefully that will give me some insight into what others are seeing and be able to provide further assistance.

I’d also add that I ran across the following that seems to have pretty solid advice for problematic upgrades. The only thing I didn’t see that would seem logical is to dump the old db and art by dumping the thumbnails folder and from .kodi/userdata/Database the MyVideos116.db, MyVideos119.db, and Textures13.db.

Plexkodiconnect worked fine for me on 18.9, with direct paths and direct play setup, everything was literally flawless.

Updated to 19 (complete clean install), setup worked without a problem but it wont play a single file. I always get a “general error” (very helpful) when trying to start a movie.

Not sure what problems op had with the install process, that worked fine.

I went back to 18.9. Maybe ill try again someday and post logs, but for now, ill stay on the working 18.9

Thanks again. I have it somewhat working, but I’m going to follow the procedure he lists for starting from scratch, as I’m not getting HDR on the 4K movies.

In other words, hoping that the third time is the charm. I’ll report back either way.

Make sure your (Kodi settings) display is set to 1080p (some have reported it getting set to 1080i after the upgrade) and in your Kodi player settings refresh rate switching is set to always or on start/stop.

It was set to 1080i after the update. I changed it to 1080p, and also have the refresh on start/stop.

I can’t figure out how to do this, in the start from scratch instructions:

  1. Exit Kodi
  2. In the folder addons of the Kodi data folder, delete the following directories completely (if they still exist):
  • repository.plexkodiconnect
  • repository.plexkodiconnectbeta
  1. In the folder addon_data in the Kodi userdata folder, delete the following directories completely (if they still exist):

Sent that too soon. Question is, do I need to ssh in in order to delete that?

You can do it via ssh but you may find it easier (assuming your a Windows user and not Linux savvy) to just install the Samba server from the My OSMC add-on and then in Windows bring up File Explorer and in its address bar type in \\192.168.x.x\osmc\.kodi and hit enter. This is replacing the 192… bit with the IP address your Vero is using.

I did all that–installed from scratch–still no HDR

I would suggest you provide some logs so we might figure out why you don’t have HDR.

Here’s a log:

Also, when I turn off my system, the red + lights up on the Vero. If this is a new feature, how do I disable it?

Did you get HDR before the upgrade? I ask because your TV is not advertising support for HDR10, only Dolby Vision.

You could try Settings->Player->Videos->HDR processing–>Force passthrough.

Yes, I did get HDR before. If I force passthrough, aren’t I going to have to set that every time I want to watch HDR? TV is a TCL 6 series that does Dolby Vision, and HDR10.

I just tried >Force Passthrough, and it didn’t work either. And just to be sure I’m not losing my mind, I tried the same movie (Blade Runner) on Infuse on my Apple TV. It displayed the HDR tag, and I confirmed with my TV remote that it was in HDR mode. What it didn’t get on the Apple TV was Atmos, and that was the reason I bought the Vero two years ago.