Auto downscale 4k Content to 1080p for Projector

Hi All,

I know many similar questions have been asked on this before and I have searched but I believe this is slightly different request/question.

I think the answer is probably no, but best to check. So like many I have a 4k HDR TV and a 1080p projector. The PJ is HDMI 1.3 so has no idea 4k exists and gives black screen if you try and play 4k content on it. My current steps are to disable auto-refresh rate switching then turn the GUI refresh rate to match the 4k content. This works fine but is tiresome repeating the steps and undoing them.

Is there any way to force OSMC to limit the resolution to 1080p, keep refresh rate switching on ONLY for the PJ, and keep it at 1080p60 GUI with 4k refresh rate switching enabled for the TV?

I see the whitelist option but expect if I select anything there it will apply to all devices.

TV & PJ are connected to a Denon AVR X3200 and I had wondered if I could force the downscale on Zone 2 HDMI Output but don’t think it’s possible. Thinking a dedicated downscaler might be needed but loathe to fork out £150 or so for a simple set of menu changes I need to make.


The answer is, vero should handle this automatically. When you switch to the PJ, a HDMI hotplug event should be triggered so vero then knows not to send 4k.

You must have your GUI at a resolution/framerate both can handle and enable refresh rate switching.

I’m assuming you don’t want to watch both TV and PJ at the same time! And vero won’t react to the hotplug event if you are already playing a movie - so switch to PJ then start the movie.

If that’s not working, please re-boot with the TV on, switch to PJ, start a 4k movie then post logs.

And don’t touch whitelisting!

Thanks for the positive sound reply @grahamh. I assumed it wouldn’t work as it’s not the behaviour I’m seeing.

  • GUI is 1080p/60 so should be fine for both TV & PJ
  • Correct that TV turns off when PJ switched on - though the Denon AVR uses Zone 2 for Audio and Zone 1 for HDMI sound in case that makes a difference.

I’ve done a re-boot with the TV on, switch to PJ, start a 4k movie, watch the blank screen, switch back to TV and movie plays OK (though froze presumably as was over SMB and not my fstab NFS shares)

Here’s the log;

Let me know if you need anything else!

You didn’t follow the instructions :wink:

I said play the movie (on PJ) then post logs ie don’t switch back to TV before grabbing logs.

Apologies @grahamh - I did read that but didn’t think switching back to the TV before uploading the log would cause an issue. That’ll teach me!

So I have:

Turned on the TV/AVR
Turned on Logging
Switched to PJ
Played movie
Uploaded the log.

Hopefully all OK but let me know if i am still exhibiting reading difficulties :grin:

Many thanks! Got enough to go bughunting…

BTW, is this new since Leia?

Perfect, thanks! And no, not new, just got a bee in my bonnet about sorting my viewing experience so bug hunting myself I guess!

Seems to be a side effect of whitelisting, even though you haven’t enabled it. We can fix it.

Ah, wonderful news! Thanks.

If I can test anything just let me know.

The evidence is you have a file /home/osmc/.kodi/userdata/disp_cap which is overriding the EDIDs. Can you delete that and see what happens?

If you can remember why you thought you needed it, let us know.

1 Like

Hmm, odd! I think I’ve deleted it, I logged in via putty and did ‘rm - rf /home/osmc/userdata/disp_cap’ which gave no error but then I couldn’t change directory to home/osmc/userdata/ to check with ls - all.

So I’ve assumed it’s worked OK and I’ll be firing up the projector later tonight so will test and report back.

I don’t recall having needed or having setup that file but I did have a few gremlins when I got the Vero and perhaps it’s a side effect of those. Thread is here where I laid out my first time user issues:

Thanks for taking a look so quickly!

Ok, didn’t work. I’ll grab some logs tomorrow, and you can check I actually deleted that file correctly when I post them!

-rf is not necessary. It’s just a file so rm on its own will do. Actually, it should be

rm /home/osmc/.kodi/userdata/disp_cap.

My bad, sorry.

The disp_cap copy was recommended before but is no longer necessary.

1 Like

Hi @grahamh

Thanks for the update, only spotted it earlier today. Have just tested with the updated instructions and… It worked! Tried 4 or 5 4k movies, all defaulted to 1080p/24 on the PJ so exactly what I wanted to happen. So thanks to you for taking ownership and resolving within a very short time frame, just excellent.

1 Like

Hi, sorry for raping this old thread :slight_smile: but as I currently still have the same setup (maybe changing to Vero V in the near futute <3) with 4k hdr material played on 1080p projector, I was wondering if the rpi4b and osmc/kodi 20.2 can do tone mapping for hdr - sdr conversion yet or if it is still limited to windows or some android based hardware. At least I couldnt find any setting for it in the system menu.

None of the Raspberry Pi SBC’s can tone map. The Vero 4K/+ can tone map. The Vero V has enhanced tone mapping abilities beyond what the previous model can do.

Thanks for clearly pointing that out :slight_smile:
Ok one pro point more on my Vero V decision list :wink: