Various issues with Vero 4k

Hi All,

I’ve recently got a Vero 4k as I was getting sick of various issues with my Nvidia Shield that rendered it more annoying than anything. There are so many posts on the forum that cover some of these issues but I wanted to create one laying out the issues I have.

I expect you’ll want to see logs for all of this which is fine, I’ll follow the steps outlined in the guide and upload them once I’ve replicated the issues. I’m also going to note some one off or currently seem to be resolved issues in case they flare up again.

Before I start my setup is as follows:

Panasonic DX902B 4k HDR TV
Panasonic AE-4000 1080p Projector
Denon AVR X3200 Amp (4k)
2x Windows 10 servers connected via Gigabit ethernet (gigabit switch upstairs that both connect to, gigabit switch downstairs that the Vero connects to)

*** Refresh Rate switching**

I currently have the Vero set to 1080p60 and find this is often locked/greyed out and cannot be changed. Possibly because the Vero is turned on before my AVR? I’ve came back from holiday yesterday and switched on and the testing I’ve been doing today for some other issues with 4k files only give me 1080p/60 (albeit with HDR!)

Maybe this is just a simple reboot once the AVR is on and this will go away, though even still it’s less than ideal as I’ve not had any issues with the Shield exhibiting the same behavior (that I recall)

It’s happened on both the TV (testing some 4k content today) and a couple weeks back using the projector to watch some 1080p content - all set to 60hz.

Refresh rate switching is on.

*** Bitstreaming**

Prior to the December update (OSMC was on the October update) lossy formats would not bitstream- AC3 and core DTS did not work. DTS-HD and TrueHD were fine oddly. Seems to be OK now but noting it in case of a recurrence.

*** 4k Playback**

I have similar playback issues with 4k content as reported here - John Wick 2 both over the network and locally via a USB3 stick freeze for several seconds around 1:50. I’m connecting via NFS (not via fstab yet but will set this up) but the same issue happens on the USB so it’s clearly not a network issue. It’s not just a micro stutter (not as above, refresh rate switching is on) but the screen freezes for several seconds the comes back having advanced the timeline.

The file is fine, plays no issue on my desktop or the Shield, unfortunately a freeze like that is not acceptable to me if it’s anything other than a fixable configuration issue.

*** 10 bit HDR**

More of a question - my TV triggers HDR with HDR content but there seem to be various thread about having to set this i.e.

echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr

I know the settings for this are being worked on - is there anything I need to actually do here given HDR switches?

*** Weather screen**

Each time I power off the TV/AVR etc when I go back into the Vero it’s on a Weather screen with ‘Feels Like’ and F (as in Fahrenheit ) in the top corner - I have the Weather function off so it’s a little annoying to have to back out of this to get to the menu. It’s not a deal breaker but there must be a way to turn it off?

I think this covers the bulk of the issues I’ve had, I’ve only really managed to watch a few movies on the Vero so far, and when it does work it works well. I’d like to keep using it, the level of support is excellent and the fact that users get requested features implemented is superb, but ultimately I want a device that just works in all scenarios, or at least with minimal fuss and we’re not quite there yet.

Silent Bitstreaming (hopefully resolved), refresh rate issues and problem playback of high bitrate files are issues that I need to have definitely resolved before I can consider this the right device.


OK quick update.

*** Refresh Rate switching**

Rebooting with the AVR on does seem to have resolved this - however, I don;t really want to have to turn the AVR on just to ensure the Vero correctly picks it up when it’s powered on. I leave the Vero on 24/7 unless we’re away so it’s going to be an infrequent thing, but it’ll annoy me if it happens each time (and I’ll forget to power the AVR on first)

*** 4k Playback**

Here’s a log with John Wick 2 playing, I left it running until the picture unfroze, around 10 seconds. This time there was no audio when it came back though my AVR still reported an Atmos stream. I tried another file afterwards, no sound.

Worth noting I did also drop an adbancedsettings.xml file into the userdata folder before this test but don’t expect that would have impacted?

I can’t seem to paste it in here with the formatting messing up.


Let’s address these issues.

That’s correct. If your receiver isn’t serving an EDID when Vero 4K is started, it falls back to 1080p.
You aren’t required to power on things in the ‘correct’ order however. In the next update, there is both the option to Lock HPD (and ignore hotplug events) and to store a list of acceptable modes to either override problematic EDIDs or workaround timing issues.

You can try the new update now if you’d like. In short, you’d turn on your Vero 4K, and when you are able to adjust the resolutions, run:

cat /sys/class/amhdmitx/amhdmitx0/disp_cap > ~/.kodi/userdata/disp_cap

Now, if Kodi cannot read display capabilities for HDMI EDID, it will fall back to the details we captured at a time when it could. Obviously if you changed TV, you’d want to adjust this.

There were some audio changes in the December update that improved things. Hopefully your problem is now resolved. If it crops up again, let me know and we can take a closer look.

I never looked in to John Wick 2 in much detail after I could reliably reproduce the 1:50 freeze. The file’s been remuxed a couple of times by the looks of it, and I wonder if that section is the reason why.

For now, I’d say no. If things are working for you, that’s good.

That’s an odd one. It might be CEC related. You could try disabling CEC temporarily and seeing if it happens. A debug log might show the button press your TV is sending, and we could effectively remap it so that it does nothing.

1 Like

Thanks Sam. Appreciate the swift response, and expected no less :+1:

So in order:

*** Refresh Rate switching**

Great, I ran the command via Putty - got nothing back, is that correct?

*** Bitstreaming**

Good to know, I’m pretty sure I’ve tried the common formats now, DTS-HD HR is probably the only one I haven;t and all seems well. Was a bit surprised when lossy audio didn’t bitstream but lossless did!

*** 4k Playback**

Fair point - I didn’t consider that there could be an issue with the file or even the decryption, it was one of the earlier disks that was decrypted though I do find it odd that the PC and Shield have no issues with it. Do you mind telling me what file it was you checked so I can compare against my own one? I’m going to try the raw m2ts file as well and see how that fares, locally and network.

*** 10 bit HDR**

Again, good news, thanks.

*** Weather screen**

Good shout, CEC is on as I’ve been using the TV remote to control the Vero. Forgot to try this when I had it on there but will try later and see how it goes. Typically the screen wasn’t up when I put the TV back on so it can’t happen each time, but I’ll see if I can capture it in a log for you.

The John Wick issue is an odd one, but it’s seems to be the only 4k file so far that the amlogic players have a problem with, other 905x based players have the same issue with it.

If it’s any consolation I’ve watched almost 60 uhd remuxes so far via the Vero 4k and JW2 is the ONLY time I’ve seen this problem occur. Every other remux has played flawlessly.

It think it’s possibly a problem with the encode that other players just happen to deal with better.

1 Like

Thanks for this, reassuring comments. Does the issue present itself more regularly during JW2 or is it only in that 1:50 - 2:00 section?

If I recall correctly it’s literally only that one section of the video. Around 1:43, something like that.

I did try remuxing, with and without audio, playing the m2ts file directly. Always the same problem. It’s either a weird problem with the encode or a very very obscure bug in amlogics code that can’t handle that section of the video for some reason. Either way I’ve never seen it in any other video nor seen any other reports of a similar problem either here or the librelec amlogic forum. So I wouldn’t worry too much.

You need to try our staging update first. The lack of feedback is correct, but it won’t make any difference until the next update, which you can try in advance.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

We’ve recently improved audio and so far the only people caught out were people who hadn’t quite configured their audio settings correctly in the past. If this happens again, we can definitely advise.

It’s an isolated problem. The file has been remuxed, and the original was nuked.
Different decoders have different levels of tolerance to shitty encodes.

I think @Mevlock sums it up correctly.

Garbage in, garbage out.


I just ripped my own John Wick 2 UHD disc with MakeMKV and it has the same problem in the same place. Serenity also has a problem that seems similar at 3:37. TV and BR player don’t give a toot about either - they sure don’t like much about these remuxes, but play these sections alright.

I’ve cut a 20 second clip of each that exhibits the same problems, and I can post them if they could help. I think it’s too early to dismiss this as shitty encodes or bad rips.

1 Like

I’ve checked Serenity, same problem at 3:37. Will need to do my own rip to make sure, disc is on it’s way. Although the video stream seems fine no evidence of corruption when playing via pc, tv or shield.

1 Like

Sorry for the slow response, been a busy weekend.

*** Refresh Rate switching**

OK, so I ran the staging update, and straight after the reboot the refresh rate switching was working as expected, no 1080p60 lock. I ran the ‘disp_cap’ command you initially sent to me so I’ll try over the coming week with random reboots with the AVR off and let you know how it goes but frst impression is positive. I didn’t change any of the settings on the new menu, assume I don’t need to if it’s working.

*** 4k Playback**

OK, so as has been reported by @Mevlock the original m2ts file exhibits the same problem - this isn’t from a remuxed, encoded or nuked release, it’s a direct decryption of the retail disk so there’s no funny/experimental h265 encoding settings or even immature public h265 tools in use.

If another disk (Serenity) is exhibiting the same issues as reported by @rmrector and @Mevlock then this is worrying and really dents my trust in the playback capabilities despite all of what the vero gets right. I’d appreciate a bit more investigation into this one.

*** Weather screen**

Ok, the screen popped up again when I checked today. It seems it only happens when I’m on the main Kodi screen, not sitting in my sources or another menu. I’ve not yet disabled CEC as that seems to switch off ARC but I’d left the Vero in debug logging so here’s the log and you can perhaps ascertain what’s happening from it - pretty sure I did a reboot on Friday then left it so there shouldn’t be much in the log except navigating to the log upload window.

Assuming that you also updated as recommended above, that should be all that you need to do.

I’d need to see debug logs and samples to reproduce the problem to be able to address this.

Your log shows the following keypress via CEC:

12:46:05.167 T:4076671744   DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverDeactivated
12:46:06.228 T:4076675664   DEBUG: ------ Window Deinit () ------
12:46:14.583 T:3944559360   DEBUG: PushCecKeypress - received key f9 duration 0
12:46:14.592 T:4076675664   DEBUG: OnKey: 249 (0xf9, obc6) pressed, action is ActivateWindow(Weather)
12:46:14.592 T:4076675664   DEBUG: Activating window ID: 12600
12:46:14.701 T:3944559360   DEBUG: PushCecKeypress - received key f9 duration 119
12:46:14.925 T:4076675664   DEBUG: ------ Window Deinit (Home.xml) ------
12:46:14.926 T:4076675664   DEBUG: ------ Window Init (MyWeather.xml) ------

This key can be ‘nooped’ to not do anything. I’m not sure why a device on the CEC bus is sending this signal; but Vero 4K is responding as it should as it believes it is a legitimate press.


Hi @sam_nazarko

There’s a link to 2 John Wick 2 samples, one MKV from the initial remux and one from the untouched m2ts. Both are 45 second clips during the affected area, and the issue kicks in around 19 seconds into each clip. For me the screen totally freezes for about 10 seconds, audio cuts out. Shortly before the video comes back, the playback GUI pops up and on the timeline the progress indicator jumps back and forth, then the buffering wheel pops up. Normal playback resumes around 30 seconds, audio takes longer to come back on the MKV vs the m2ts.

FYI you’ll need to ask for access to the link, assuming I’ve set it up right!

Logs for playback of both, the Vero was rebooted before and in between each sample playback:

As for CEC am I reading the log correctly that it’s seeing an F9 press which is bringing up the weather window? Forgive my ignorance on this, is it just a keymap editor change I need to make or can I load a keyboard.xml that disables this?

Thanks again.

Would like to test this, too… Have sent you an access request for the link. :wink:

No worries, granted @Chillbo.

Hopefully you see the same as me! :grin:

Same here!

Audio and overall playback resume faster on the MKV here.

Played back the two files via a USB 3.0 stick directly connected to my Vero 4k.

Thanks for confirming. USB 3.0 stick in the Vero here too, forgot to note that.

Yes, please. Can you let hornergf in?

Done a couple hours back, let us know how you get on.

Got it. I’ll take a look in a couple of days

1 Like