Playback issue with high bitrate file

I’m having trouble playing this UHD BD Remux of John Wick 2
Here is the MediaInfo for the file

At arround 00:01:48 the plaback slows, then stops and after a few seconds continues to blackback just fine.
Here is a log that might show it (i stopped a few seconds after it playback came back smoothly)

In the log, i’m playing the file fom my fstab mounted nfs share, but i have tested from a fast usb stick and got the same problem in the exact same scene.

My guess was that it’s a bitrate spike, so i tried to mess arround with advancedsettings.xml, without really knowing what combination of settings made the most sense.

In the log the advacedsettings.xml looks like this (formatting is correct in the actual file, just woudn’t show here)

buffermode 1
memorysize 104857600
readfactor 10

With the default values the playback problems would appear even sooner.

Not sure, what other information i can give you, so please let me know if i can provide anything else.

Thanks guys!

Commandline: /usr/bin/apt-get-real install iperf

You’ve already installed iperf. Did you test your network’s true throughput capabilities to/from the server?

Overall bit rate : 85.1 Mb/s

This file is beginning to approach real world max speeds for 10/100 ethernet.

Thx for looking into this!

I could’t figure out how to test throughput from the Server (it’s asynology NAS)
I found a tutorial though, which i will try to follow and and test it.

However, i did test the file from a highspeed USB drive and had the same results in the exact same scene.
I know the USB ports a 2.0 only, but that should still be quite a bit faster than 10/100 ethernet, right?

This starts to make make me question the encode of the file itself. You should try playing on another device.

I guess I’m one step ahead of you on that one :smiley:
I tested the exact file on a Himedia q5 pro and it played fine from start to finish. Also since it’s a remux and not a reencode, I would assume that it’s as good as it gets.

Try doubling cache settings and see what happens.

Explanation of the settings: Memorysize how large Kodi’s cache is in bytes (will use 3 times the memory indicated here). Readfactor is how fast Kodi will try to fill the buffer. E.g. with a stream of 50MBit/s and a Readfactor of 10 Kodi will try to use 500MBit/s bandwidth. This setting has not much impact and just caps the bandwidth Kodi should use. Worst thing: it uses all available bandwidth.

The problem you describe sounds pretty much like data is not coming in fast enough despite full cache. Meaning the cache is emptying faster than it can be filled up again in the end. Though there are some issues in general how Kodi buffers stuff…

USB 2.0 thumb drives can handle about 30 MB/s read rate, but that is rarely achieved on the average cheap USB drive. But for this file it should still be enough unless the thumb drive really drops very low for a prolonged time. I had some sticks that dropped below 6MB/s quite often for prolonged times reading files. I would not trust them for comparison on 4K high bit rate files anymore.

Also possible that the encode is problematic to begin with and cannot be handled by the codec version Kodi uses (read bug in codec, not in encode). But what you are describing sounds pretty much like data is not coming in fast enough.

Measure it from the command line with some tests what the actual throughput you are receiving is to get some ballpark numbers.

Would be nice if the next iteration of Veros will have a Gigabit port… Using an USB Gigabit adapter will only give barely double the speed of 100MBit/s connection.

Thanks for joining the topic!

I doubled the memorysize and readfactore, but it didn’t change anything. I allready had the impression,
that there was a point where raising the value had no further effect. The Vero 4k is using only 300-400MB of RAM when playing this video, if advancedsettings.xml did what i told it to, it would be a lot more.

I also retested playback from USB (its a very fast USB 3 stick that has read speeds of arround 300 MB/s) and i confirmed, that the playback problem happen in the same scene. I would agree that it’s a bad file, but it played back on another device, without issues.

I’ll be testing the same title, tomorrow hopefully if my Vero 4k arrives then.

It’s right at the top of my list of titles to check anyway given it’s extremely high bitrate.

There seems to be a consensus that the JW rip is a bit dodgy.

I think La La Land was better.

Can someone send me a torrent link (PM is great) so I can check it’s the same rip we are talking about?

NFS fstab mount will fare better than SMB.


Yeah, at a certain point the caching doesn’t do anything. There are quite a few assumptions Kodi makes and how it uses it. But that is a total different topic.

But I guess we can rule that out as you used an USB drive you know has good sustained performance.

That would suggest a problem with the codec and Kodi handling it. You already ruled out that it is a bad encode (unlikely on a remux). Guess there is a bug in h265 decoding somewhere as in “something special is not handled correctly”.

I do not know enough what components are involved here on the Vero4K. You might give a test version of Kodi 18 a try though. Or - don’t know how though - use a different player on the Vero 4K just for testing if it is Kodi related or maybe goes into some kernel module that might be involved when the file is played back.

What you could try is a quick remux with the latest mkvtoolnix, just the video and remove everything else. Just to limit it more down if it is caused by the video stream alone.

Though it would be interesting if anyone else can playback the file on a Vero 4K, just to rule out any Network / bandwidth whatever stuff for sure.

A new 4K encode would probably solve this problem for you for sure but will not get us closer to the root cause naturally.

I put my money down on something that is not properly handled by the codec at this point in regards to JW2 if other high bandwidth 4K remuxes work nicely for you.

Hey, I have the same issues with the movie. Stops around 1:53 and continues to play fine after a few seconds. Plays just fine using the built in TV media player though so can’t say for sure what’s wrong.

I just tried this on a nvidia shield (kodi and spmc) and it didn’t have any issues playing the file, so not 100% sure what’s wrong.

Vero 4k came today.

Same problem that others have experienced. Freezing at around 1:48.

Took me a while to get smooth playback for the rest of the file however. SMB even manually mounted via the console just wouldn’t cut it had to use NFS. Smooth sailing after that though.


I have the same problem with John Wick 2. For sure the bitrate is very high for 100Mbit, I thought with changing th cache settings in advancedsettings the the file would be played without issues. The Vero 4k is connected with a Gbit switch and qnap NAS (NFS mount). My Oppo UDP-203 can play the movie without any issues.

best regards,


FSTAB based?

Hello fzinken,

mounted normally through Kodi gui, never tried FSTAB mount. Are there speed differences with the two possibilities?

Yes there are performance improvements with fstab based mounts as e.g. these guys reports

Hello fzinken,

thanks for the tip! I’ll give it a try and let you know the results.

bes regards

The Oppo UDP-203 looks like it has gigabit LAN.

You didn’t post your advanced settings but AFAIK the advertised bitrate of a file is the average figure of what is a variable bitrate. I’ve seen peak bitrates that are many times higher than the average figure, albeit ony for short intervals. The net result is that when peak bitrates rise to about 95 Mbps or higher, you’re going to get a depletion of the video cache for as long as the transient bitrate spike occurs. So for high bitrate files it will be worthwhile having a well-sized read-ahead cache to be able to cope with these transient spikes.

One other thing to note. I recently discovered that with most video formats, except Quicktime, Kodi will in reality use just over half of what you specify for the cache buffer size. My understanding is that half the specified space is given to video caching, and the other half is given to audio caching - but most of the audio cache is normally left unused and not physically allocated

you’re right, the Oppo has Gbit LAN. During playing with the Oppo i noticed bitrate of 90 - 110Mbps, so for sure the 100Mbit LAN of the Vero is a bottleneck. I thougt that mybe the caching-function in the advancedsettings helps, but the judder was the same. Next I’ll try FSTAB NFS mount to see if it resolves the issue.

Which buffer settings can you recommend according to your experience?

best regards,