AVR Onkyo TX-RZ820, DTS-HD HRA/Hi Res Passthrough Issue

Well, it won’t lead anywhere to point fingers (although a Denon source has hinted at it being a problem with their lower-end AVRs, which doesn’t make this easier to solve. also the Denon source didn’t believe it would/could be solved by the manufacturer in software). It is an issue not only affecting the combination of those AVRs and the Vero 4k, that’s what it looks like.

As I said, DTS-HD HRA is such a rare format that most affected users might not even have noticed it. Otherwise there would be a loud outcry already about these AVR lines IMHO.

We’ll continue to look for a solution and let’s hope for the best :wink:

I just checked my DAC specs, but I got a AKM AK4458, just like in your Denon.

It’s not about the DAC, but the DSP chipset. But again, that correlation could be accidental and therefore this is just a guess…

Aahhh sorry, shame I can’t seem to find any sheet with the DSP named by brand or model.

Yup, can’t find anything either. But all models before that had Cirrus Logic DSPs (same as all Pioneer and the lower-end Marantz/Denon models). So, it’s likely that the TX-RZ820 also has a Cirrus Logic DSP…

The RZ820 has a Cirrus CS49844 DSP, see

ONKYO TX-RZ820 Service Manual download, schematics, eeprom, repair info for electronics experts, search for “CS49”
CS49834/44 | Cirrus Logic

1 Like

I have an Onkyo TX-RZ810 and can report that the only way I can get sound from HRA is by choosing ‘Fixed’ in the audio setting. The file then plays as Multi-Channel PCM.
As I only had 2 movies with the HRA sound format, I have sourced replacements and will just avoid that format in the future. As it has been said, HRA is not common.

Can you test the beta we have in stretch-devel now? Use the instructions at the head of the original thread [TESTING] Improved multi-channel PCM for Vero 4K

I hope to get some time tomorrow in the afternoon, will let ya know.

Didn’t make change after updating

Could you please turn on debug logs, re-boot, play a problem file and post the logs and mediainfo.

And what is indicated on yr Onkyo when you play it?

I think you probably know how to do all that but…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

2 posts were split to a new topic: DTS/AC3 passthrough not working

I just notice now that DD and DD+ doesn’t work anymore, all the others do :anguished:
TrueHD is troublesome as well, but atleast that works after 2-3 times.
Just updated to the latest devel, 3.14.29-73, without any succes.

  1. You mean DTS, DTS-HD (MA, HRA and X), TrueHD and Atmos?
  2. Is this repeatable? People are saying it works sometimes.
  1. HRA has never worked, since I only got 5.1, I only get TrueHD from Atmos.
    But DTS, MA and X work perfectly.

  2. Yup tried 5x after each other each.

1 Like

Did DD and DD+ work last month?

Yeah it did, never had issues before our test.
Been really busy the past week, so haven’t watched any movie or tv show in the main time.

Updating to the latest kernel 75, fixed it for me, now only HRA still doesn’t work.


I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

DTS-HD HRA still doesn’t work, but DD, DD+, TrueHD, DTS, DTS-HD MA and DTS:X still does.