Back and Play/pause buttons not Working

On one of my Vero 4K the Back and Play buttons don’t work.
When I press the buttons the remote does give the blue light, but nothing happens in the menu or when I play a movie.
The other buttons seem to work fine.
I have tried to reset the USB pairing but that didn’t help.
What should I try next?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks, the URL


Can’t see any issues with the remote, but it can’t seem to open the file for playback:

2022-08-01 22:23:30.279 T:2740    ERROR <general>: CFileCache::Open - </mnt/3Movies/3Movies/Movies/Eventyret Om Askepot (2015)/Eventyret om Askepot (2015).mkv> failed to open
2022-08-01 22:23:30.279 T:2740    ERROR <general>: InputStream: Error opening, /mnt/3Movies/3Movies/Movies/Eventyret Om Askepot (2015)/Eventyret om Askepot (2015).mkv
2022-08-01 22:23:30.313 T:2780    ERROR <general>: CFileCache::Open - </mnt/4Movies/Movies/Mickey og Bønnestagen (1947)/Mickey og bønnestagen (1947).avi> failed to open
2022-08-01 22:23:30.314 T:2780    ERROR <general>: InputStream: Error opening, /mnt/4Movies/Movies/Mickey og Bønnestagen (1947)/Mickey og bønnestagen (1947).avi

Could be a network issue.

Regards Tom.

It plays the movie just fine. Every movie or series I have tried works.
It’s the back button and the play/pause button that’s not doing anything when I click them

Those two movies must because I haven’t cleaned up the database. They have been deleted


Please enable debug logs and hit play and back a few times and please upload logs.

Regards Tom.

Can you plug the dongle into a PC then open your web browser and go to Youtube and start playing any video. On the remote press the play button. Does this start and stop the video from playing? Now press the back/return button. Does this take you to the previous web page?

I’m a bit lost here as well since I don’t see a custom keymap being loaded, the keymaps that are loading are correct, and if their was a mismatch between the remote and dongle it would not affect either of these particular keys.

I already did that in the first log


Have you tired @darwindesign’s request?

Regards Tom.

You did not. If you had debug logging turned on then it would have allowed us to see what buttons on the remote were registering as being pressed. With normal logging no handlekey events are recorded in the logs.

If you don’t have a PC available to test with but you have a device you can ssh from (android device perhaps) you can also test it like I describe in this thread…

I did enable debug logging, are you referring to Enable event logging?

I have enabled all the options under logging and restarted twice. Started a movie and click all the buttons. Log is here.
Back, play and stop don’t do anything. The other keys work as expected.

I also tried to insert the dongle in my PC with windows 11. I started YouTube and pressed the keys on the remote.
These are not working:
Back, play, stop, volume up, volume down.

The rest worked, also Options… the one right of Back.

The keys don’t register it seems, even though the light turns blue on the remote when I press the button:

osmc@osmcplus:~$ kodi-send -a toggledebug
Sending: {'type': 'action', 'content': 'toggledebug'}
osmc@osmcplus:~$ tail -f ~/.kodi/temp/kodi.log | grep -B 1 'HandleKey'
2022-08-02 18:38:20.644 T:3315    DEBUG <general>: Thread Timer 3627421888 terminating
2022-08-02 18:38:20.644 T:2710    DEBUG <general>: HandleKey: up (0xf080) pressed, action is Up
2022-08-02 18:38:21.238 T:2710    DEBUG <general>: Keyboard: scancode: 0x6c, sym: 0x274, unicode: 0x0000, modifier: 0x0
2022-08-02 18:38:21.238 T:2710    DEBUG <general>: HandleKey: down (0xf081) pressed, action is Down
2022-08-02 18:38:26.238 T:2710    DEBUG <general>: Keyboard: scancode: 0x72, sym: 0x174, unicode: 0x0000, modifier: 0x0
2022-08-02 18:38:26.239 T:2710    DEBUG <general>: HandleKey: volume_down (0xf0b8) pressed, action is VolumeDown
2022-08-02 18:38:27.254 T:2710    DEBUG <general>: Keyboard: scancode: 0x73, sym: 0x175, unicode: 0x0000, modifier: 0x0
2022-08-02 18:38:27.254 T:2710    DEBUG <general>: HandleKey: volume_up (0xf0b9) pressed, action is VolumeUp
2022-08-02 18:39:07.479 T:2710    DEBUG <general>: Keyboard: scancode: 0x2e, sym: 0x99, unicode: 0x0063, modifier: 0x0
2022-08-02 18:39:07.479 T:2710    DEBUG <general>: HandleKey: c (0xf043) pressed, action is ContextMenu
2022-08-02 18:40:33.532 T:2710    DEBUG <general>: Keyboard: scancode: 0x6c, sym: 0x274, unicode: 0x0000, modifier: 0x0
2022-08-02 18:40:33.533 T:2710    DEBUG <general>: HandleKey: down (0xf081) pressed, action is Down
1 Like

It probably disabled itself again when you rebooted. Just for reference, you only need the regular debug logging turned on, no component specific is required. When enabled from the GUI there is a text overlay on the top left of the screen that lets you know when it is active.

Stop and volume would be expected since youtube doesn’t do anything with the multimedia_stop key and plugged into a Windows PC the volume keys actually send - and = keypresses.

This is a new one to me. I think it is safe to say there is an issue at the hardware level from these tests. The only thing left to try would be to put in a new battery just on the off chance that it is sitting at a marginal level and acting up. Perhaps @sam_nazarko has seen this before and has some insight.

I would suggest trying another power supply.

Is there anything nearby that could be causing interference?

@darwindesign suggested to me that changing the battery doesn’t make a lot of sense.

After reading the thread more thoroughly I don’t disagree.

Some buttons are sent as mouse events and some as keyboard events due to how the keycodes are broken. It looks like one of these input pathways are broken. If you send an email to we can handle this. My suspicion is that the receiver is problematic


I will first try my second receiver and second remote on this Vero 4K - and the problematic dongle and remote on the other Vero 4K

I can’t think of anything that should be causing interference. TV (LG) and Onkyo receiver.

Disregard that… Sam was skimming a bit too fast on his first look. On rare occasion there has been situations where someone sticks their Vero right next to a wireless access point or similar item and it causes destructive interference with the radio signal from the OSMC remote. Given that your issue is very specific, consistent, and followed a second location (PC testing), it is implausible for this to be a factor.

I have two spare Vero 4K - I have replaced the dongle and remote with one of the spare ones.
And that’s working as it should. So I guess it’s the dongle as you mentioned.
No need to do more

1 Like