Backup failed to copy Tar file Vero 4K

After the upgrade I’ve experienced multiple days of consecutive failures to copy the TAR files to the NFS (via Kodi) mounted qnap NAS folder. The same nfs mount can be be accessed via video file browser etc or via the osmc backup settings. I just performed a restart and tried to create a manual backup via the osmc service with the same result.

The NAS doesn’t show any errors.

I’ve uploaded the logs

https://paste.osmc.tv/adofubawor

I’d appreciate assistance and feedback on how to resolve this.

I can stream from the same NAS via the Kodi mounted nfs shares just fine

Thanks :blush:

I experience a similar issue both on my Vero 4K and 4K+ since the latest “big update”.
The destination folder for my backups is an fstab based Samba share mount.

I doubt it’s related – because @dirk doesn’t appear to be using fstab.

Perhaps you both have QNAP NAS devices and they both recently received an update?

Sam

Possibly! I installed 4.5.4.1741 15 Day(s) 8 Hour(s) 9 Minute(s) ago.
However, all other accesses from Kodi to the nfs mounts work without an issue. Is there anything out of the ordinary you can see in the logs?

Another user reported an issue with backups in My OSMC, so it could be an add-on issue if you’re using that and not a NAS related issue at all.

I am happy to assist any way I can, Sam. I can correlate the issues starting the day after the update of My OSMC.

I’ve brought this to the attention of @anxdpanic, as he may have some ideas.

1 Like

This is now fixed in the next update, thanks for the report.

3 Likes

Thank you :blush:

I’m seeing this error as well, but it’s kind of weird because I can perform a manual backup without any issues and the tar file ends up where it should. Why would it work manually but not as part of the scheduled update?

I’m subscribed to dev updates but I still get this error every backup, scheduled or manual. I backup to USB, plenty of space. Nothing in the log about it at all.

https://paste.osmc.tv/izepusexig

Your last update is from 25th August, suggest to check for manual update.

I have it do daily checks, just tried manually: no updates available. [edit: sorry for brevity, I was on my mobile. Thank you for helping.]

Then do via command line (see below)
sudo apt-get update
sudo apt-get dist-upgrade

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Also afterwards you might want to check the folder .kodi/temp/ to ensure no old version of the backups remains.

Nope, I’m still on 2021-08.01, so I’m guessing it’s removed the dev updates from my sources and I’ll be blowed if I can find what it is - still looking :smiley:

Suggest to upload logs again so we can help

Nothing’s changed, won’t the old ones do? I’ll sort it in a bit, got a meeting… (sorry :slight_smile: )

Well need to figure out why and the logs may tell.

https://paste.osmc.tv/ugoloyulap

Confirmed that the devel is still in sources. Log is a reboot, followed by update (no update) and then backup (failed.)

Ok problem clarified. The new version wasn’t released. Expect to show up in a couple of hours.

1 Like