Backup failed to copy Tar file Vero 4K

It should be available now – sorry about this.

Tried it late last night and again just now; still no updates and backup failing.

Edit: tried the sudo commands too.

To clarify further (as per another thread mentioning lack of updates) with the GREP command I’m still seeing 19.1.0-16

It seems that the mirrors have not all updated yet.

1 Like

There was an issue with a machine which is responsible for rsync.
I’ve taken care of this and mirrors should be synchronised now.

1 Like

This has worked fine, thank you and sorry for delay in acknowledging it, been in bed ill.

I’ve missed all the replies.sorry about That.

For the record I can’t find any updates for OSMC.

Backups don’t work, the error persists.

Logs: https://paste.osmc.tv/unokesezag

I’d there something else I ought to check?

What happens if you try upgrading from the command line?
Your machine might already be up to date.

I’ll give it a try and report back ( I would also think it’s up to date tbh, checks run and report there are no updates)

Which in turn would mean the backup issue has multiple variants.

I’ve also just realised, that was did in fact not get the “backup failed to copy” every day after you mentioned a while ago that a fix was forthcoming. I tried removing the schedule and adding it, changing times etc.

It looks like the schedule didn’t work as well.

But let’s check the update first.

The following packages will be upgraded:
  libc-bin libc-l10n libc6 libntfs-3g883 libssl1.1 locales multiarch-support ntfs-3g openssl
9 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.9 MB of archives.
After this operation, 13.3 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://security.debian.org buster/updates/main armhf ntfs-3g armhf 1:2017.3.23AR.3-3+deb10u1 [401 kB]
Get:2 http://ftp.fau.de/osmc/osmc/apt buster/main armhf libc6 armhf 2.28-110.1 [2390 kB]
Get:7 http://security.debian.org buster/updates/main armhf libntfs-3g883 armhf 1:2017.3.23AR.3-3+deb10u1 [162 kB]
Get:3 http://ftp.fau.de/osmc/osmc/apt buster/main armhf libc-bin armhf 2.28-110.1 [665 kB]
Get:8 http://security.debian.org buster/updates/main armhf libssl1.1 armhf 1.1.1d-0+deb10u7 [1300 kB]
Get:4 http://ftp.fau.de/osmc/osmc/apt buster/main armhf libc-l10n all 2.28-110.1 [846 kB]
Get:5 http://ftp.fau.de/osmc/osmc/apt buster/main armhf locales all 2.28-110.1 [4059 kB]
Get:9 http://security.debian.org buster/updates/main armhf openssl armhf 1.1.1d-0+deb10u7 [818 kB]
Get:6 http://ftp.fau.de/osmc/osmc/apt buster/main armhf multiarch-support armhf 2.28-110.1 [215 kB]

A few packages were upgraded when using

sudo apt-get update
sudo apt-get dist-upgrade
as advised further up.

It does not look like there was any update for OSMC.

I also checked:

the scheduled backup did not run
But there was also no error message this time around.

You would need to add this to your /etc/apt/sources.list

deb http://apt.osmc.tv buster-devel main

Update with the above commands and then remove that line again.

Gotcha, Thank you :slight_smile:
I edited the sources with nano, ran the commands.
Currently being installed.

osmc@kodi:~$ sudo nano /etc/apt/sources.list
osmc@kodi:~$ sudo apt-get update
Hit:1 http://ftp.debian.org/debian buster InRelease
Hit:2 http://ftp.debian.org/debian buster-updates InRelease
Hit:3 http://security.debian.org buster/updates InRelease
Hit:4 http://ftp.fau.de/osmc/osmc/apt buster InRelease
Get:5 http://ftp.fau.de/osmc/osmc/apt buster-devel InRelease [4708 B]
Get:6 http://ftp.fau.de/osmc/osmc/apt buster-devel/main arm64 Packages [16.6 kB]
Get:7 http://ftp.fau.de/osmc/osmc/apt buster-devel/main armhf Packages [34.2 kB]
Fetched 55.6 kB in 3s (21.6 kB/s)
Reading package lists... Done
osmc@kodi:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  armv7-libass-osmc armv7-libcrossguid-osmc armv7-libnfs-osmc bluez dh-python
  gnupg-agent libapt-inst1.5 libbind9-140 libbind9-90 libcdio13 libdbus-1-dev
  libdevmapper-event1.02.1 libdns100 libdns162 libdpkg-perl libenca0
  libevent-2.0-5 libgdbm3 libgif4 libgnutls-deb0-28 libhogweed2 libicu52
  libicu57 libisc160 libisc95 libisccc140 libisccc90 libisccfg140 libisccfg90
  libiso9660-8 liblvm2app2.2 liblwres141 liblwres90 libmicrohttpd10
  libmysqlclient18 libnettle4 libntdb1 libntfs-3g871 libperl5.24 libplist2
  libpng12-0 libprocps6 libpsl0 libpython3.5-minimal libpython3.5-stdlib
  libssl1.0.0 libssl1.0.2 libunistring0 libwebp5 libwebpdemux1 libwebpmux1
  libwebpmux2 libxtables10 pkg-config python-apt python-certifi python-chardet
  python-dbus python-dbus-dev python-gobject python-idna python-imaging
  python-pexpect python-pil python-pkg-resources python-ptyprocess
  python-requests python-six python-unidecode python-urllib3 python3-distutils
  python3-lib2to3 python3.5 python3.5-minimal wireless-firmware-osmc
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  python-crypto python-ldb python-samba python-tdb samba-common-bin
  vero364-image-4.9.113-48-osmc:arm64
The following packages will be upgraded:
  mediacenter-addon-osmc mediacenter-eventclients-common-osmc
  mediacenter-send-osmc mediacenter-skin-osmc vero3-mediacenter-osmc
  vero364-kernel-osmc:arm64
6 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 204 MB of archives.
After this operation, 130 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.debian.org/debian buster/main armhf python-crypto armhf 2.6.1-9                                                       +b1 [255 kB]
Get:2 http://security.debian.org buster/updates/main armhf python-samba armhf 2:                                                       4.9.5+dfsg-5+deb10u1 [1812 kB]
Get:3 http://ftp.debian.org/debian buster/main armhf python-ldb armhf 2:1.5.1+re                                                       ally1.4.6-3+deb10u1 [33.9 kB]
Get:4 http://ftp.debian.org/debian buster/main armhf python-tdb armhf 1.3.16-2+b                                                       1 [16.0 kB]
Get:6 http://security.debian.org buster/updates/main armhf samba-common-bin armh                                                       f 2:4.9.5+dfsg-5+deb10u1 [579 kB]
Get:5 http://ftp.fau.de/osmc/osmc/apt buster-devel/main armhf mediacenter-eventc                                                       lients-common-osmc all 1.0.4 [23.2 kB]
Get:7 http://ftp.fau.de/osmc/osmc/apt buster-devel/main armhf mediacenter-send-o                                                       smc all 1.0.0-6 [2468 B]
Get:8 http://ftp.fau.de/osmc/osmc/apt buster-devel/main armhf mediacenter-addon-                                                       osmc all 3.0.733 [6680 kB]
Get:9 http://ftp.fau.de/osmc/osmc/apt buster-devel/main armhf mediacenter-skin-o                                                       smc all 19.1.0-4 [18.2 MB]
Get:10 http://ftp.fau.de/osmc/osmc/apt buster-devel/main armhf vero3-mediacenter                                                       -osmc armhf 19.1.0-18 [152 MB]
Get:11 http://ftp.fau.de/osmc/osmc/apt buster-devel/main arm64 vero364-image-4.9.113-48-osmc arm64 4.9.113-48-osmc [24.2 MB]
Get:12 http://ftp.fau.de/osmc/osmc/apt buster-devel/main arm64 vero364-kernel-osmc arm64 3.9.213 [1056 B]
Fetched 204 MB in 1min 37s (2104 kB/s)
(Reading database ... 39897 files and directories currently installed.)
Preparing to unpack .../00-mediacenter-eventclients-common-osmc_1.0.4_all.deb ...
Unpacking mediacenter-eventclients-common-osmc (1.0.4) over (1.0.3) ...
Preparing to unpack .../01-mediacenter-send-osmc_1.0.0-6_all.deb ...
Unpacking mediacenter-send-osmc (1.0.0-6) over (1.0.0-5) ...
Selecting previously unselected package python-crypto.
Preparing to unpack .../02-python-crypto_2.6.1-9+b1_armhf.deb ...
Unpacking python-crypto (2.6.1-9+b1) ...
Selecting previously unselected package python-ldb.
Preparing to unpack .../03-python-ldb_2%3a1.5.1+really1.4.6-3+deb10u1_armhf.deb ...
Unpacking python-ldb (2:1.5.1+really1.4.6-3+deb10u1) ...
Selecting previously unselected package python-tdb.
Preparing to unpack .../04-python-tdb_1.3.16-2+b1_armhf.deb ...
Unpacking python-tdb (1.3.16-2+b1) ...
Selecting previously unselected package python-samba.
Preparing to unpack .../05-python-samba_2%3a4.9.5+dfsg-5+deb10u1_armhf.deb ...
Unpacking python-samba (2:4.9.5+dfsg-5+deb10u1) ...
Selecting previously unselected package samba-common-bin.
Preparing to unpack .../06-samba-common-bin_2%3a4.9.5+dfsg-5+deb10u1_armhf.deb ...
Unpacking samba-common-bin (2:4.9.5+dfsg-5+deb10u1) ...
Preparing to unpack .../07-mediacenter-addon-osmc_3.0.733_all.deb ...
Unpacking mediacenter-addon-osmc (3.0.733) over (3.0.730) ...
Preparing to unpack .../08-mediacenter-skin-osmc_19.1.0-4_all.deb ...
Unpacking mediacenter-skin-osmc (19.1.0-4) over (19.0.0-28) ...
Preparing to unpack .../09-vero3-mediacenter-osmc_19.1.0-18_armhf.deb ...
Unpacking vero3-mediacenter-osmc (19.1.0-18) over (19.1.0-16) ...
Selecting previously unselected package vero364-image-4.9.113-48-osmc:arm64.
Preparing to unpack .../10-vero364-image-4.9.113-48-osmc_4.9.113-48-osmc_arm64.deb ...
Unpacking vero364-image-4.9.113-48-osmc:arm64 (4.9.113-48-osmc) ...
Preparing to unpack .../11-vero364-kernel-osmc_3.9.213_arm64.deb ...
Unpacking vero364-kernel-osmc:arm64 (3.9.213) over (3.9.208) ...
Setting up python-crypto (2.6.1-9+b1) ...
Setting up mediacenter-skin-osmc (19.1.0-4) ...
Setting up vero364-image-4.9.113-48-osmc:arm64 (4.9.113-48-osmc) ...
11+1 records in
11+1 records out
11741184 bytes (12 MB, 11 MiB) copied, 1.3167 s, 8.9 MB/s
0+1 records in
0+1 records out
112640 bytes (113 kB, 110 KiB) copied, 0.00835016 s, 13.5 MB/s
Setting up python-ldb (2:1.5.1+really1.4.6-3+deb10u1) ...
Setting up vero364-kernel-osmc:arm64 (3.9.213) ...
Setting up mediacenter-eventclients-common-osmc (1.0.4) ...
Setting up python-tdb (1.3.16-2+b1) ...
Setting up mediacenter-addon-osmc (3.0.733) ...
Setting up python-samba (2:4.9.5+dfsg-5+deb10u1) ...
Setting up mediacenter-send-osmc (1.0.0-6) ...
Setting up samba-common-bin (2:4.9.5+dfsg-5+deb10u1) ...
Checking smb.conf with testparm
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Server role: ROLE_STANDALONE

Done
Setting up vero3-mediacenter-osmc (19.1.0-18) ...
Processing triggers for libc-bin (2.28-110.1) ...
Processing triggers for mime-support (3.62) ...
osmc@kodi:~$ reboot

I will check if the backups run automatically again tomorrow then at the scheduled time.

I also removed the added line again.

This worked exactly once.
So the effect is as follow:

after the actions documented earlier, on the next day it copied the backup on the 24th.
Today I just checked Kodi and the message “Failed to copy Tar file” is back.

FWIW I had the same issue today. Had to reboot the Vero4k in order for the backup to be able to copy the Tar file. Nothing else changed… not a permissions issue on the destination network location for sure. Definitely within the OSMC software. Will try tomorrow to see if I get the “Failed to copy Tar file” error. BTW, I was on the main, not the dev branch when this happened. Will update to the dev branch then attempt to see if this has been resolved.