Best HDD format for Vero 4k+? (And how to do so!)

#1

Hi,

I’ve recently received my Vero 4k and it’s been great. However, I’ve noticed stuttering when playing large 4k files. From some posts here, it seems like NTFS is not the best format as that’s what I’m using. I tried the command mentioned in https://discourse.osmc.tv/t/vero-4k-still-usb-2-0/73800/42:
sudo hdparm -tT /dev/mmcblk0 And I got around 30 MB/s in the “Timing buffered disk reads”.
My guess is that’s because of NTFS, right?

If so, what is the best format I can use instead that will provide better read speeds for the 4k+? (And what is the best way to do that)

(FYI: I’m using a 4TB WD HDD powered by a separate USB hub)

Thank you so much in advance! I’ve already started backing up the HDD to prepare for a possible format.

#2

Do you plan to use the drive on another machine? If so, exFAT is your best choice. If you don’t, ext4 is a good choice.

#3

ext4 is best, assuming you don’t want to read it from windows?

you’ve got to be careful how you do it or you’ll format the wrong disk!

This isn’t a bad guide I’d say: http://okomestudio.net/biboroku/?p=291

Basically fdisk to identify the correct device and delete/create partitions, then mkfs.ext4 to format as ext4, add to fstab to mount on boot.

you might want to run “sudo tune2fs -m 1 /dev/whatever” to reduce the reserved blocks down from 5% on a 4tb drive!

#4

Thanks for the quick response! I don’t think I’ll need to use it on my Windows machine. But if so, will exFAT mean slower read speeds? If it does, then I’ll stick to ext4.
Also, you can confirm the 30 MB/s read speeds are because of the NTFS?

#5

Thanks for the response! I’ll get on it once I’ve backed up my files.
Also, can you elaborate on this part:

What does this offer?

Once again thanks for your time.

#6

It reserves less space for the root user; something that won’t really be necessary unless you’re using the disk to run an OS on, so it’s a good idea to get a bit more storage.

1 Like
#7

Your external disk would probably have been /dev/sda, not /dev/mmcblk0.

Try the hdparm command again: hdparm -tT /dev/sda

#8

Yes, I changed the command according to my setup. It was giving 30 MB/s (I ran “sudo hdparm -tT /dev/sda”), sorry for the misunderstanding!

Should it be higher with NTFS or is that normal?

#9

hdparm reads directly from the device, so, AFAIK, shouldn’t be affected by the file system.

#10

Indeed. Running that on mmcblk0 will give you a paperweight and it would need to be returned to us.

#11

Hmm. How would I know whether or not the stuttering is from the (NTFS) file system, then?

#13

Are you talking about connecting a drive directly to the Vero 4K by USB?

If so, it’s possible that the bottleneck is the Vero’s USB 2.0 port: that’s likely to max out at around 30-40MB/s, regardless of what the disk is doing. A Vero 4K+ talking to a remote drive via gigabit Ethernet is likely to be faster.

Having said that, the maximum bit rate you’re ever going to encounter on a 4K video is, what, around 120 Megabits per second? If you can read from the disk at 30 Megabytes per second, that’s twice what you need.

#14

The USB 2.0 interface is fast enough to handle 3 UHD rips simultaneously. 40MB/s is 320Mbps/sec. Won’t be the issue.

#15

I’m connecting a HDD via a powered USB (3.0) hub (as I’m not sure the Vero 4k+ can handle powering the HDD).

Many sources say that NTFS has high read overhead on linux so playing 4k@60fps can create some stuttering.

#16

NTFS has to go through userland (FUSE) so performance is pretty lackluster.

#17

Why do you think there would be stuttering then? (if NTFS is not the culprit)

#18

NTFS is likely the culprit. Your 40MB/s speed is from a block level access, not a filesystem level access.

#19

I’m not entirely sure what this means tbh lol. But I’ll take your word regarding NTFS being the culprit and use exFAT or ex4.
One last question: would both exFAT and ex4 solve my problem or exFAT would not be as good?
Thanks a lot for your support!

#20

I would use ext4 if you can

1 Like
#21

I have just been reading this post regarding what is the best format for new external hard drive
I have just formatted a seagate 8tb to ext4
When this drive shows in windows on ntfs I have 7.27 tb when it’s been formatted to ext4 I have 7.16 tb. Is there any way of getting this back?
Can someone please give me a simple explanation as i have googled it but is all a bit over my head
Many thanks in advance