Black Screen After Install On ATV1

I am new to open source and I must say I am impressed with the hard work and dedication by you all.

So I tried installing OSMC last night several times. I got to the part where it says successful installation. Then it boots then I get no system interface or anything, just either black and sometimes pink.

I wonder If my failure were due to not installing a Crystal HD, due to not have a working Internet when I installed (I thought this was not necessary unlike OpenElec), and I was using HDMI, although when I tried reinstalling again with the RGB ports I was stuck at the installation for 15-25 mins until I decide to redo it again.

I have tried both USB install and HDD. I get the success installation with HDD, and mostly stuck with the installation bar completed with USB.

I will try again tonight and will use a diff USB stick and try HDD install again.

Thank you in advance for the input.

I tried installing again with RGB ports instead of HDMI.

First, with HDD and I received the success installation information and then after that it booted and then all I saw was blank screen. I tried this process again and then after the success I removed the USB during its boot and then it showed installation process again and then stuck in the end of the installation process.

Second, I tried with USB install and it was the same, a blank screen.

Success installation with openelec, but configurations are a mess and now it’s just giving me the skin with nothing. Maybe I should try this again altogether when I have the “highly” recommended crystal HD.

I have tried leaving the USB attached as well. It loads then nothing and a few times showed me a sad face. That does not seem like a success installation to me so I try a different avenue of installation, but to no avail.

I am not making any assumptions, and follow instructions. I just do not have the Crystal HD.

i just installed the usb stick version, after 2 reboots with the tux/atv logo displayed briefly in between, but all i get is a black screen (rgb)

now what? ssh is super sluggish, & the screen flashes occasionally

I get the same thing with USB. My TV is the older Sony WEGA DLP, which I know is capable of 720 and 1080p’s because I have used them with PS3 and other components with no trouble.

I think that crystal HD might be something necessary rather than “highly” recommended.

The Crystal HD card would have nothing to do with this. It simply decodes H264 video playback.
OSMC will boot and work ok without it, just don’t expect HD video playback of H264 files to be great.

A black screen on bootup usually means that someone may have to manually configure X11 since the settings their display requires, for some reason wasn’t auto detected. I had the issue back with CB2, with my HDMI TV. If the TV was connected downstream of my surround sound system I would get a black screen. Even when directly connected, the TV would send out invalid EDID info and X11 would therefore select the wrong settings and X11 was running in Standard Def.

Sad face can be cause by many things. For example, a “read only” partition, caused by partition corruption will cause kodi startup to fail. Partition corruption can occur if you unplug the USB stick without shutting down OSMC.

We don’t suggest anyone try an HDD install until the bug is fixed. There could be other issues indirectly caused by the bug and you will need to wipe and reinstall the HDD once the bug is fixed anyhow.

This was explained back in post #4 of this thread.

i do have the chd card (isn’t that the whole point of this exercise?-) and my tv is connected via the component port…480i looks gr8 on a 70" 4k when booting, but black is black;-\

i just rebooted w/o the usb stick, & it runs thru the installing files prog.bar but then hangs as noted above.

rebooting now w/the usb stick, but still blackscreen…here’s my install.log:

osmc@osmc:/boot$ cat install.log
Wed Dec 2 16:04:22 2015 Starting OSMC installer
Wed Dec 2 16:04:27 2015 Detecting device we are running on
Wed Dec 2 16:04:27 2015 Mounting boot filesystem
Wed Dec 2 16:04:27 2015 Trying to mount to MNT_BOOT (/mnt/boot)
Wed Dec 2 16:04:27 2015 Using device->boot: /dev/sdb1 and FS: hfsplus
Wed Dec 2 16:04:32 2015 No preseed file was found
Wed Dec 2 16:04:32 2015 Creating root partition
Wed Dec 2 16:04:32 2015 From a root partition of /dev/sdb2, I have deduced a base device of /dev/sdb
Wed Dec 2 16:04:34 2015 We are using GPT. I need to erase the first 512 bytes and reconstruct the partition table
Wed Dec 2 16:04:39 2015 Re-creating Apple TV partition structure
Wed Dec 2 16:04:39 2015 Going to mklabel with device: /dev/sdb with a label type of GPT
Wed Dec 2 16:04:41 2015 Calling mkpart for device: /dev/sdb and fs: hfsplus with start 40s and end 256M
Wed Dec 2 16:04:42 2015 Going to set flag 1 atvrecv on /dev/sdb with value of on
Wed Dec 2 16:04:45 2015 Determined 256 MB as end of first partition
Wed Dec 2 16:04:45 2015 Calling mkpart for device: /dev/sdb and fs: ext4 with start 258M and end 100%
Wed Dec 2 16:04:47 2015 Calling fmtpart for partition /dev/sdb2 and fstype ext4
Wed Dec 2 16:06:07 2015 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
1941504 inodes, 7753216 blocks
387660 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=0
237 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000

Allocating group tables: done
Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

Wed Dec 2 16:06:07 2015 Mounting root
Wed Dec 2 16:06:07 2015 Trying to mount to MNT_ROOT (/mnt/root)
Wed Dec 2 16:06:07 2015 Using device->root: /dev/sdb2
Wed Dec 2 16:06:07 2015 Extracting files to root filesystem
Wed Dec 2 16:06:07 2015 Starting extract progress…
Wed Dec 2 16:42:22 2015 Extraction of root filesystem completed
Wed Dec 2 16:42:22 2015 Configuring bootloader
Wed Dec 2 16:42:22 2015 Configuring bootloader: moving /boot to appropriate boot partition
Wed Dec 2 16:42:36 2015 Configuring boot cmdline
Wed Dec 2 16:42:36 2015 Configuring /etc/fstab
Wed Dec 2 16:42:36 2015 Successful installation. Dumping log and rebooting system
osmc@osmc:/boot$

I’m not aware of a 70" display supporting 480i (composite) inputs, nor a situation where this would look great. We can only help you if you’re honest about your situation. If you’re using an AVR which has an HDMI upscaler, then seeing as you can afford such a display, you’d be best served by upgrading (both your AVR and your playback device too)

Best

Sam

rebooting w/hdmi gave me the sadface 1080i then repeatedly flashes the osmc splash screen/blackscreen…ssh hangs until the splash comes up…and now my atv calls itself Etc instead of osmc:
osmc@Etc:~$ uname -a
Linux Etc 4.2.3-6-osmc #1 Mon Nov 2 17:21:18 UTC 2015 i686 GNU/Linux

trying the hdd install stick now…

actually i got a gr8 deal on an open box vizio: $1100!-) it shows 480i when the atv is connected thru the components…ah, just rebooted w/ the hdd stick & hdmi, now it’s only flashing the sadface:-(

osmc@osmc:~$ mkdir .ssh
mkdir: cannot create directory ‘.ssh’: Read-only file system

yup, that’s a problem:-\ w.a.f. = zero;-}

You will then need to follow the instructions in the osmc wiki so that X11 will use the Component out.
https://osmc.tv/wiki

It’s not hanging… it completed the install… and on reboot you get a black screen since you don’t have component configured as shown in the wiki

[/quote][quote=“airdrummer, post:75, topic:10272”]
Read-only file system
[/quote]

The first post in this thread, and few others, and the post 4 above this, states:

ATTENTION: A bug has been found that prevents the HDD install from working correctly. It is being investigated. Stay tuned for updates. Although the HDD appears to work correctly if you leave the USB stick inserted, ONE OF THE PARTITIONS WILL BE READ ONLY AND WILL NOT WORK CORRECTLY

Advice: do a clean USB install on a good stick, and configure component output as described in the wiki.

thanx, i’ll just go with hdmi;-)

btw https://osmc.tv/wiki/apple-tv/configuring-component-output has no diff between 720p & 1080p…might want to fix that

Thank you for the clarification. Now that part is clear for me and I saw the instruction on how to manually adjust the configuration with X11. How do I go about doing that? Do I take the USB out of ATV1 and then try to mount it on my Mac and change the configuration? I am new to this kind of stuff so bear with me and thank you again.

no need to pull the hdd, just ssh into the atv & edit the config…welcome 2 the commandline;-)

My ATV is not even connected to the network yet. How do I “ssh” that?
I can’t view anything past complete installation and reboot. It is blank.

The wiki has info on how to use SSH.

ssh allows you to access the command line/shell remotely.
Once connected it’s like having a normal command line in linux

OSMC has it enabled specifically so you can log into osmc via command line though a wired network on boot.

I plan on creating a detailed SSH tutorial in the future, but unfortunately I don’t have free time at the moment.
In the meantime do a web search for something like “beginners guide to ssh” or similar. Lots of generic tutorials out there.

Unfortunately that only helps you get into the box. then you need to configure X11, and that’s another learning process.
Especially so for the ATV which, unlike most other devices, has component, composite, and HDMI out.
HDMI and composite work out of the box, but in some cases the TV won’t respond with the correct info, so X11 can’t automatically choose the correct modes.

Are you currently using Component or HDMI for the Wega TV connection ?
I vaguely remember someone back in the Crystalbuntu days, having the same problem with an older Sony Wega TV.

I have both options for the RGB and HDMI, and during installation trials I’ve done they both displayed beautifully up until the reboot process and then I get blank.

I plan on using HDMI if doable.

Check my post above. I was editing it when you posted.

I think I was able to edit it. I shared my laptop’s internet using ethernet and did a remote connection. How do I save the new configuration?