Black Screen after stopping playback

Just had this happen for the third time. Nothing I can do except unplug to reboot. Different film each time.

On the latest update so it’s not that. Combined the the VC1 playback issues can’t say I’m impressed with it so far.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Can you check if the system is still accessible by ssh in that moment?

Sorry bit of Kodi noob. Could you explain a little, “ssh”

If I didn’t know any better I would say it’s a hdmi handshake issue. I get the odd flicker and pink blocking colour occasionally when stopping while it changes resolution… Seems like it’s struggling to handshake. I have another cable which is the same.

Its a shame as I like it.

I have enabled event logs so I can upload something next time it does it

Set up is xmc processor into neet hdmi extender over cat 6 to Panasonic TV. All other sources are fine so it is an issue with the vero 4k.

One thing I have noticed, when I applied the hotfix for the VC1 issues there was already hotfix text in there. Does that mean this is a recycled unit not a new one.

SSH is a protocol to access the command line of OSMC via your LAN eg from your PC.
See Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Well that could be an EDID reporting issue. I suggest you get access via SSH and compare EDID before and after.
cat /sys/class/amhdmitx/amhdmitx0/edid

No worries, by default there is something written in that field

Thanks for the replies and the links. I’ll have a go at this ssh stuff then.

A workaround for now is to just set the refresh rate to 23.98 for the display as then it doesn’t change when you play most films and also the same when you press stop. It is also a bit quicker as a result.

That sounds like your setup is struggling with Adjust Refresh Rate option. Try disabling it and seeing if it helps.

No — it’s there as an example. We don’t send any second hand units. When your device was first powered it should’ve prompted you for country, time zone etc as it was a new device

Thanks I’ll see how it goes.

I’m still getting this problem from time to time. It’s a bit frustrating and seemingly just a problem that can’t be fixed??

Really should have returned this within the timeframe. I wanted something reliable the kids could use without asking me how to fix it when the black screen of doom appears. Cycling the inputs on my processor does fix it but it’s the only device I have with this issue.

I guess I better try and learn how to do this reporting stuff. I’ve followed the above and got the Edid info, but it’s fine now, I take it when I get the black screen I need to do it then? The copy/paste it here for someone to comment on?

IIRC, we didn’t get any logs so didn’t get a chance to look in to this further.

I don’t think it’s a common occurrence as we haven’t got other reports of it.

Can you let me know what I need to do to reproduce the problem?

I trust you now find VC1 playback to be fixed

Sam

Yeah sorry a bit new to this logging stuff. I’ll have a read on how to do it and submit something.

I can pretty much get it to do it regularly so when would be best straight after it has failed the handshake? Would the log show this?

I’ve created a sequence for the Harmony so I can just get it to switch inputs wait a couple of seconds then switch back. Fixes it every time.

I’ve set up my display at 1080p 50hz. The black screen happens sometimes when starting a 24p film and other times when pressing stop. Ie changing refresh rates. Disabling auto adjust frame rate is not an option, as I want 24p to be 24p.

Don’t know if this is any good:

https://paste.osmc.tv/ gepogidova

Would be grateful if someone could have a look at the above.

Not sure if it’s linked, or if it’s another issue. Rewind and Fast forward rarely work. The time bar on the bottom goes forward and back but when I press play nothing happens. The same image remains on screen throughout the rewind/ffwd and play. The time does change as if I press stop then play again it asks if I want to resume at the correct rewound/ffwd time.

Rewind and fast forward don’t work mostly as it requires lots of throughout in your network and extensive buffering… Especially with higher bitrate files this will cause problems.
Better use skipping with the arrow keys of the OSMC remote. That should resolve issues related to rewind/fast forward.