Black screen blinking with video files | Rpi2

Hello,

I have such installation:
[OSMC/RP2] <-> Onkyo amplifier <-> Epson projector.

All connected via HDMI cables.
I take into account that it could be problem with amplifier, but for now I think it is OSMC problem, because Onkyo is working well with satellite receiver without any black screen blinking.

For about a week I have problem with playing videos.
Video playback is ‘blinking’. I play video and after about few minutes (I cannot find any rule yet) screen is going black, Onkyo showing that it doesn’t have any audio input (it looks like kodi is disconnected, normally onkyo showing something like DTS etc.), projector going black and after 5 seconds everything is reconnected and playing ‘normally’ to next time error occurs.

Example video: youtube-dl -f mp4 Pearl Jam 10-16-2014 Detroit Mi Full Show Multicam SBD Blu-Ray - YouTube

Thanks for any help.

In kodi.log I have (for other movie):
http://paste.osmc.io/jeledifaci.coffee

This was start of video, and during playback I have a lot of:

22:00:36 1879.240234 T:1370485792 DEBUG: CDVDPlayerAudio::HandleSyncError - average error 20396.749697 below threshold of 50000.000000
22:00:36 1879.240479 T:1370485792 DEBUG: CDVDPlayerAudio::HandleSyncError rr:1.00118 error:20.397ms

Losing HDMI sync is usually a result of low voltage from your power supply.

Have you tried going back to normal overclock if you are on Turbo ?

Have you tried a different power adaptor ?

You could try increasing config_hdmi_boost for example to 7.

Thanks for reply!

I haven’t tried anything you mentioned, so now I will.

My /boot/config.txt just for sure everything is ok:
overscan_top=16
overscan_left=24
overscan_right=24
config_hdmi_boost=7
hdmi_edid_file=1
start_x=1
sdtv_aspect=0
overscan_bottom=16
gpu_mem_1024=256
disable_overscan=0
hdmi_force_hotplug=1
hdmi_drive=2
disable_overscan=1

For 3 days with config_hdmi_boost=7 everything is working.

For now I can say it is solved.

If you need to use a high config_hdmi_boost setting then the root cause is usually either low voltage from the power adaptor, (this might only happen under heavy CPU load thus making it seem intermittent) or the HDMI cable is too long or is poor quality. (Or you have extra passive devices in-line like a passive HDMI switcher)

With a good power adaptor and HDMI cable increasing this setting is usually not necessary.

I have original Rapsberry Pi2 power supply 2A - http://www.modmypi.com/raspberry-pi/accessories/power-supplies/raspberry-pi-universal-power-supply-5v-2a

I don’t thinks that Onkyo amplifier is passive switcher but I have such connection

[OSMC] <— 0,5m HDMI —> ONKYO <–10m HDMI–> Epson projector