Black screen for 10s after playback is started


I’ve updated my Kodi to v19.1 recently (few days ago). Since then I’m experiencing that after I start playback of video or Live TV, screen turns black for 10s withing the first 1-2s after I start the playback.

Note: this does not happen for all videos. So far I’ve not been able to figure out if it’s related to resolution or file format of the video. I would suspect it’s rather related to resolution, since it also happens for live TV.


Could it be the resolution change of the TV to adapt to the Video.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Is this live TV via DVB or IPTV? And does it affect broadcast SDTV or HDTV or both?



Is this live TV via DVB or IPTV? And does it affect broadcast SDTV or HDTV or both?
TV via DVB.
Can’t really tell if it’s related to SDTV or HDTV. Some SDTV work, some HDTV don’t.

FWIW: screen is also clipped during playback mode of “low” res material.

That most likely is overscan wrong setting on TV. Check for just-scan or 1:1. If you let us know your make and model of TV we can check the right mode

I wonder why you set your GUI to 1920x1080 @ 30p normally it would be set to 1920x1080 @ 60p or 1920x1080 @ 50p

In terms of your playback issue maybe @grahamh has an idea. Here is some part that wondered me

2021-08-12 16:25:41.322 T:2609     INFO <general>: Display resolution ADJUST : 1920x1080 @ 50.00 - Full Screen (28) (weight: -0.000)
2021-08-12 16:25:41.322 T:2697    DEBUG <general>: OnAVChange: CApplication::OnAVChange
2021-08-12 16:25:41.333 T:2609    DEBUG <general>: ------ Window Deinit (DialogBusy.xml) ------
2021-08-12 16:25:41.386 T:2634    DEBUG <general>: CEGLNativeTypeAmlogic: Detected HDMI switch
2021-08-12 16:25:41.389 T:2629    DEBUG <general>: ActiveAE::SyncStream - average error of 12.006832, start adjusting
2021-08-12 16:25:41.389 T:2629    DEBUG <general>: ActiveAE::SyncStream - average error 0.006832 below threshold of 30.000000
2021-08-12 16:25:42.500 T:2842    DEBUG <general>: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-37956.514979, adjusted:-40000.000000
2021-08-12 16:25:53.331 T:2842     INFO <general>: CVideoPlayerAudio::Process - stream stalled pts:12.008 clock:12.038 
2021-08-12 16:25:53.341 T:2837    DEBUG <general>: CVideoPlayer::HandlePlaySpeed - audio stream stalled, triggering re-sync
2021-08-12 16:25:53.341 T:2837    DEBUG <general>: CVideoPlayer::FlushBuffers - flushing buffers
2021-08-12 16:25:53.344 T:2844    DEBUG <general>: CAMLCodec::Reset

It’s a Samsunt Q60T 85".

TBH, I also do not know why it’s set to 30p. I’ll set it to 60p.

fzinken is quite likely right that this is the player switching output resolution and refresh rate to match the video resolution and frame rate. It takes a while for the player and TV to sync up the HDMI signal again.

The standard recommendation is to set the Kodi desktop to run at 1080p/60Hz, and under Settings / Player / Videos / Playback, set “Adjust display refresh rate” to “On start/stop”. That makes 1080p videos be output as 1080p, and 4K videos as 4K, and also ensures that the output refresh rate matches the video frame rate. That all improves viewing quality, but you can get a few seconds of black during the mode change.

Assuming that is what’s happening, you can make sure you don’t miss any of the video by adding an automatic delay when there’s a mode change. Under Settings / System / Display / General, there’s a setting called “Delay after change of refresh rate”. Set that to however long it takes for the picture to come back, and you won’t miss anything.

1 Like

Also…if you are using an AV receiver and have the Vero plugged into that, the blanking out to match rates can take longer…another car in the train.

I may have made a wrong assumption @noap_ . During the blackout does the audio continue or does it go silent? If it goes silent, that’s normal for a mode change.

The sounds continues, only screen goes black.

Not sure if this is relevant, but I did not have this issue before the update to v19.1 (nothing else changed).

Should be something like fit to screen or fit and move set to OFF

Where do I find this setting?

Also, any ideas on how to solve the “black screen for ~10s” issue?

Based on the manual of your TV at Settings > Picture > Picture Size Settings

As you wrote the Sound continuous to play just no picture which means it is not the normal resolution switching duration. Is this problem actually the same of on all different kind of files?
Have you tried if it goes away when you enable audio pass through?

No, problem does NOT appear on all files.
Enabling audio passthrough does not change anything.

Anything else I can try?
Do you need more info from my side?

If you can find something the files which exhibit this have in common, that would be useful. File format? Codec? Resolution? Refreshrate?

I’ve set this “adjust screen size automatically” setting to off.
This did not change anything though, some videos - or at least the control and status bar - are still cut off.

Did you also reset all the image manipulations you did on OSMC?
How about other options on the Samsung? Can you take a picture of the menu as it seems different than what the manual writes.

I have a Samsung q70 and a Samsung nu8000, both are set to adjust to screen size ON and both work as expected. Both play uhd hdr correctly as well as other resolutions

Edit: set to off cuts the edges of the home screen off