Black Screen on HDMI

Device: Raspberry Pi 2 B
Installation media: microSD
Connection: wired
Power Supply Type: ?
Power specs: 5V 2000mA
Peripherals: TV or Monitor, Network
Storage Device (incl. Network Sharing Protocol):
OSMC version: 2015.08-1 (also tried older ones)
XBMC version: Kodi (15.1). Platform: Linux ARM (Thumb) 32-bit
Codecs: none
Audio/Video Output: HDMI
Overclocked: No
Config.txt Extras: hdmi_force_hotplut=1, config_hdmi_boost=7

Would post logs, but to be honest, i have no idea how to turn on logging via command line.

Problem: No HDMI signal - or better, no image on the TV. I only have a black screen.
I do can log in via SSH.

Tried different HDMI cables, a LG TV and two Samsung monitors. Tried hdmi_safe=1, config_hdmi_boost=4-7, set the hdmi modes by hand.

I can get the following informations (Done while connected to the TV, output on Monitors are simliar)

tvservice -s says:

state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

tvservice -M CEA says:

Group CEA has 15 modes:
       mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
       mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive 
       mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive 
       mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive 3D:FP|TopBot|SbS-HH
       mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 3D:SbS-HH
      (prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 3D:TopBot|SbS-HH
       mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive 
       mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive 
       mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive 3D:FP|TopBot|SbS-HH
       mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced 3D:SbS-HH
       mode 21: 720x576 @ 50Hz 4:3, clock:27MHz x2 interlaced 
      (native) mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive 3D:TopBot|SbS-HH
       mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive 3D:FP|TopBot|SbS-HH
       mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz progressive 
       mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive 3D:TopBot|SbS-HH

tvservice -m DMT says:

Group DMT has 5 modes:
       mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
       mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive 
       mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive 
       mode 35: 1280x1024 @ 60Hz 5:4, clock:108MHz progressive 
       mode 39: 1360x768 @ 60Hz 16:9, clock:85MHz progressive 

Also the TV seems to provide correct EDID information.

tvservice -n says:


If i enable monitoring of the hdmi port (tvservice -M), OSMC recognizes when i remove or connect the HDMI cable.

On the Monitor, i noticed that if i pull the HDMI cable, the monitor shows “no signal”. if i attach it again, it tries to find something on my HDMI but can’t and kinda goes to sleep mode.
HDMI inputs and cables work fine with my PC… so they should not be the problem.

I had it working once about a month ago when i got my Raspberry pi 2 - the next time i wanted to power it on, it did not work anymore.

Funnily, the same happened with my old Raspberry B+ (1) when updated OSMC about a month or so ago…

Any help?

Some logs:


Edit 2:
new kodi log:

try xbmc-send --action=“ToggleDebug”

Thanks. kodi.log now shows a bit more:

//edit, journalctl:

Can’t see anything wrong with any of the logs - as you say, it is correctly detecting the EDID too.

So you don’t even see the blue OSMC splash screen ?

You say you have tried older versions of OSMC and they also did not work - do you mean you re-imaged the card ? When you did so, did you see the installer screen (with the progress bar) at all ?

You’ve already tested everything pretty thoroughly, my guess is you have a hardware fault. Have you tried a different power adaptor in case the power adaptor is dying ?

Other than that it could be the Pi itself, such as a damaged HDMI socket…


No, i do not see any splash screen. nothing. (not even the colored splash screen - just nothing.

Yes, i did a new install with the osmc installer. Did not work and i did not see anything.
I remember a month (or two?) ago, i tried it. had the same problems and somehow after XXX attempts i came to the progress bar. set it up and when i wanted to boot it up again i could not get it bootet (again, black screen).

i try for days already and can’t even get a single image on the screen now.

Well, i tried a second power adaptor - same thing.
I also tried with my Raspberry Pi 1 B+ which worked great with the old raspbmc - also worked with the first version of OSMC i tried (really don’t know if it was RC4 or the first official release). But this one now too does not work. Just shows a black screen like the Pi 2.

As both don’t work, i don’t really think it’s a Hardware problem.

Sorry, but I don’t see how it can be anything but a hardware issue. There are over 400,000 other users using the exact same software as you, and we don’t see similar symptoms to yours reported elsewhere. The software works, and it certainly doesn’t fail to do something as basic as display an image on the screen even during the installer…

You already said in your first post that you had a similar problem with your Pi B+ as well - what makes you think you don’t have two faulty Pi’s, or that something is in common between them ?

Have you been using the same SD card on both Pi’s or have you tried different SD cards ?

Only a process of elimination is going to find the cause of the problem but I can assure you it won’t be a software problem.

Might sound stupid, but have you tried a different hdmi cable? I know you said you tried the cable in other devices, but have you tried other cables in the pi? (dumb I know, but hey you never know)

the pi b+ ran without any problems with raspbmc for 2 years. would need to install it now to confirm it still does - may get around to this later today.

It also ran good with one of the earlier versions of osmc, but with the new osmc version both don’t. of course you could be right that both, the 2 year old pi b+ and the 2 month old pi 2 B could be damaged - i just doubt it… especially on the same time.

I have two different SD Cards.

Yes, of course. I tried 3 different HDMI cables.

You have installed the wrong version of OSMC in your SD card.

For the B+ you need to ensure you select Raspberry Pi as your device and not Raspberry Pi 2. Installing the wrong image will result in the device not booting



Of course I installed the Raspberry Pi image for my Pi+ and the Raspberry Pi 2 image for my Pi 2 B.

I both tried with the installer (windows) and manually with dd on osx.

//edit: And it DOES boot. I can ssh into it.

I was getting a black screen the other day, OSMC had booted and I could SSH into it.

turns out i hadn’t fully inserted the HDMI cable into the pi, took me an hour to figure out.

Could really be a hardwareissue with your raspberry. Also, what powersupply are you using? Someone stated that he had one that should be 5v but actually had an output of 6v what messed up his hdmi connection. So maybe you can try a different powersupply? Do you use the same one for your B+ and your 2?

HDMI Cord is fully inserted.

as power supply i use the one that came with the rspberry pi 2 from RS components.
on my Pi 1 b+ i use an older, different power supply, that worked for years aleady.

Also tried the old one on the n pi 2 and the new one on the pi 1

Did you measure them?
Do other hdmi devices work on the same port on the tv?

Edit: You didn’t power on the raspberry for a longer time before? Sounds stupid, but check for dust or corrosion that could lead to short circuits on the small pitch connections to the hdmi socket on the pi.

did not measure them, no.

On the TV no, but on my two monitors. My pc is connected on those hdmi ports and works flawlessly.

The second pi is 2 month old. But i checked, everything seems fine.

You could try to boot another distribution like raspbian. If that doesn’t work either, you can rule out osmc as the culprint and retrurn your pi for exchange after contacting your dealer.

isn’t osmc based on raspian?

If you can install a standard raspbian installation and it provides output that your TV recognizes, then we will know that your hardware is not broken.

On raspberry 1: yes
On raspberry 2: no (it’s mainline debian armhf)

Kernel, networkstack, drivers and other stuff is also customized.


had very little time but tried raspbian. same thing. will try again tomorrow or just try to get it replaced.

just baffles me that both died at the same time? and on both only the hdmi?