Black screen on Vero 4k after update

When I woke up this morning my new Vero 4k said there was an update available so I ran it. After getting done I had a black screen. I thought maybe it did a shutdown and not a reboot for some reason and did a hard teboot. Black screen again.

When I start it up (via power cable unplug/replug) I get please stand by, then splash screen, then maybe 10 lines of code for a few seconds then black. There are no GUI sounds, just endless black. If the light on the Vero is supposed to be lit, it’s not.

Last night I copied over the advancedsettings.xml, sources.xml and Thumbs13.db as part of a MySql shared library setup with MySql running on my older rpi3 box in another room. Not sure if that could somehow be involved considering it seems more likely the update killed it, but there you go. I am using NoxSilvo skin as I am on my rpi3. Both are running osmc builds.

Any help?

The update would not have changed your advancedsettings. I more suspect that the changes you made were not correct but you didn’t reboot so didn’t see the problem until the update caused a reboot.

A quick fix to get you running so you can try your changes again (ssh in to do this)

sudo systemctl stop mediacenter
mv ~/.kodi ~/
sudo systemctl start mediacenter

should get Kodi running again.

Do you have a 4K or 4K +. On the older model there was a blue power light. On the + there is no power light.

I will run those commands when I get home. It’s just so confusing. those three files are the only ones I copied over to the Vero 4K+. Previously the start-up console messages were three or four times as long. What from those files would cause such a quick failure of startup?

It’s hard to tell if Kodi is even trying to start. Normally we would expect to see a sad face if those files were the problem. My suggestion may help narrow down the problem. You may not even be able to ssh in depending on where things are failing. So I decided to try the most basic test.

And if I’m unable to SSH, is there a recovery or reset protocol?

Let’s worry about that later if we have to :wink:

Fair enough. I’m prone to putting the cart before the horse. It just took me so goddamn long to finally get SMB working. I didn’t know until long after I’d been fighting with it that OSMC can share them automatically. Then I just had to mount the USB drive to the right folder and adding it via SMB worked to clear the way for MySQL.

By the way, I used the instructions here for the MySQL setup (using the updated commands several replies deep).

How about we get you running first, and then worry about getting MySQL working :wink:

Launch successful!

Details please? Did moving .kodi get you running?

It did. When it booted back up I installed SMB from the OSMC app store and kicked it down to SMBv1 and rebooted. Was able to navigate in Add Videos through SMB to my library share on rpi3 osmc box. Any interest in helping me figure out where I went wrong with my MySQL escapade?

Instead of doing that here, start a new thread. That makes it easier for others later to find problems.

In that thread, show your advancedsettings.xml, and explain again what you did for MySQL.

Roger. Thanks!