Blank green screen on HDMI

Just turned on today, no updates or changes I’m aware of and the HDMI output of my Vero 4k just shows a blank green screen. Tried changing leads, inputs and forcing different resolutions - no difference. Image is OK when booting - BIOS splash and blue background OSMC loading, but as soon as kodi starts blank green screen. Can also see the debian shutdown sequence text after kodi exits on a reboot.
Logs at

Can you try and move your Kodi user data directory?

systemctl stop mediacenter
mv ~/.kodi ~/.kodi-backup
systemctl start mediacenter

Just tried along with a reboot for luck, no difference.

Something odd is happening. Your TV says it supports 1080p but the HDMI clock is not fast enough for that. What’s the TV make and model?

How were you ‘forcing different resolutions’?

It’s an old one… Wharfedale LCD42F1080P. It’s a rebadged LG if memory serves me correctly.

When trying different resolutions I was attempting the sudo fw_setenv hdmimode xxxxforce, sudo fw_setenv outputmode xxxxforce. I did make a visible difference to the blue background osmc boot splash but that’s all.

Just in case I’ve created a red herring in the logs by setting 1080P60, I’ve just reset it back to 1080P50 and tried again, no difference. I’ve put a new set of logs at at this setting.

Try 720p as a quick test.
Why did you force 1080p? Did you have problems before?

When I saw the green screen, and reboots and cable swaps make no difference forcing 720p was what I tried first just in case something was dodgy with 1080p. I forced it to 1080p only because I wasn’t sure how to undo the forcing to 720p.

Hack guisettings.xml. Where you see this:

<setting id="videoscreen.screenmode">0192001080050.00000pstd</setting>

change it to this

<setting id="videoscreen.screenmode">0192001080050.00000istd</setting>

Yes! 1080i in guisettings.xml ‘fixed’ it. Still don’t have a clue as to what went wrong though. The TV reports both 1080p & 1080i detected when they were set and i swear nothing was changed to prompt this in the first place.

I’ll have a look at the code to see if we can catch that. I’m pretty sure your TV is lying about supporting 1080p. Anything in the manual about that?

Manual’s long gone. Thanks Graham, and Sam. Excellent support as always.


I think actually something’s been replaced in your TV. Maybe the repairman didn’t know how to re-program the thing with the correct EDID.

Normally it shouldn’t be possible to get vero to send 1080p. If you set it in the GUI, you will get the green screen which should time out and return you to 1080i.

Not sure how it happened.

“Wharfedale LCD42F1080P”… LCD 42" 1080p ???

I’d venture a guess it’s more likely that some of the circuitry inside of that old TV is knackered.

I think his EDID is corrupted.
There’s actually a fix from AML regarding this.


 * Actually, in some old televisions, EDID is stored in EEPROM.
  * some bits in EEPROM may reverse with time.
  * But it does not affect  edid_parsing.
  * Therefore, we consider the RX edid data are all correct, return "OK"

Typical AML bodge (upstream 99b2d80093974867644c584a359463000963f2a0)