Blu-ray structure playback on Alpha 4


Does OSMC support playing back blu-ray folder structures like RaspBMC did? I don’t get any indication that it’s trying to play - just nothing happens. The same Pi playing my blu-ray disc rips on RaspBMC worked OK.

The files are hosted on a remote server and accessed via SMB

This should work OK

Can you upload a log?


I believe that we are missing some libraries for this (libbluray)…?

You are right.

I have added this, so it will be in the next release:

Thanks, Sam :slight_smile:

I have this issue as well. When is the next release?

You dont have to wait for the next release, you can install the required librarys by running

sudo apt-get update
sudo apt-get install libbluray

Just use putty to the IP address?
What’s the login credentials?
Just trying to circumvent a lot of searching :smile:

Yes just putty to it both username and password is osmc

Username and password are both osmc

Brill. Thanks for your help.
I’ll give it a try tonight

Remembered I had access to the box from work.
Getting an error running sudo apt-get install libbluray
E: Unable to locate package libbluray

Did you run sudo apt-get update first?

I did

Double checked on my install now, the correct package is libbluray1, so run sudo apt-get install libbluray1 and it should work.

Update seems to have worked, Now I’ll have to wait until I get home to see if I can play the films. Thanks for your help.

That worked :smile:
Doesn’t seem to play wmv files though

Pretty sure you need the VC1 codec for that.

Did you buy the VC1 codec for your Pi and install the license code ? If not WMV won’t play.

Have now - will need to wait for the licence. Thanks