Bluetooth keyboard not working on kodi 17

Hi all, i write in order to have some feedback or help if possible… on my osmc install i updated kodi to version 17. From this update my bluetooth keyboard started not to work anymore in kodi. The keyboard is correctly paired and connected (tried many times) but in kodi every key has no effect. Also when rebooting the Pi3, closing kodi i can see in the text interface lines of strange chars ("@") as if the keyboard was writing in the console part of the os instead of working in kodi (but not sure about that). With previous version i had no problems, and the keyboard is indeed working in other environment eg retropie etc. Did you see some similar behaviour? Is there some setting i missed in the new version? Or missed some package to install or update? Thanks for reply.


logs may give us more of an idea whats going on.

You may have more success if try it from the command line.

DBMandrake posted some instructions sometime back, which look good to me. They can be found here.

If you are still having issues, the out from the commands; should give us more to go on.

Thanks Tom.

Thx for reply and pointing me the links. I tried with ssh but results seems the same: keyboard connected but no effect in kodi. I post my command sequence, i will check with logs, im not used to…

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun May 21 18:08:12 2017 from ipad-di-turio.local
osmc@TurioPi:~$ bluetoothctl
[NEW] Controller B8:27:EB:5F:BF:44 TurioPi [default]
[NEW] Device 58:71:33:00:00:2C Bluetooth 3.0 Keyboard
[NEW] Device 16:07:05:05:54:98 VR shinecon-5498
[bluetooth]# scan
Missing on/off argument
[bluetooth]# scan on
Discovery started
[CHG] Controller B8:27:EB:5F:BF:44 Discovering: yes
[NEW] Device 41:64:F0:7C:14:76 41-64-F0-7C-14-76
[bluetooth]# scan on
Failed to start discovery: org.bluez.Error.InProgress
[CHG] Device 41:64:F0:7C:14:76 RSSI: -85
[CHG] Device 58:71:33:00:00:2C Connected: yes
[CHG] Device 41:64:F0:7C:14:76 RSSI: -71
[Bluetooth 3.0 Keyboard]# pair 58:71:33:00:00:2C
Attempting to pair with 58:71:33:00:00:2C
Failed to pair: org.bluez.Error.AlreadyExists
[Bluetooth 3.0 Keyboard]# trust 58:71:33:00:00:2C
Changing 58:71:33:00:00:2C trust succeeded
[Bluetooth 3.0 Keyboard]# connect 58:71:33:00:00:2C
Attempting to connect to 58:71:33:00:00:2C
Connection successful
[CHG] Device 41:64:F0:7C:14:76 RSSI: -60
[Bluetooth 3.0 Keyboard]# info 58:71:33:00:00:2C
Device 58:71:33:00:00:2C
Name: Bluetooth 3.0 Keyboard
Alias: Bluetooth 3.0 Keyboard
Class: 0x002540
Icon: input-keyboard
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Human Interface Device… (00001124-0000-1000-8000-00805f9b34fb)
UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
Modalias: bluetooth:v04E8p7021d0100
[CHG] Device 41:64:F0:7C:14:76 RSSI: -70
[Bluetooth 3.0 Keyboard]#


Ok can see that the keyboard pairs and connects, will need full debugging logs; showing the failed output to the screen. To be able to advise any further.

Thanks Tom.

Ok, i guess i uploaded the logs following the procedure in my osmc… it is enough? Not sure about that… or should i pick them from sd somewhere and upload them here in some format to identify that they are related to this post. Thanks for your attention.

I activated the debug as explained, then rebooted. Used the kodi remote app from my ipad to navigate and pair again the keyboard. This seems successful as usual and the bluetooth icon becomes blue. But no effect in kody with the kb… then i sent logs from myosmc program


When you uploaded the logs, it would have provided a url; please post here.

Thanks Tom.

Thank you.


20:10:39.990 T:1937765360 DEBUG: {'58:71:33:00:00:2C': {'alias': dbus.String(u'Bluetooth 3.0 Keyboard', variant_level=1), 'connected': True, 'trusted': True, 'paired': True}, '16:07:05:05:54:98': {'alias': dbus.String(u'VR shinecon-5498', variant_level=1), 'connected': False, 'trusted': True, 'paired': True}}

I keep seeing this it keeps connecting, then disconnects.



remove aa:bb:cc:dd:ee:ff (aa:bb:cc:dd:ee:ff being mac address of the device)

sudo reboot 0.

Then try and pair the device again.

Thanks Tom.

Hi thanks for your prompt reply. Well I will try later theese commands and will update. I would only specify that I had 2 bluetooth devices: the second is VR shinecon-5498 which is a gamepad. I tried to pair again this also: the pairing was succesful but not working (with previous version it was working), anyway the system automatically suggested me to configure it, probably it deleted the old config and now it’s working. I did not find anything similar to reconfigure a keyboard controller… So after activating the debug, rebooting, and trying to pair again the keyboard, I turned off the Shinecon, and my guess is that on the log the disconnection is relative to Shinecon pad. Moreover I selected pairing the keyboard with a custom code (since on my crt the previous codes were too small and unreadable…); anyway the pairing seemed succesfull and the keyboard icon icon became blue.

In the meantime thanks again for your help, will update command prompt results.

+1 @BobCratchett The codes are only there for a second or two - need to be readable and could be huge and ugly!

I’m not sure how and where these are displayed, or what is triggering their display. If you can grab me a screenshot, I’ll look at it and the debug logs posted to see what - if anything - we can do skin-side about it.

Codes are displayed on a text line in the upper right corner: the font size is quite small and elegant but on small or crt screens they become pretty unreadable. On android Tv i.e. the codes are big and take full screen size.
I’m sorry for bothering again, but I tried to remove and reboot, then reconnect all with ssh commands but nothing changed :frowning: … i tried also dist-upgrade which updated kodi 17.1 to 17.2 but with no improvement. The keyboard is definitely working with oher os on the same Pi, and the gamepad works as well as controller in osmc’s kodi. I noticed that in kodi (settings/input/peripherals) i can see only the shinecon gamepad and the CEC but not the keyboard… in myosmc bluetooth settings instead i can see both, and both connected … don’t know if it can be of some help or if it’s normal… am I the only one encountering this issue updating to kodi 17? :confused:



sudo hciconfig hci0 up

hcitool cc aa:bb:cc:dd:ee:ff

If you still can’t type:

hciconfig hci0 reset

Thanks Tom.

Thanks for the screenshot, I understand now what you’re talking about :slight_smile:

For me, the Bluetooth Pairing shouldn’t be displaying a non-modal notification (dialogNotification.xml) - which are, ideally, purely informational with no action required. Where action is required - even if that action isn’t within Kodi/OSMC itself - they should preferably be displayed in a modal dialog (dialogConfirm.xml), which will display until you, the user, dismiss it.

From the look of it, this notification is being generated by myOSMC, so perhaps @sam_nazarko knows whether we can adjust how the add-on presents this…?

Hi, just tried with hcitool… i had to give all commands with sudo, otherwise i got errors… unfortunately no change… it seems also that the keyboard is not getting the paring codes typing… i tried again to pair with bluetoothctl by hand, succesfully in the sense that the keyboard icon became blue and on the left part in myosmc, but not functional again :frowning: … i appreciate very much your help.


Have you tired for unpairing/forgetting the other bluetooth device. Pair the keyboard, then add any another bluetooth devices afterwards.

Thanks Tom.

The other day, my BT keyboard stopped working although it was connected. I resorted to a USB kb and that didn’t work either, so I re-booted. In that couple of seconds after the gui goes and you get to see a terminal telling you what’s going on I noticed several lines of the sort of characters you get when special keys on the keyboard are not interpreted properly by the OS. So the Pi was receiving keystrokes but not doing the right thing with them. By then it was too late to get a log, but my point is, could the problem we have here be somewhere other than in the BT stack?

Same here: when rebooting i can see the same effect of special keys… so I guess the issues could be related. I will try to unpair everything and then pair the kb only.