Bluetooth Plantronics headset : no sound & video freeze

#1

Hi all,

I have exactly the same issue as angry.sardine there: after the installation of a2dp, I paired my Plantronics headset to the vero4+ easily but I have no sound at all and the video freeze after a few seconds.

I already removed a2dp, installed it again, reboot several times Vero,… No joy.

What can I do? (and please, be very clear: I’m quite a noob and English is not my first language).

Thanks in advance.

#2

Run:

sudo apt-get remove --purge pulseaudio and reboot.

Sam

#3

Thanks Sam for your quick answer.

If I understand well, I have now no pulse and no a2dp. But if I’m able to pair my headset with Vero, the indicator is red : it fails to connect. And consequently I have no sound in the Plantronic s(but no freezing of the video)…

I tried to install again a2dp but it install also pulse with the same behavior as previously: pairing and connction successfull but no sound and freezing of the video after a few seconds.

Do you have another idea ?

Regards

#4

Bluetooth audio is still experimental. Can you try with another headset as a test?

Sam

#5

Hi Sam,

Good idea. I don’t have another Bluetooth headset but I tried with a smartphone (Sony Xperia) and a Bluetooth speaker (JBL Go).

With exactly the same results: without a2dp (after purge of pulse), unable to connect the device, with a2dp, able to pair and connect but no sound and the video freeze.

FYI, when I have a2dp and the device connected, the freezing happened only when the device is not only paired but also connected (aka switch on). The video unfreeze if I switch off the device.

Also, if I was unable to use the smartphone as a speaker, I was able to listen sounds from the smartphone to a hdmi connected speaker trough the Vero. (Sony -> Bluetooth -> vero -> hdmi -> speaker).

Regards

#6

You could try pairing via the command line using bluetoothctl which will show you more details about the pairing process.

#7

I sincerely think you should put “Bluetooth is experimental” in the blurb about the 4k/4k+ so that buyers are aware they can’t / may not be able to use their bluetooth headphones or speakers.

I have exactly the same problem as the OP, except with sony headphones. It works about 10% of the time and only after several reboots and several pairing / unpairing options. Freezing audio, screeching sound or no sound is usually what happens.

Despite all the good things the vero can do, this has been a problem for ages with no permanent solution. I had hoped with the recent big update that this problem will finally be resolved.

#8

Bluetooth isn’t experimental.
A2DP streaming is (which we don’t advertise at all)

A number of users are using Bluetooth remotes or games controllers without issue.

#9

Hi,
As suggested I tried connecting a Bluetooth speaker with the command line (after a pulse/a2dp purge): no joy. The pairing seems ok but not the connecting. And no sound at all.
One solution is to use a Bluetooth dongle provided with the headset. But I can’t: I use 1 USB port for the remote and the other for an external disk.
To sum up, I’ll continue with a jack connected headset. Thanks for your time, and if you plan modifications, I’ll be happy about it.

#10

You changed the audio sink after connecting?