Unable to connect Vero 4K+ to Bluetooth device

#1

Logs: https://paste.osmc.tv/izuxijojof

I’m trying to pair my Vero 4K+ with a Bluetooth device. It’s an add-on for my hearing aids called an “easyTek” - but as far as Bluetooth devices are concerned, it functions simply as a Bluetooth headset. It works fine with my phone and with several other devices.

But it won’t pair with the Vero 4K+. If I try “connect without PIN” it simply says “connection failed”; if I try “pair using PIN” then it does add it to the list of known devices, but it still says “connection failed”, and the icon quickly turns red.

Bluetooth Plantronics headset : no sound & video freeze
#2

Did you install the a2dp package? sudo apt-get install a2dp-app-osmc

#3

I hadn’t. I now have, and it appears to have paired the device successfully, but I’m not actually getting any Bluetooth audio when I play a video. Is there anything else I need to do to activate it?

(Do you need new logs?)

#4

Change the audio output device in Settings -> System -> audio

#5

Okay, I changed the Audio output device to “Playback/recording through the Pulse audio sound server”. I do now get an indicator LED on the easyTek suggesting a Bluetooth connection, but I’m still not getting any actual sound.

Also, the video keeps freezing, which it wasn’t doing before.

Some fresh logs: https://paste.osmc.tv/pogopedihi

#6

Maybe try to reboot. Basically in the current setting OSMC should automatically switch audio to the headset when it is connected and back to HDMI when you disconnect (switch it off)

#7

I tried rebooting. No dice. Also tried setting number of audio channels to 2.0 Fixed rather than 7.1 Best Match, and fiddling with a few other audio settings, all to no avail.

As the video becomes completely unwatchable with the Bluetooth device connected - picture keeps freezing for several seconds at a time - I’ve had to turn Bluetooth off for now, but if you want me to test anything else, let me know.

(The last logs I posted were taken during a video freeze).

#8

So I assume with your headset switched of but audio setting unchanged the video play well?

This sounds like pulseaudio hanging.
Maybe @sam_nazarko has an idea. More next idea would be in the case of a hanging video (with bluetooth headset connected) connect via SSH, check the PID of Pulseaudio and sent a kill -9 <PID of pulseaudio)

#9

How do I do that? :slight_smile:

#10

ps -aux | grep pulseaudio the nuimber after osmc is the PID

#11

Hi,

Coincidentally I was just wondering about outputting audio from the Vero 4K to my Anker Soundcore 2 speaker, and found today’s thread.

I’ve installed the a2dp package, and rebooted. In settings, audio output had been automatically changed to “Playback/recording through the Pulse audio sound server”.

Unfortunately the Anker speaker isn’t making a connection, as shown by the device’s blue led continually flashing.

I cannot locate any option to initiate pairing in the osmc settings. Rebooting with the speaking in pairing mode didn’t help.

This speaker has bluetooth 4, and works fine with my ancient Galaxy S2, my Raspbery Pi 3, Galaxy Tab E, and Esinkin bluetooth to 3.5mm receiver.

Any help gratefully received.

YouTube playback - random blank video with 'input not supported' monitor message
#12

It’s in MyOSMC -> Connections -> Bluetooth.
If that fails than go via command line using bluetoothctl

#13

If I execute that command repeatedly during playback, I get a different number after the osmc each time. And trying to kill any one of them with kill -9 gives me “No such process”; tentative conclusion is that the process is continuously crashing and restarting, and this is somehow connected to the video freeze.

#14

Looks like that. Maybe upload new logs with the respawning visible. Maybe @sam_nazarko has an idea

#15

Is that not visible in the last logs I uploaded (post 5)?

#16

Didn’t see a spawning of pulseaudio in that log

#17

@fzinken Try https://paste.osmc.tv/qokorohewu

#18

Hi,

Thanks for the assistance.

No joy via My OSMC, but partial success using bluetoothctl.

issuing ‘scan on’. The speaker is found, and its MAC displayed.

Issuing ‘pair [mac address]’ works, and triggers the pairing confirmation sound from the speaker.

‘trust [Mac address]’ also succeeds, however
‘connect [Mac address]’ fails

Attempting to connect to 08:XX:XX:XX:XX:41
Failed to connect: org.bluez.Error.Failed
#19

You had successfully installed a2dp and rebooted?

#20

Hi,

Yes to both