Bluetooth stopped working - "no default controller available"

#1

All of a sudden my bluetooth stopped working.
If I enable bluetooth, the start/stop detecting is always on and doesnt find any devices.
accessing the vero via ssh on putty, command [Bluetooth]# scan on and [Bluetooth]# devices gives as response: “no default controller available”
i searched on the forum and on google for it, didnt find any answer.
i dont know if there has been an overnight update or anything. i dont have backups activated.
normally i have my logitech harmony connected via bluetooth. no other device gets discovered (mobile phone, tv…)
i can control the vero with the harmony remote via CEC of the TV, but that doesnt work as nice as direct connection.

anyone having an idea what the issue and possible repair solution could be?

thanks

#2

Vero will never install any update without a user confirmation.

Logs would likely be useful to determine what the cause might be before throwing random ideas out.

#3

never? even with automatic updates activated?

here is the log

https://paste.osmc.tv/wefibuvumi

#4

You will always be prompted to accept or refuse any available updates, no exceptions.

#5

any idea? help would be appreciated…

#6

Can you see WiFi networks under My OSMC?

#7

No I don’t.
I can only see the menu point for wired connection

#8
#9

I dont need the wifi… I need the bluetooth to work (see initial post)
Thanks

#10

The proposed solution should be relevant for wifi and Bluetooth. Give it a go.

#11

Ok… I will

Even if that command line doesnt mention bluetooth?

sudo rm-rf /var/lib/connman/ethernet* & sudo rm-rf /var/lib/connman/wifi*

#12

Hi,

Yes Connman controls, ethernet, wifi and bluetooth. So clearing connmans settings, should resolve the issue.

Thanks Tom.

#13

WiFi chip may be faulty. I would recommend reinstalling and if that fails to open a ticket

#14

i just tried the connman controls, i get the response:

sudo: rm-rf: command not found

#15

rm -rf

there is a space inbetween

#17

ok, now i did as proposed with no error message… reboot done…
problem still existing :frowning:

#18

I suggest try Sam’s advise

#19

how do i reinstall on a vero 4k+?

#20

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

#21

I tried a fresh reinstall. didnt help.
wifi not available and bluetooth doesnt start discovery.