Bluetooth trouble after latest update, 5 seconds until the Vero 4k is responsive on Harmony actvity start


#1

Hello

Unfortunately after the latest update, my Vero 4k will have to wait 5 seconds to be responsive after I start my Logitech Harmony actvity. This problem was once solved many months ago and now it is back.

But now it is actually worse because it happens every single time. The harmony hub has no problem with other decices, so I am pretty sure it is not the fault of the hub. It is just that the bluetooth pairing again takes an eternity…

This is very very annoying… and no, using IR is no option, this is 2018 and not 1978…


#2

Hi,

This is interesting. The Bluetooth firmware was updated in this update.
Maybe re-pairing will help this. Do you remember what you did before to resolve the issue?

Sam


#3

I already tried everything, repairing, different bluetooth adapter… no help

Actually I never changed anything, after an prior update, it just vanished… and now it is back.

It‘s just like the Vero 4k is unpairing when the activity is closed in the harmony… and needs repairing when the harmony starts the activity… I actually see that if I end the harmony activity while watching the bluetooth options under myosmc… before I end the activity, the pairing is obviously active… after ending and restarting the activity, the pairing is inactive, 2-3 seconds later it becomes active and another 2-3 seconds later the Vero 4k accepts any input.


#4

I’ve got a Vero 4K setup paired with a Harmony Hub as well. After the update to our July update, everything’s as it has always been before: When I had the OSMC activity activated before, the Vero is responsive immediately via Bluetooth. If I had e.g. my PS4 activity (also using Bluetooth) active before, it will take the mentioned 5 seconds to repair with the Vero before it’s responding.

The 5 seconds are not always occuring here… Just after switching from an activity which also uses Bluetooth. :man_shrugging:t2: Thus it can’t really be a general issue.


#5

Yeah that was what it was before, 5 secs delay when switching between another activity with bluetooth… but that problem actually vanished for me months ago, I could switch between the Vero 4k activity and my Aplle Tv 4k activity without any delay whatsoever… but now it is always a 5 second delay on the Vero 4k, even if I don‘t use another activity in between… :frowning:


#6

Hm… Very weird. The 5 seconds between different activities have always been there for me. Would be nice without, but that’s a hub issue from the looks of it (it also takes 5 seconds to pair with my PS4).
It all sounds like there’s something going on with your hub and not the Vero. At least from a logic standpoint :thinking:


#7

Yes it is strange. It seems to me, that „somehow“ my Vero 4k always was able to hold pairing, no matter what I did with other activities… because the repairing process is just sloooow on the Vero 4k, right? So the only explanation dor not having a 5 seconds delay is that the pairing was always intact… but how and why it is not anymore, no idea.


#8

Well, to my knowledge, the Harmony Hub can’t keep up pairing with more than one device at a time (it can remember more than one paired device of course). So, that part is already very weird. Pairing on the Vero is not abolutely light speed fast, but the re-pairing with my PS4 takes about the same as I mentioned.
As your Vero 4K/Harmony Hub setup are and have been behaving differently, it sounds less like a Vero issue, but might we have different Harmony hub itterations? There are different ones, I’ve read, but on the other hand, they shouldn’t be different when it comes to the hardware, I suppose. Maybe a different firmware version?

Can you check which firmware version your Harmony Hub is running on currently?
Mine is running on the 4.15.119 firmware.


#9

I have 4.15.193… and I am starting to believe that it might indeed be the hubs fault… it seems it has been updated as well recently, considering I have a higher number than you.

It is an annoyance but not really terribly bad. I will check logitech boards if there is indeed a pronlem with the hibs software.

I just only saw the Vero 4k update and nothing else and did not change anything else as well, so my first thought that the Vero update brought back the delay…


#10

Then the Hub’s new firmware could indeed be the culprit here. To test, I could update as well… But honestly, I wouldn’t like this behaviour to start here as well. Maybe someone like @Smurphy can shed some light on this? He has a Harmony Hub setup as well… Which firmware version are you on, @Smurphy and do you experience the same issues?


#11

Fcking Logitech, it was the new firmware on the hub… I did the suggested steps for a recover and now it works as before.

Sam, I am terribly sorry… I hate people who bother you with problems, that are in no way your fault… and now I did this as well. And thanks to Wuschel for pointing me in the right direction.

Problem solved, if any people discover similiar problems, maybe the information here helps…


#12

Did you downgrade the hardware or was it fixed after a restore to the same firmware version?
Just asking, if the same behaviour could show up after a firmware update of my hub as well…


#13

I guess it was a downgrade, though it depends on how you interpret my new firmware number, which is 4.15.96… 96 is lower than 193 but it seems odd that it now only has two digits at the end.


#14

Very strange… It’s probably a restore to the firmware it came with from the factory.
I’ll better leave my Hub without an update for now :sweat_smile:


#15

My Harmony bluetooth also stopped working. Could you point me to instructions to downgrade the firmware? Thanks.


#16

I just googled it… used the description here:

https://community.logitech.com/s/question/0D55A000073ZTpxSAG/downgrade-harmony-firmare


#17

Out of curiosity: Is your Harmony Hub’s firmware also version 4.15.193?


#18

Yes


#19

This is very strange. Last night I couldn’t get the remote working and now it “fixed” itself over night. I’ll report here if the problem reappears.


#20

Has there maybe been a firmware update during the night? :see_no_evil: