Bought a 2nd Vero4K, can't browse


A couple of months ago I bought myself a second Vero4K device since I am so satisfied about the first one I bought and wanted one for my other TV as well. :slight_smile:

Since I got it (and I have updated it with every new update since arrival) I still haven’t been able to browse properly on my network with it. I have the same settings both in Kodi/OSMC and for the network (not same IP obviously) as my first Vero4K, as far as I can see.

The issue comes when I browse on my SMB-network and go inside of my “Workgroup” and try to enter my Windows 10 fileserver to reach my shares there. Instead of getting a list of my shares on that machine I get an error message which says in the subject “Error” and the actual message says “Operation not permitted”.

Thing is that I do not have any issues reaching shares on other devices such as a small Seagate NAS for an example. I’m thinking that something is wrong on my fileserver but why doesn’t my first Vero4K, a few Raspberry Pi’s (with OSMC and LibreELEC) and my Windows och Apple laptops have any issues reaching my fileservers shares then for an example?

I’m completely confused here and can’t find what’s causing this, from some points of views I would like to blame my second Vero4K since that’s the one which has the issue so to speak. At the same time it doesn’t feel completely logic either and I work with IT and ain’t a noob. Still I can’t figure this out. :slight_smile:

I have tried to reinstall the second Vero4K as well, by the way.

Could there be some new “hidden(?)” settings in Windows 10 that arrived in some update earlier that prevents new devices, who hasn’t already got to know the Win10-fileserver kind of, to reach the machines shares? Since all my “older” devices I listed above don’t have any issues like this with this machine.

So in short: My second Vero4K can see the Win10-fileserver on the SMB-network but once it tries to enter it to list the shares it gets the error Operation not permitted.

Lot’s of thanks in advance to whoever that could help me solve this!

Kind regards,

If you want to access the same shares on both units, I’d just take a backup on the first device and restore it to the second device.

Are both devices up to date and running 2017.10-1?

Restoring a backup will prevent you needing to re-add sources and also ensure your SMB settings are identical on the new unit. If browsing then doesn’t work, then something’s up.


Hi Sam!

First of all, thanks a lot for an incredible fast reply, as usual! :smiley:

Yes, both my Vero4K devices (as well as two RasPi devices with OSMC) is running 2017.10-1 which is the latest version as far as I get it.

I understand that if I restore a backup from my first Vero to my second I will then get an identical setup on both of them and since the first work as it should then the second one should as well after this manouver. If not then we know that there isn’t some setting somewhere on the second which is causing the issue. Is this the troubleshooting plan you are thinking about here?

I will for sure try this and get back with the result. :slight_smile:

Could my issue be a common or at least known one (I get that the reason for this issue could be more than one though)? I’m wondering since I have tried to Google on this issue and have run in to several similar cases related to Kodi and issues with browsing SMB-networks. None of them fitted exactly my situation, unfortunatly.

Thanks again!

No – haven’t really heard of the problem where one device works and the other doesn’t.

There were SMB changes over the Summer due to vulnerabilities discovered in SMBv1. But if both devices are up to date with equivalent settings, then they should both work.

Let us know how you get on.


Hi again!

No success unfortunatly. :frowning:

Still can’t browse like I described earlier and I can’t even start a movie from the library I also got restored/imported from the old/first Vero4k (nothing happens when I try to play a movie).

I suppose that you meant that i should backup and restore from the “My OSMC” → “Updates” → “Manual Controls” → “Run Backup of settings now./Restore a backup of settings now.” ???

I did like above to and from a USB flash memory. I selected to restore “Everything” and to “Overwrite existing files”. I got some error in the end of the restore though. “Some items failed to restore. See log for details.” Though when I go to the “Eventlogg” under Kodi System/setting there aren’t any logs except for one that says “Kodi started successfully” and I have enabled all log-settings so to speak.

Also I tried to enable “Reset Kodi on next reboot” and the rebooted before I restored the backup, just in case. I’m not even sure this reseted all settings and stuff either because for an example it still had an addon I had installed from the repository and it still kept the device name under “Settings/Services” but the reset maybe doesn’t reset exactly everything?

So what now? :frowning: Any other suggestions? :slight_smile:

Kind regards,

We need to see the logs then.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Restoring a backup won’t delete any addons
Device name is set from the hostname, it’s not a Kodi setting. This can be configured via the command line, or when you first set up your OSMC device via the walkthrough.


I understand, well it’s getting late here so I will get back to this troubleshooting and logs tomorrow evening.

But it does say in the description about resetting, when you enable to reset at the next reboot: “Warning: This will delete ALL user data in Kodi; skins, addons, databases, settings, …” So according to that alla addons you have installed yourself should be deleted as well as far as I got it. :slight_smile:

Thanks again for your help so far and for your insanly fast replies. :slight_smile:

Kind regards,

I’m not familiar with exact details of the backup add-on as it’s been a while since I looked at it. I believe it only extracts over the current Kodi directory, but does not delete it beforehand.

Try it again tomorrow with debug logs enabled and we’ll be able to identify what the error was, and also advise why you can’t access your shares.


Hi again Sam!

I’m not sure if I’m stupid or not here but I’m not sure if I get how to upload the logs here even though I read your link above.

First I made sure that I had enabled all logging under Settings–>System–>Logging and rebooted the Vero4K.
After it had rebooted I tried to browse my SMB-network and to reach my shares without succeeding, as usual on this device.
Then I went to “My OSMC”–>“Log Uploader” and enabled “All Configs and Logs” and choose “Upload Selected Logs Now”. It then went on and uploaded stuiff it seemed and at the end gave me the message “ < html >”.

Have I uploaded the logs now, I guess not but if so to where? I went to “” on a computer but obviously it was empty.

So what is it I do not understand here? :frowning:

Lots of thanks in advance!

Kind regards,

Are you behind a proxy?
Is your device definitely up to date? Maybe try reinstalling OSMC on the problematic device

Try a reboot and uploading logs again



I’m behind an Asus router.

I updated both my Vero4K today to 2018.12.1 which you released last night (a great update btw!).

I have tried to reboot once more and upload the logs with the same result. :frowning:


I have reinstalled the problematic device before during my own troubleshooting but I guess I could try it once more, with the latest version and so on.


Do not enable all logging options. Only enable debug logging.

I downloaded the installer for Windows and started it. I followed the guide through: English, Vero4K, 2017.12-1, “on an SD card”, I choose my SD card Q: 32GB etc, check the “I accept…”, it ask me i I want to re-download the image and I klick “yes”.

Right when it is supposed to start downloading the image it gets an error"An error occured extracting the archive! Please consult the logfile." and it’s on 0% as well btw.

I also tried older images but that didn’t work either with the same result.

I do not get this, I haven’t had any issues with the installer before and on this copmputer too. I do not even now where the logfile in this matter are located.


I now resetted all settings on the Settings/System/Logging menu page and then only enabled “Enable Debug logging” as you said and rebooted. Then I tried to reach my shares again without succeeding and then tried to upoload the logs again with the same result as earlier. :frowning:


Try deleting the image locally, or downloading an older version. It will update just fine.

OSMC’s Pastebin will allow logs up to 10M, any bigger and you may get a problem. How big is Kodi.log when you try and upload?


Hi again!

I have tried to download any version of the image through the installer but get the same error as yesterday above, everytime. :frowning: I do not know what you mean with deleting the image locally, where is it then?

Ok, I think you are right about that the log I’m trying to upload is too big. I said earlier I resetted all logging-settings under Settings–>System–>Logging and then only enabled the top one. Still I couldn’t upload a log after a reboot, like before.
But when I went to “My OSMC” → “Log Uploader” and deselected “All Configs and Logs”, then I could upload a log with a working link but that log is obviously lacking and is pretty empty. So I then have to select some stuff under “All Configs and Logs” but what is relevant in my situation?


I now found the local images and the log file for the installer etc. and got the installer working as it should. I’m currently waiting for my problematic Vero4K to be done with reinstalling… :slight_smile:

Still need the uploading of the log sorted out as well as the original browsing issue of course.

Thanks in advance once more!


I now selected a bunch of the options under “All Configs and Logs” and then uploaded the log successfully and this time did get a bunch of stuff listed in the log. I do not know if all of what you need here is included, let me know if you are lacking some info in the log and I will try to include that too as well.

This stuff above I did after the reinstallation of the problematic Vero4K was done with the 2017.12-1 image and then once again tried to browse my “server” without succeeding now either before uploading the log as described above.

Thanks in advance once more!


22:25:02.375 T:3884970752   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://KONTOR-FILESRV1/'
                                            unix_err:'1' error : 'Operation not permitted'
22:25:49.958 T:4079596112   ERROR: GetDirectory - Error getting smb://KONTOR-FILESRV1/
22:25:49.959 T:4079596112   ERROR: CGUIDialogFileBrowser::GetDirectory(smb://KONTOR-FILESRV1/) failed

First thing: never use hostnames for SMB if you want reliable resolution. DNS on consumer networks is problematic. I’d be interested to know if using the IP works OK.

Are both devices connected to the network in the same way (i.e. both wired, or both wireless)?