Broadcom Crystal HD

Just got my hands on an Apple TV 1st gen and installed the Broadcom Crystal HD card. I am wondering if I will need to install the drivers for the Cystal HD or are they built into OSMC?

They are built in

Thanks was getting stressed because I have no idea of what I am doing! when I bought this box I thought it would be like jailbreaking other apple products, and I saw hacking it involving command scripts I got worried.

I did eventually try and made an error which erased a chunk of my computers OS! Anyhow fixed my computer and have waited for the Apple version of OSMC to become a reality, given my awful technical skills.

Once again thank you for your quick response.

No problem.

Herte’s a quick rundown of how osmc is installed:

There are Linux, WIndows, and OSX installers. The installers allow you to create a USB stick that can install OSMC.

When you boot the ATV1 with the USB stick that is created, it installs and launches OSMC.
Currently it only installs to the USB stick so your HDD install will not be affected

The OSX installer is not available yet, so it currently requires some technical skill to get osmc onto a USB stick in OSX.
Your may see posts on using the DD command. Done incorrectly, it will wipe the wrong drive.
So far I haven’t seen a good simple step by step instruction on how that works, so most people should avoid it for now.

if you are using OSX, I’d suggest waiting a short time for the OSX installer for ATV1 to be posted.
If you are using Windows. to install, it’s easy.

Just make sure you use a fast USB stick. I tested with a few old ones I had lying around, and they either wouldn’t boot, or were really sloooow.

Thanks! Will try it once again. Hmmm but maybe I will wait as Sam did mention that an installer was being worked about 15 hours ago.

I highly recommend Apple Pi-Baker for GUI OSX use.

Its all drag and drop. Its all nice and easy for OSX users.
Works with usb sticks as well.

1 Like

Hi. How can i know my Crystal HD card is working?. I just buy one and installed in my apple tv but doesnt show a menu or where can i see the card is working. Thanks a lot…Vincnet

Do you have OSMC installed ?

yes i just intall it

For now, you need a keyboard connected to test that.

To verify if CrystalHD is running:

  1. Play an h264 video
  2. While the video is running, hit the ‘o’ key on a keyboard. You should see ‘chd-osmc’ or ‘chd-h264-osmc’ on the screen listed as the decoder if it’s accelerated.

The CrystalHD card is only used for H264 format videos, it is NOT used for MPEG2 or VC1 videos.

If you don’t have a keyboard, an alternative is to play an 1080 HD H264 video and see how well it works.

Hi Spinner thanks for the help. I just have an issue. I can not get to play any video from apple tv with osmc. I just managed to add my network hd with movies and doesnt play any. Also try to install youtube pluguin, installs ok but when i put a Video it just reset to OSMC Main screen. I have the Apple tv connected by HDMI cable and resolution 1080p. I also remember that in the original apple tv settings i put RGB as the Video output. What i am doing wrong…Thanks a lot…Vincent. Note: I just Enter advance configuration and change Video decoding to software and All is working ok. So the card is not working at all or what can you think is the problem my friend. I just try youtube and Youtube still doesnt work with the software encode video setting.

Love to get to the “drag and drop” part but applePi- baker is asking me for a password and I have no idea what to put in the window!

Hi Sparked,

It’s asking your user password - the one you likely use to start your mac with - as it requires admin privileges to perform the usb writing.

It does sound like the card is not working. Can you upload a log file ?

It looks like I have a different login in my Keychain access than what I use to login to my computer. I will solve that and then see if things work better. In the meantime has anyone stepped up regarding the OMSC installer?

You mean the official OSX installer ?

Yes I was humbly inquiring. My technical skills are not anyway near you or probably the vast majority of folks in this forum.

Ok I will wait because I have tried three, Mac Linux USB creator, Unetbootin, and ApplePi-Baker. The first 2 don’t recognize the image file and the last one does not see my SD card, and the latest version will not let me sign in! lol

The latest installer code is actually ready to go, but unfortunately the OSX build server is down.
When the server is back up they’ll compile/test it and post it for users.

It’s the very early stages of OSMC for ATV1 so you can expect some issues.

@ Sparked,
If you do not know your System Password for OSX on your Mac you are in for more trouble than just not being able to use Pi-Baker. I strongly suggest you find your OSX System password before you run into a lot more OSX problems than just this using this program.

1 Like