Buffering + CEC issue

I just received my 4k+ and right from the bat I can’t seem to play any videos properly without buffering. No matter if 4k or 1080p, it always buffers (4k more than 1080p). I’m playing my videos from my NAS. Playing them directly on my TV (which can only play properly with up to 30Mbit/s) wireless (5Ghz) on Kodi (without the Vero) plays all videos fine. So I don’t think it’s the connection or my NAS.

CEC issue was solved

The other issue is that I set the Vero up on HDMI 3. Now I changed it to HDMI 2, but whenever I start a movie, it automatically switches to the empty HDMI3?

Can someone help me out please? Thanks in advance!

Log: http://paste.osmc.tv/uhavilohor

Is the Vero using WiFi or wired? As with any support request, logs would help us.

For the CEC issue, try turning the TV off and unplug it from the mains for 5 minutes. That should reset the CEC info in the TV.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for the quick reply and sorry for missing information!
The CEC problem was solved, thanks for this.

I’m using Vero wireless on a 5Ghz connection.
Here’s the log: http://paste.osmc.tv/repajivide

The video you are trying to play is Hi10P. That is not supported on the Vero. Do a search on the forum here (Just search for Hi10P) and you will see plenty of information about why.

Also, you are using Kodi SMB mounts. That can be an issue. You would be better to use kernel based mounts via fstab or autofs. And if possible use NFS instead of SMB if your NAS supports it.

oh bad pick i guess, here’s another log with another video:

Is the Kodi SMB mount really a problem if my Philips Android TV can handle it just fine? Unfortunately my NAS doesn’t suppoert NFS.

Something else that I noticed was that my Vero update downloaded with only roughly 60kbit/s. I thought that it might be the update servers but could it be that the Vero isn’t getting the bandwidth it’s supposed to get? According to my router the Vero should be much faster,

Do you know how to use SSH to connect to the Vero?

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

After logging into the Vero, please share the output of:


Yeah I know the basics.
iwconfig wasn’t found. I’m using Windows and macOS. Do you have an alternative for me?

If you transfer one of those same files over the network to your PC what is the transfer speed and is it a straight line or does it go in fits and starts.

I forgot, it’s not installed by default:

sudo apt install wireless-tools

Then try iwconfig.

eth0      no wireless extensions.

wlan0     IEEE 802.11  Access Point: Not-Associated
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  invalid crypt:0  invalid misc:0

lo        no wireless extensions.

additional info: at 4k content it’s stuck at buffering for around 60secs until it starts playing again. And it only shows Cache 0% until it suddenly continues the video again.

With my Kodi Android TV it would at least buffer from 0% to 100% (if it buffered) in 5-10secs.

It’s pretty consistent at 35 MB/s

But you still have issues with buffering with 1080p content? Is there any way you can hard wire your vero to get around the issues with trying to play 4k content over wifi.

Unfortunately my cables are not long enough. But yeah, it buffers with 1080p content, which it never did with my Android TV Kodi setup (and still not if I switch to it right now).

Then perhaps you could try moving the vero temporarily where it may get a better wifi signal and see if you get an improvement. Wifi can be incredibly variable. Since your planning on playing 4k content I would highly recommend hard wiring it if that is at all feasible.

An fstab based mount should let you use WiFi and watch 4K content. See File sharing with a NAS, media server, windows share or other device


Mounting via fstab didn’t improve it at all unfortunately.

Did you checked your throughput with iperf3 over a longer time?

so I can’t do it with my hard drive but I did it with my Macbook while playing a video file.

with -R:
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-120.00 sec 487 MBytes 34.0 Mbits/sec sender
[ 4] 0.00-120.00 sec 487 MBytes 34.0 Mbits/sec receiver

So this is way too slow am I right? Also for 1-2 occasions it dropped down to sub 10Mbit/s for 2secs.

Now if I do it without -R (while still playing the video file):
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-60.00 sec 622 MBytes 86.9 Mbits/sec 3532 sender
[ 4] 0.00-60.00 sec 620 MBytes 86.7 Mbits/sec receiver

Yes that would not be enough for 4k and if it even drops sometimes below 10Mbit it might even not work for 1080p

So you either need to improve that (other channel, antenna relocation,…) or find a “wired” solution (e.g. Wireless Bridge, Ethernet over Power or underfloor cable).

I already tried to improve it by changing the channels. I bought the Vero for using the wifi and these semi wired solutions involve more costs, cables and power outlets.
But how can it be that my TV that has worse hardware and only supports 5Ghz with lower channel frequencies and support for 30Mbit/s per video file has no problems playing them wireless but my Vero has?