Buffering every couple of seconds

Hello,

So i’m pretty new to OSMC and raspberry pi, and i’ve got OSMC set up on my raspberry pi2 right now and i’m sharing my files over nfs. But everytime i try to playback a file it starts to buffer after a couple of seconds. I’ve tried checking if there was something with my network by connecting to the nfs share on my desktop but it played perfectly on my desktop. I also tried to change the buffermode to 1 but it didn’t change anything as far as i could notice.

Any help would be appreciated

A set of logs would be nice to identify the problem. Do you use wifi or cable?

Oh yeah sorry I use a cable, and here is a log from right when i started playing my file: log on pastebin.

Please provide full, un-edited, debug enabled logs. Simple instructions are in the following link.

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Oh i’m sorry for the misunderstanding, here is the full log. BTW some extra information it’s a fresh install with one addon(keymap editor) installed to change a button on my remote.

Have you tried turning off OMXplayer or MMAL player or both in advanced system video settings?

No I didnt try it untill now, OMXplayer was allready turned off and i turned MMALplayer off, but it’s still the same.

try omx player on? Does the same file play without issue from a locally connected thumb drive or copied to the sdcard?

I just tried turning only the omx player on and it’s still the same, I tried playing it back from the USB and it worked perfectly.

Next is to determine why your network is serving data so slowly. Maybe remove any switches between the pi and the router?

hmm yea, could it be the cable between the pi and the switch? because the desktop i tried to watch the nfs share on and where it worked perfectly is connected to the same switch.

I tried it with a different cable and it’s still buffering after a couple of seconds. Btw the pc running the nfs server is also connected to the same switch, and I would try and connect dirrectly to the router but i dont really have the means right now so i have to try in about 2 hours when I can move a screen to there for testing.

What’s the CPU doing on the PC you are running NFS on? What OS is it?

It’s on windows and it’s running at 20 percent but like I said it works just fine on another pc. :confused:

Windows? WHS or? Because NFS doesn’t run natively on Windows…

I’m using haneWIN nfs server.

Have you tried using SMB?

I tried in the beginnning with my first install but it was also buffering I’ll try again tho.

Hmm i can’t add my pc through SMB anymore it keeps telling me connection timed out. BTW I tested connecting my rpi directly to the router and it was still the same.

Some speed checks need to be done.

I have a suggestion, not sure if it is the easiest or the best
You have or you can setup an ftp server on your PC?
On the Pi you can install “mc” (Midnight Commander) on the command line with Putty
With mc launched press F9, select “Right” choose ftp link to your server and copy a big file and check if the speed/time is what it is supposed to be.

Other possible option is Youtube HD clip streaming.