Buffering on mkv 4K remux file playing from HD attached to Vero 4K+

While playing a 4K remux .mkv file (26GB file and movie is 130 minutes long) there are buffering issues making the movie experience very bad.

I have 2 HD-drives formated to ext4 attached to the OSMC powered USB-hub attached to the Vero 4K.
The Vero is connected directly to the TV through HDMI and using an optical cable to the S/PDIF connection to my A/V receiver.

I am running Aeon Nox: Silvo skin.

First time buffering started early during (after 4 minutes) playback. After a reboot buffering started some minutes later (after 10 min).
To create the logs I rebooted again and buffering started after 18 minutes.

Logs here: https://paste.osmc.tv/tamuquyeja

While typing this I am trying another file (60GB file/ movie is 135 minutes long) and now it buffers at 5 minutes.
I did not reboot after creating the above logs. But here are the new logs:

I really want to figure this out, because the main use of my Vero is to play these huge UHD remuxes.

Can the bottleneck be the USB 2.0 connections of the Vero?

I changed the skin to the OSMC skin and still have the same issues. Reading the logs I see that at the time of buffering there is mention of audio related stuff (or am I wring about that?):

Oct 20 11:25:07 osmc kernel: aml_spdif_dai: aiu 958 playback disable
Oct 20 11:25:07 osmc kernel: aml_spdif_dai: aml_hw_iec958_init,runtime->rate=48000, runtime->channels=2, same source mode(0), stream format=2
Oct 20 11:25:07 osmc kernel: aml_spdif_dai: set divider = 4
Oct 20 11:25:07 osmc kernel: aml_audio_hw: IEC958 16bit
Oct 20 11:25:07 osmc kernel: hdmitx: audio: aout notify rate 48000
Oct 20 11:25:07 osmc kernel: hdmitx: audio: aout notify size 16
Oct 20 11:25:07 osmc kernel: hdmitx: audio: hdmi_ch: 0 speaker_layout: 0
Oct 20 11:25:07 osmc kernel: hdmitx: audio: no update

Have you tried turning “adjust display refresh rate” to “start/stop”?

I have not touched that option. What is the default setting? I am now watching another huge remux and 1 hour in there is no buffering. I am getting confused :slight_smile:

After this movie is finished I will check the “adjust display refresh rate” option and try the two files I had issues with again.

The default setting is not optimal for you and is also giving you a less than optimal experience right now (ie your not currently getting 4k output).

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty)
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

I have the GUI set at 1080p.
Aren’t these settings visible in the logs I uploaded in my first post?

That bit after the first sentence is a generic reply. I could see your settings and I could see that you did not have the refresh rate adjustment on. With your current settings the file you are trying to play is 23.976fps and Kodi is having to fit it in a 60fps display and it can’t do that cleanly with a bitstream as it cannot modify the timing of that kind of audio. You are also not getting 4k output without changing your settings.

1 Like

Thank you very much for pointing this out!
I changed the settings to the above settings your provided and am checking now if the problem occurs again.

My TV now shows it is displaying 4K content as previous it did not. That makes me very happy now! And feeling a bit stupid as I only noticed this now :slight_smile:

Can you explain why when I previously looked at the stream info in OSMC while playing a movie it did state video stream was 3,840x2,160px and 60 fps while my tv stated it was playing at 1080p. Does that video info only state the info of the file that is playing and not the image it is outputting on the tv?

When the UI shows those details it is just stating what the file is. AFAIK Kodi does not have any way to show actual output in the UI. I think you will find your shows looking quite a bit more fluid now.

I will check the files that I had issues with later. But I can clearly see the difference in image quality for the movie I am now watching. 4K does make a difference :slight_smile:

It still is buffering…

I am wondering if it has to do with my HD or the USB-hub. I was able to play a big file without issues from HD one. But the two files hat buffer are from HD two. They both are the same type of HD and both are connected to the powered USB-hub I got from OSMC.

I am thinking buffering occurs because of slow transfer speed in stead of the Vero/kodi needing to work too hard…

Is there a way to measure transfer/reading speeds from the HD’s through the Vero?

Are your remux in a mkv container? If not muxing them to mkv definitely helps.

USB2 won’t give you a bottleneck for 4K
You can do a test with smart tools


I switched the HD places on the hub to check if problem occurs. The reason I think it might be the hub is because the second usb-connection on the hub is faulty as it does not provide power to my HD (you here HD clicking). The other three connections do provide power.

Can you elaborate on the use of smart tools? I only have a MacBook and connecting the drives to that is not possible as it cannot read ext4 drives. Can I use the smart tools on the Vero? If so, how? Or by using ssh?

edit - it is not the location of the HD on the usb-hub as it started buffering again with HD two in the location of HD one…

I will reboot and create a new log.

If you unplug one of the drives, does the clicking go away?

Yes, it does.
I thought the issue was with the second usb connection on the hub. But now I have disconnected one drive and have the other drive connected to that second location and no more clicking…

just guessing but It looks like the hub isnt providing enough power to power all drives at the same time

Indeed. @bezulsqy might prefer to use a different power supply for the hub if connecting several drives.


Does having only one of the drives plugged in also make the stuttering issue go away? If so, then if you plug one drive directly into the Vero and the other in the hub (note that this is not an officially supported thing to do) does everything work as it should?

Thank you all for the tips.

This morning I had half an hour to do some more checks.

The USB-hub indeed is faulty or broken, as I now cannot power two drives simultaneously. But there also may be a problem with my second HD.

Yesterday I had no trouble watching a 4K remux that was on my first HD. It played without problems without “adjust display refresh rate” enabled and halfway through the movie I changed that setting to start/stop and the movie continued to play without issues but now in a 4K resolution. Thanks @darwindesign for pointing that out!

Three 4K remux files with a smaller or similar size as the file I mentioned above did buffer while playing from the second HD. Because the buffering occurred at different parts of the same file I suspect the files themselves are okay.

This would mean that the Vero 4K+ is doing its job and the fault lies or in the hub or in the HD (or both). The best way for me to test this is to have the same file on both HD’s and try to see if the buffering occurs on both drives. But because it takes a while to transfer 60GB twice this will have to wait until tomorrow.

I am going to purchase a new HD with its own power supply and transfer everything onto that. Because I did not know about the “adjust display refresh rate” yesterday was my first experience of watching 4K using the Vero 4K+ and I have to say it looked absolutely smashing on my OLED tv. I want more of that :slight_smile:

I would say that the least expensive thing to replace would be the hub. Get a new one. And then if the problems with the questionable drive still happen, then buy a new drive.

A hub is a far cheaper fix than a new drive. And if the hub is the real problem, then the new drive could have been a waste of money.