Can anybody recommend a decent gigabit usb adaptor?

I actually ran NFS vs SMB benchmark accessing same file on Windows server using USB gigabit adapter.

As per Windows task manager it was 265mbps for NFS vs 335mbps for SMB, both mounted via fstab.

Not sure if the reason behind that was that built-in Windows Server 2012 NFS server did not work with Vero so I installed some 3rd party one called WinNFSd

That’ll be it.

Any recommended way to setup Windows NFS to work with OSMC/Linux? The NFS share is discoverable but is empty. I tried to google it but still haven’t found anything helpful.

Upd never mind, found that manual from Microsoft, will give it a try.

If you are sharing from a Windows server stick with SMB.

Pushing an old topic… anyone has a recommendation for a usb gigabit adaptor that is proven to give great transfer rates on the Vero 4k?

You can check this post.

But I think you might have also already read that 99% of files can be played via the 100 MBit with the right settings

I can’t really recommend the TRENDnet USB 3.0 Gigabit adapter since I didn’t get any improved speeds. What I found to be the solution was to optimize my WIFI AC connection. I installed an AP in the same room as the Vero, and now I have no problems with speed at all. Even some very high bitrate movies like John Wick (1) and the latest Transformers who both have bitrates that exceeds 100 Mbit/sec plays withtout any misbehaviour. My AP is a D-Link DIR-865, older model I had laying around. I only use it as AP, no lan. My TV is a SONY A1 65" and I’m sitting 3,5 mtrs away, truly astonishing picture quality from the Vero compaired to Netflix 4K :slight_smile: Sound is Dolby Atmos or DTS-HD, and the receiver is a Marantz SR 8012. So high bitrates, but no problem anymore, thanks to good stable WIFI AC :slight_smile:

this one is working here: - plug&play without any problems

iperf “says” the ethernet-connection is around 180 - 200 Mbit (tested over Kodi-NFS-connection, I added the fstab-NFS-connection later and did not measure it)

John Wick was driving and shooting fine over this connection without dropping (almost) any frames for the first hour of the movie (did not look further, ran out of time). Strangely enough there were two or three (small) skips, but during a dialogue-scene where the bandwidth was not extremely high. I guess there is a problem with the rip…

That sounds alot like what uniquedk is reporting… transfer speeds up to 200 mbit/s but not completely stable.

I think the problem in the Wick case is not the connection, but the source material. I noticed only three frame drops in a very short time frame (maybe one minute of the movie). And these drops occured always at the same time. The rest of the film played perfectly fine.

no issues with any other high bitrate files?

not yet. But I only had time for a few short views into some movies and one 60 minutes documentary

I am considering buying D-Link USB 3.0 Gigabit Ethernet Adapter DUB-1312 to improve speed over network:
DUB-1312 USB 3.0 Gigabit Ethernet Adapter | D-Link UK .
It’s an ASIX AX88179 chip. Does it work with Vero 4K right out of the box? What settings in OSMC will I need to change?
Will the speed be improved?

I’m using an AX88179 with no problems. I’m streaming from an Emby server, so messing around with fstabs and nfs wasn’t an option, and I had major problems with most UHD remux material with the built-in adapter.

For me, the USB adapter was a nice quick solution to the biggest flaw of the Vero4k. Didn’t have to do anything special to get it working BTW, it was picked up by the software automatically.


I’ve just bought this adapter ( and plugged it in and it doesn’t appear to be plug and play for me. When connected by lan normally I have a manually configured fixed ip address. Can you tell me do I need to disable that please? What settings do I have to set using the MY OSMC program? I have ethernet enabled. I’ve tried disabling and that doesn’t work…

Thanks for any help you can give me


Is the fix IP address configured on the Vero or on the Router (DHCP server)?

The router’s DHCP server maps MAC addresses and IP addresses. Since the USB-Ethernet-adapter has its own MAC address the router does not recognize it. You have to use the MAC address of the adapter instead the MAC address of the Vero for the “old” IP address.

It’s in the Vero setup for the built in ethernet adapter.

Should I turn that off? Will it then recognise the usb-ethernet adapter?



@mlavende: I assume you want to replace the 100 Mbit/s Vero 4k LAN interface with the USB-Giga Ethernet adapter, right?

I do not know whether this adapter will be recognized by the Vero 4k at all but also let’s assume this is the case:

  1. Shutdown the Vero 4k until the red light
  2. unplug the power cable
  3. insert the usb-adapter into one of the Vero 4k USB ports or powered USB hub
  4. Switch the LAN-cable from the Vero’s LAN port to the USB-Ethernet adapter … the LAN port of the Vero is now empty!
  5. Power on the Vero this could take a while
  6. Go to MY OSMC -> Network > Wired
  • in case the adapter was disabled -> enabled it
  • in the status line of the menu you should see something like usbnet0 … if you see eth0 something is wrong, most possible the adapter was not recognized at all
  • if you see usbnet0 or so, you can now enter manually your fix IP address data … and finally try a reboot

If that should not solve your issue, please, open a new thread since this thread cares about recommended Gigabit usb adapters and not troubleshooting an Anker USB-Ethernet plug.

1 Like

Thanks JimKnopf I’ll try that later

I was under the impression that I bought a recommended USB adapter. It seemed to be recommended by Rito_Bear earlier.


also thanks to JimKnopf!

Just to ensure mlavende: I have exactly the same Anker-adapter and if you follow Jim’s guidelines there shouldn’t be any problems.