Can anyone suggest/provide a Crystalubuntu 2 Mirror?

Hi Sam,

I’m sure that it will take some time for a developer to come up to speed with whatever you need help with, but please let me know if I can be of any assistance. I’m fluent with Linux, shell scripting, kernel compilation and many other things. Bootloader … it depends what you need. I just joined the forum because you asked for help, so I can’t PM you yet.

BTW, thanks a lot for all your hard work! You’re the best!

@elroy - Which process and steps did you follow exactly? The one from wrxtasy? As is or some changes/ fixes?

@wrxtasy - I’d love to hear how a dual boot setup could be done. I was hoping to keep the Apple TV OS (all ATV original functionality - Apple Airplay etc) and CB2 as well on ATV, but the only way to do that is booting CB2 of USB drive and remove when one wants to go to ATV OS.

Thoughts on the above? What kind of dual boot were you thinking?

Yes, I followed wrxtasy’s steps exactly as above (with the exception of changing the location of the image on my local drive - which was done simply by typing the first part of wrxtasy’s instructions:

dd if=

And then dragging the image file into your terminal window (it will automatically type the location of the file for you) then completing the rest of the command before hitting enter.

Hope that answers your question.

1 Like

hi Sam any news on the osmc for the atv 1

1 Like

What ATV OS functionality do I lose when I move to CB2? Can any of it be replicated?

You might want to have a look at this nice Skin called AppTV:
http://forum.kodi.tv/showthread.php?tid=214143

Its fast, simple and works well :slight_smile:

@wrxtasy - I looked at that. Its nice and clean.

I meant from a point of view of Native ATV functionality / AirPlay + HomeSharing etc… Things that would be easy work in the Apple World (SInce I have iPhone and iPad).

What kind of things from that world would not be directly available on CB2 based ATV?

@xbliss Just a guess, but I would think that streaming programs directly from iTunes on a Mac or PC wouldn’t work. And Airplay seems to be a little wonky with CB2.

@Bonnie_Raitt Did you manage to solve your resize?

@Soli

I’ve been trying to expand the sda2 partition from 40gb to 160 as you said. The resize command cannot be executed as the device needs to be unmounted. I tried to unmount it and obviously I can’t as it’s busy. This leads me to the question, how can I execute your ‘resize’ command?

Assuming it made a difference I installed gparted, but it never starts as:

(gksu:2192): Gtk-WARNING **: cannot open display: 

Can Gparted/parted be executed as a live usb OS in the atv and perform the resize from there?

Thanks for your help & patience.

Of course gparted isnt going to work… I never said to use that. I said you can mess with atvboot to boot up Gparted, but I really meant Gparted Live. This whole mess is pretty much a parody now. If I were you, I’d forget about OSMC for the ATV and just get a raspberry Pi 2.

Thanks man for the unsolicited advice. I have two Pis that work quite well, I was looking for advice on parted that looked like you had some knowledge to share. My bad that isn’t the case.

I finally gave up. I couldn’t figure out a way without removing the hard drive which I didn’t want to do

No need for that passive-aggressive bs. You obviously don’t get it. I’ve said twice already that you need to use ATV boot loader to boot Gparted Live. (Or just kexec directly from CB2) The advice I had regarding Parted I already shared, too bad the partition is locked.

Hello there,
I’ve been following you’re links to install Crystalbuntu2 on my ATV1.
But now I’m stuck.

I previously used OpenELEC ATV1 on a CRT TV. iPlayer stopped working so I reset to Apple but that was futile. Don’t want to pay to watch free BBC.

Here’s what I’ve done:

  1. Made OpenELEC USB
  2. Downloaded crystalbuntu2.img.bz2 from https://docs.google.com/open?id=0B_2SE2NYhMjQSnZldGhWdk4xUkk
  3. cyberducked file to ATV1 while running OpenELEC/XBMC
  4. Rebooted ATV1. Watched CPU get busy in XBMC and went to bed.
  5. Rebooted ATV1 and saw the Duck with lines of code. Screen went black!
    5.5) Followed the KODI update.
  6. Got xorg.conf code from chewitt (sprunge.us/gNEJ) that previously fixed OpenElec on my CRT TV.
  7. Used Terminal on OS X to ssh into atv.
  8. Used following command to edit existing xorg:
    sudo nano /etc/X11/xorg.conf/etc
    Saved Edit.
  9. Rebooted ATV1. See the Duck and code. Screens stays OK. Code stops. But no XBMC. Just Code.
  10. Plugged in usb keyboard to ATV1 and it types. Not sure what to write.
  11. tried various start XBMC and stop XBMC codes in terminal. No results.

    Thanks in advance.
    Looking forward to trying OSMC. Have ordered a CHD card off ebay.

There is a way to use kernel 4.x with legacy nvidia driver.

Edit: can confirm this works. I have Kodibuntu running on the ATV with kernel 4.1.2 with Nvidia driver working just fine.

You might try that link again. Christian Hewitt has posted updated versions, including Isengard 15.0 RC2 for ATV1. I bought a Raspberry Pi 2 because I thought it would be an upgrade, but have had problems with my remote and with digital audio. I’m back to my ATV and am happy for the moment with Kodi 14.2, at least until I can sort out my RPi setup.

Openelec is kinda useless on the ATV1, even though it should in theory perform better than a regular distro. I have no idea why (apart from the ATV1 lacking ram).

This should be:
nano /etc/X11/xorg.conf