Can I use Netflix on OSMC?(post 4)


#308

Am I right in thinking that 1080p and 4k are still a no go with osmc on a vero 4k+?

No problem if it is, I’ll just use the app on my TV, just wondering as this was the case a while back when I last looked into it.

Edit…just noticed this is the RPi forum, apologies.


#309

Is the addon working for you guys ? I renewed my Netflix subscription yesterday and tried to play something today and got:

18:29:00.360 T:1650455280   ERROR: Traceback (most recent call last):
18:29:00.360 T:1650455280   ERROR:   File "/usr/lib/python2.7/SocketServer.py", line 290, in _handle_request_noblock
18:29:00.362 T:1650455280   ERROR:     self.process_request(request, client_address)
18:29:00.363 T:1650455280   ERROR:   File "/usr/lib/python2.7/SocketServer.py", line 318, in process_request
18:29:00.363 T:1650455280   ERROR:     self.finish_request(request, client_address)
18:29:00.363 T:1650455280   ERROR:   File "/usr/lib/python2.7/SocketServer.py", line 331, in finish_request
18:29:00.363 T:1650455280   ERROR:     self.RequestHandlerClass(request, client_address, self)
18:29:00.363 T:1650455280   ERROR:   File "/usr/lib/python2.7/SocketServer.py", line 652, in __init__
18:29:00.363 T:1650455280   ERROR:     self.handle()
18:29:00.364 T:1650455280   ERROR:   File "/usr/lib/python2.7/BaseHTTPServer.py", line 340, in handle
18:29:00.365 T:1650455280   ERROR:     self.handle_one_request()
18:29:00.365 T:1650455280   ERROR:   File "/usr/lib/python2.7/BaseHTTPServer.py", line 328, in handle_one_request
18:29:00.366 T:1650455280   ERROR:     method()
18:29:00.366 T:1650455280   ERROR:   File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSLHttpRequestHandler.py", line 69, in do_GET
18:29:00.366 T:1650455280   ERROR:     dolby, hevc, hdr, dolbyvision, vp9)
18:29:00.366 T:1650455280   ERROR:   File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSLv2.py", line 244, in load_manifest
18:29:00.368 T:1650455280   ERROR:     data = self.__decrypt_payload_chunks(resp['payloads'])
18:29:00.368 T:1650455280   ERROR:   File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSLv2.py", line 332, in __decrypt_payload_chunks
18:29:00.368 T:1650455280   ERROR:     decrypted_payload = decrypted_payload[1]['payload']
18:29:00.369 T:1650455280   ERROR: KeyError: 1
18:29:00.369 T:1520956144   ERROR: CCurlFile::FillBuffer - Failed: Server returned nothing (no headers, no data)(52)
18:29:00.369 T:1520956144   ERROR: CCurlFile::Open failed with code 0 for http://localhost:44485/manifest?id=80211499&dolby=true&hevc=false&hdr=false&dolbyvision=false&vp9=false:
18:29:00.369 T:1520956144   ERROR: AddOnLog: InputStream Adaptive: Cannot download http://localhost:44485/manifest?id=80211499&dolby=true&hevc=false&hdr=false&dolbyvision=false&vp9=false
18:29:00.370 T:1520956144   ERROR: AddOnLog: InputStream Adaptive: Could not open / parse mpdURL (http://localhost:44485/manifest?id=80211499&dolby=true&hevc=false&hdr=false&dolbyvision=false&vp9=false)
18:29:00.372 T:1520956144   ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.netflix/?action=play_video&infoLabels=%7B%27rating%27%3A+0%2C+%27writer%27%3A+%27%27%2C+%27episode%27%3A+1%2C+%27plot%27%3A+u%27On+the+night+of+her+36th+birthday%2C+Nadia+meets+an+untimely+end+...+then+suddenly+finds+herself+back+at+the+party+her+friends+threw+for+her.%27%2C+%27season%27%3A+1%2C+%27tvshowtitle%27%3A+u%27Russian+Doll%27%2C+%27title%27%3A+u%27Nothing+in+This+World+Is+Easy%27%2C+%27mediatype%27%3A+u%27episode%27%2C+%27mpaa%27%3A+u%27-%27%2C+%27director%27%3A+%27%27%2C+%27genre%27%3A+u%27TV+Comedies%27%2C+%27year%27%3A+2019%2C+%27duration%27%3A+1499%7D&video_id=80211499&pin=False&start_offset=-1]
18:29:00.372 T:1520956144  NOTICE: CVideoPlayer::OnExit()
18:29:00.449 T:1917898752  NOTICE: CVideoPlayer::CloseFile()
18:29:00.449 T:1917898752  NOTICE: VideoPlayer: waiting for threads to exit
18:29:00.449 T:1917898752  NOTICE: VideoPlayer: finished waiting
18:29:00.461 T:1917898752 WARNING: OnMessage: Suspiciously long time to handle GUI_MSG_PLAYBACK_STARTED (3.43s)

using the latest 0.13.21 version. (even tried reseting everything and redownload the vine thingy).
I can browse the menu/episodes/movies just fine…When i try to play something this happens.

EDIT: Tried to use the new version 0.14 with similar problems…Browsing works but not playing anything. Getting error: https://pastebin.com/raw/Dk1m635Y


#310

Sorry to say I still got it working, version 0.13.21 of Netflix addon.

Which version of pycryptodomex are you using? i got:

osmc@pi3:~$ pip show pycryptodomex
Name: pycryptodomex
Version: 3.7.0


#311

hmmm…i get: Version: 3.6.1 How the hell did this happen.
Also: Kodi 18-RC4

I’ll try first :

sudo apt-get update
sudo apt-get dist-upgrade

and then sudo pip install pycryptodomex==3.7.0 and post back


#312

Nope…updated everything, still get an error on playback…Now i tried again with your version…got this:
https://pastebin.com/raw/9vBMw3TW
And re-retrying the 0.14 version ( a bit more detailed log, but same error) : https://pastebin.com/raw/pvxbCsuT (The 2nd error…the 1st was not logged in crap)

Even redownloaded the libwidevinecdm file.


#313

To be honest i’m a bit out of my depth, but did you try to clear the challenge /response files in .kodi/cdm/

Seems to be something with the decryption that goes wrong, but as I said i’m out on thin ice.

Next step would be to try the github, https://github.com/asciidisco/plugin.video.netflix/issues


#314

Yeah, i tried that, didnt work. I’ll send a ticket although i have the impression the addon is abandoned…thats why someone else picked up.
Thanks @joakim_s


#315

There haven’t been any updates to asciidisco build for a while now, not sure what happened to the developer but I see a few people are having playback issues.

Some recommend to try this fork:

Or this one:

which has a lot more recent activity. Haven’t tested it so can’t vouch for it.


#316

Thanks @gmc,
I’ve already tried the 2nd link , i’ll give wintuxx’s a try as well.


#317

Case closed, it was the stupid DNS settings my router had…Once i restored my ISPs values, everything returned to normal…
So for someone else having the same problems … if you see socket type errors…its your DNS settings.
(i ended up using CastagnaIT’s distro)


#318

Hello, everybody… I really enjoy netflix on OSMC however 720p seems to be limits, any news about 1080p support?


#319

wont happen with the current hardware…