[HOW-TO ALL PLATFORMS]Can I use Netflix on OSMC?(post 4)

#329

Apologies I thought you were involved… Thanks for the link

#330

just tried it , works 100% at 720p

thank you!!!

#331

Hi guys, I want to use netflix on my Pi. I followed the guide which is basically these steps

echo "deb http://download.osmc.tv/dev/gmc-18 gmc-18 main" | sudo tee -a /etc/apt/sources.list
wget -qO - http://download.osmc.tv/dev/gmc-18/pubkey.asc | sudo apt-key add -

sudo apt-get update
sudo apt-get dist-upgrade -y

sudo apt-get install python-pip python-crypto build-essential -y
sudo apt-get install python-all-dev python-setuptools python-wheel -y
sudo apt-get install python-crypto-dbg python-crypto-doc python-pip-whl -y

pip install pycryptodomex
sudo ln -s /usr/lib/python2.7/dist-packages/Crypto /usr/lib/python2.7/dist-packages/Cryptodome

wget https://github.com/kodinerds/repo/raw/master/repository.netflix/repository.netflix-1.0.1.zip
wget https://github.com/Sandmann79/xbmc/releases/download/v1.0.2/repository.sandmann79.plugins-1.0.2.zip

sudo reboot

Now the issue is that I can log into netflix but nothing happens when I try to play something, if I am correct I should see a prompt to install widewine right?

#332

I’m haveing issues as well, and I’m not in position to make a clean install the next couple of days.

#333

I’ve just made a clean install of OSMC on my Pi3. I updated to nightly and then ran my netflix-prep script(in post 4, after upgrading to nightly), installed the latest netflix addon(0.13.22). Logged in and when I chose a show it asked to install widvine, after that the show played as it should.

#334

Just tried it but got the same issue, I can login to netflix, click on something to play but then the screen loads and comes back to the previous state and nothing happens after that, I don’t get the prompt to install widewive.

Is there a manual extraction method that one could use instead?

#335

Just curious, when OSMC with Kodi v18 is released, will Netflix be supported without issues? I see a lot of posts here still that people have issues.

I love OSMC, and I’m eagerly waiting for Kodi v18 to be able to watch Netflix, but just wondering what the experience will be. Thanks.

#336

Well it’s all about the add-on, Netflix changes some stuff in user authentication and other stuff from time to time to discourage user of unofficial apps. Then the add-on has to be updated. Other times it is due to an update to inputstream.adaptive that breaks the add-on.

The installer-prep script I made, installs all needed dependencies and downloads the latest stable Netflix add-on and gives you instructions how to install the add-on in Kodi. So far it’s worked, but as I said, when Netflix changes things there is often a few days until the stable gets updated.

#337

I only caught a few things here and there but didn’t the Kodi higher-ups try to partner up with Netflix and become officially supported platform/app? IIRC DRM was the deal breaker.

#338

There was also something about the UI wasn’t up to Netflix standards.

1 Like
#339

Netflix add-on is third party; so it will never be a frictionless integration unfortunately.

Sam

#340

While we’re at it: https://kodi.tv/article/presenting-koditv-multipass :smile:

#341

@joakim_s I’ve previously managed to get Netflix working on my Vero 4K+ with this procedure, but trying it again now it says it’s missing some libraries:

“Your system is missing the following libraries required by Widevine CDM: libnss3.so, libnssutil3.so, libnspr4.so. Install the libraries to play this content.”

Do you know where I can get these from?

#342

sudo apt-get install libnss3 libnspr4

I just did a clean install and i also got that message, did the line above and it works. I fixed this in my prep script now.

1 Like
[TESTING] Kodi v18 release builds
#343

Thanks. Got it working with the above. (The plug-in still seems a little unstable, but it launches and plays at least some of the time!)

#344

@joakim_s Awesome guide and got this working with today’s official release of Kodi. Only issue I am having is it’s buffering time to time and want to know any tricks and tips to enable smooth playback.

Thanks again for your hard work and make this add on available via OSMC platform

#345

Installed this today on a Vero with the official Kodi 18 release. Installation went smoothly, I found the settings to limit decoding to 720p, and initial playback was fine. I then attempted to resume playback on a title and the Vero crashed, completely unresponsive with a flickering screen. Had to pull the power and start again. So I guess this add-on is not ready for prime time just yet.

What is the mechanism by which users are notified of updates to the add-on? Is it the same as regular add-ons or do we need to manually download a new zip file? If the latter, where do we look for news on updates?

#346

As I’ve used it for the add-on for most part of the last year, I’ve just noticed updates when there is a problem with the plugin to play Netflix, and then I’ve done manual updates. Since the add-on doesn’t work without the update, those updates can take between a few hours up-to 4 days to come to life.

Here you can see the latest release of the non-beta add-on:

#347

Thanks, I’ve bookmarked that link. The installer seems to have installed the latest 13.22 beta release anyway, so that was the version that crashed the Vero. Will keep a look out for new versions.

#348

There is a 14.0 brash of the plugin, but with a couple of more functions. I tried it before but i didn’t find it working better. But you could check it out:

And the latest version I’ve found of 14.0 is beta 24, and there are a few forks of 14.0: