Can’t connect to synology NAS

Recently upgraded my network from google WiFi to the nest WiFi system. Left everything the same, SSID, password etc. basically just swapped in the new routers. Now I cannot connect My vero 4K Kodi to the NAS. All my settings were correct on the synology in terms of sharing etc. here’s a pic of the log file.
Running 18.5

Need some help:)

Does the NAS still have the same IP address?
Please post the link directly in the future: it’s quite a waste of space to post a photograph.

Sorry! Yes, I believe the IP address stayed the same. The shared drives that I mounted in windows worked after I swapped routers so I’m guessing the NAS IP stayed same.


Your log appears to be empty.

Your windows PC may well be mounting them via hostname, rather than IP.

Are you able to access your nas via a web browser on the address you believe it is, the url will something like this:


Your probably be present with a page reporting a ssl certificate error.

Thanks Tom.

I don’t remember the IP address of the NAS before I switched routers unfortunately. I do have the ip currently and it pulls up the NAS just fine when I type it into a browser.

Need me to redo the log file?

Yes and please advise the current IP of the nas.

Kodi freezes when I try to add files under browse for NFS. That’s probably why log is empty.
(Synology ip)


For now if you could just reboot the vero4k and upload a new log. No need to try and connect to the NAS at this point.

Thanks Tom.



Fixed your link, but your log is still empty.

If you are running any third party addons, could you please temporarily disable these and reboot and try uploading the logs again.

Thanks Tom.

Shoot! Not sure what’s going on:(

Here’s new log (I have one add on for screensaver that’s it)


It’s funny for a bit I had a connection to my server now it’s broke again.

In MyOSMC where your uploading your logs can you check the box that says “all configs and logs” and upload with that enabled.

1 Like


Unfortunately your NAS’s IP has changed. The Old nas IP and the new one as you’ve stated is You’ve got a few choices here, If you want to do it external from the vero4k.

Set the nested wifi to (or network and set DHCP address pool to start at

Then Give the nas a static ip address of

Control Panel, network, network interface, edit lan connection. Use manual configuration radio button.

Vero4k side has a couple of options, both would need command line access:

The easiest would be resetting kodi and setting everything back up again using the nas’s new ip address, the reset is done as follows:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

The other option is using a path substitute using a text editor such as vi or nano, create ~/.kodi/userdata/advancedsettings.xml containing:


Thanks Tom.
1 Like

I’m going to try and do it externally.

Can you specify what I need in each of these boxes?

Just to verify these are my google WiFi lan settings

Set your gateway and DNS server to the router lan address
Set the IP address to

1 Like

Thanks! Done!
Now Under network settings (my osmc) - network-Wired- under status it shows no internet? I can’t create a log now either?

Sorry guys! This is tricky for my level of knowledge

Reboot your device so it picks up the new dhcp settings. Once you changed your subnet on your router your devices that are pointed to the old address are going to keep trying to talk to the old location until their lease runs out or you give them a kick in the pants.

I tried rebooting just the Vero and same deal. Should I reboot anything else as well?

Edit- it’s also odd that in kodi under system info-network- the MAC address and internet lines say “busy”.

Never saw that before