Can’t update from Nov. 2020

Trying to manually update and getting a connectivity issue message on scan fo updates now. Also upgraded to a new router and lost movie artwork, now shows only thumbnails.

Try the hotfix from the FAQ

I am having the same issue., where I get a connectivity issue mesage when trying to update manually. I figure it should have offered me the update automatically (that is how I have it set up)?.
I have been using the same wired router since before I bought the 4K+ a few years back, and nothing has changed in my set up and I have tested the connection speed and it is solid (I have fibre optic 500 MB up and down). There doesn’t seem to be any info on how to address this in the “(Kodi v19 Matrix is here. Here's what you need to know - OSMC” thread…


Have you tried the hotfix mention by fzinken?

Thanks Tom.

The hot fix worked for me. Unfortunately I’m now having problems with v19 locking up, Happened once when I hit chapter forward and once when selecting a movie to play.


Probably best to raise a new topic for the issue and post some logs please.

Thanks Tom.

Hi, apologies for the late reply, I was only able to get the time to apply the hotfix this afternoon, but it did indeed allow me to run the update. I haven’t yet tested anything.

For anyone that finds this thread when searching, the hotfix from the FAQ is as follows:

Q: I’m unable to install the update, even if I try updating via the command line, my system is still on an older version of OSMC. What can I do?

  • Go to My OSMC → Updates → Manual Controls → Apply Hotfix.
  • Enter ucawobahij and proceed.
  • You can now update your device via My OSMC or the command line.

Many thanks for the responses!

1 Like