Can’t update osmc to latest version

Logs :

Please help

The logs don’t show an error (nor a try to update).
What happen if you manually scan for updates?

When I go to myosmc- updates- manual control- scan for updates the pop up in the right corner says downloading updates and then it says two more things but too fast to read the text.

After that nothing happens.

And there isn’t any Install downloaded updates now button in manual controls either.

I’m stuck on 2020-11-1

Updated logs:

I tried to update multiple times after enabling debug logging and rebooting so it should be in the log

Did you use the hotfix from the FAQ?

Looks like hot fix did the trick am now on 2021-11-1 kernel 4.9.113-55

Kodi 19.3

I assume that’s the most recent update ?

Thanks a lot @fzinken


1 Like

Sorry to continue in this thread but I’m trying to install

If I try from repository I get an error about not satisfied python 2.20.0 dependencies and i don’t have a pc here to download the zip from GitHub and install it.

Could you help me to install and download through the console and with the python error

You always can reach the console by choosing Exit from power menu and pressing ESC (need to connect a keyboard). Then you can download the ZIP via wget.

Thanks I usually just ssh into the vero from my tablet and use that keyboard

After I wget where will the .zip download to ?

That works (just thought you didn’t had that as no PC).

/home/osmc if you login as osmc and start the wget

1 Like


I wget

And when I try to install it I get the message it’s not compatible with this version of kodi

Installs fine here, are you sure everything is up to date?
Did you check for updates in MyAddons?

When I updated osmc I got the message that twitch and YouTube addons are not compatible with this version of kodi and will be disabled then I try to update them via my addons - update addon but that didn’t work Than I uninstalled twitch

Then I went the console route with your help

Now I’m here

Should I open a separate thread about the problems with the twitch addon ?

Would recommend to open a new thread. But as mentioned it works here on my system which could indicate that you still have an issue with not having updated the addon repository and all it’s dependencies.

Well that might be but I’m a noob so how do I do that ?

I have only done what you have told me. Applied the hotfix and updated osmc through the gui

For the past year or so, I didn’t realize OMSC wasn’t updating. Just saw this hotfix, LOL.

1 Like

Hi, just discovered same update issue and happy there is a fix available. Unfortunately, suggested hotfix did not help. Tried several times, incl reboots, no change. Any other advice I could try to update to current version? Also with 2020-11.1

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot: