Can we now do auto updates?

can we now do auto updates? or is it still all manual?

if its manual, im on a mac using cyberduck, and allowed it so i can view hidden folders, now is there a folder we can just drop in the newest file, and it will update?

thanks
j

1 Like

if your talking about systemupgrades then its simple, first of if think your thinking of Openelec when your thinking of dropping a file in a folder OSMC is a bit more sophisticated then that since its based on Debian Jessie and yes you can auto update with Unattended Upgrades.

now if your talking about files per say then i suggest the addon called watchdog it scans if a new file is dropped into a folder it has access to.

im talking like the newest update of osmc, i know thereis a feature for auto updates, but with the last fiasco, can we turn auto updates back on?

if not and we have to do it manually, what is the best way? is there a specific update folder were we can drop in the file when u ssh into the box?

its ignorant to call it a fiasco Sam and the rest of the team is working hard at bringing OSMC without doing hacks on other systems. And yes it is safe to update the system and i just told you how to go about autoupdating but i guess your not that familiar with linux so just manually update for now via MyOSMC.

2 Likes

WHOA WHOA

NO NEED TO ACT 12 NOW IS THERE… IGNORANT? HMMM OK,

IT WAS A FIASCO!!! A THREAD WITH CLOSE TO 200 REPLYS SHOWS THIS!!! AND COUNTLESS PEOPLE HAVING TO REDO THEIR BOXES…=FIASCO!!

Of course sam has worked hard, this wouldnt be OSMC if he were lazy ITS A GIVEN, MAN ALIVE

I think you need to change your tone… atleast I don’t like it!

3 Likes

I used to be an update junkie… now I only update when I see a significant reason. Or I wait long enough to see how it works for everyone else.

1 Like

Hi there,

If you’re referring to the SD card issue on Pi, then a one-line edit to config.txt, which is editable on a Windows PC, a Mac or a Linux system, would resolve this.

I myself, was not particularly chuffed with an SD card driver this problematic either, which is why it’s been reverted. But one must consider the incidence of said reports (200 replies) compared to the number of users, as well as the fact that most were repeat posters.

No one had to redo their boxes. Wasn’t a good situation, but unfortunately affected SD cards that our team members didn’t have. With that said, iff we consider each reply was unique (it wasn’t), this would have affected 1 in 3500 reported Pi users.

S

Just realised you’re talking about aTV. Turn off your device properly, and you won’t see an issue…

Yelling at people in caps to call them twelve is bitterly ironic. Remember everyone replying to you is doing so of their own accord in their own free time. Afford them some respect

Sam

2 Likes

Sam,
i apologize to u as its your forum, but a guy calling someone ignorant deserves no ones respect…he in fact to me, deserves CAPS imo, that was a very very childish response to someone who had a q, if in fact he was trying to help, you dont put someone down! thats not how a respectable forum, or business should act…

what i am referring to is in openelec there is a hidden folder called updates, i wanted to know if osmc had one in order for us to just drop an update in, or if the auto updates are fixed towards the new image u had put out?

that was all,

This is the crux of the issue with the ATV update problem that some users had.

The update work perfectly fine on my ATV1. This is because I always shut my system down from the menu, and wait until it it’s says the system has HALTed, before powering it off.
In the few cases where it was not shut down safely, I manually fsck checked the drive.

You can’t simply yank the power plug on a PC without problems. Doing the same to the ATV1 causes more problems due it’s mandatory use of Apple’s HFS+ filesystem on the boot partition where the kernel and related files reside.

So… If you don’t turn off or reboot your ATV1 safely/properly, then the system couldn’t fully update.
Why ? Because the HFS+ partition will end up being Read-Only, and the system update will only partially complete.

The latest update tries to help prevent this, but the integrity of the filesystem on the ATV is best protected from this type of problem by shutting down or rebooting correctly.

So yeah, you can update. If you want to be extra sure before you update, SSH into the ATV1 and use the mount command to confirm that the partitions are mounted R/W.

Once you have the January update installed, it will TRY automatically repair any filesystem damage from not shutting down/rebooting the system safely.

OSMC is updated nothing like OE. It uses update servers just like Debian linux.
Using the MyOSMC gui or manually via apt-get on the command line both work.

thanks spinner, im not to tech savy, so doing any command line stuff is a bit much for myself…

so in order to update i have to boot it down first?

so can u turn on the auto update feature and let er go then? if so im confused on why id turn it off? sorry but yeah im confused…

oi get the reasons, im just not 100% that the auro update feature works…

and if it doesnt do i wright another usb and stick it in? and if i do, wont i loose everything i have on the appletv then? yes i can make a back up, but thats why the auto update feature was gonna be one of the best features to me thru osmc…

well im lost as to how ur suppsoed to update, went in osmc and checked manually for an update,… it failed at like 60%… im really frusterated and am not good with terminal, last time i couldnt get any logs really, and im not really sure what to do at this point, frustration and discouragement begging to settle in they have…

Here is a cheatsheet for how to navigate in a Linux shell: Cheatsheets and Tutorials for users new to Linux based operating systems

now as for tools to connect to your terminal well it aint that hard Putty works

http://www.putty.org/

as for logs

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us

just follow that or if you cant handle that you could use the log uploader in myosmc.

I do agree with you on most of what is said in your post but there is one thing which make your suggested behavior problematic. I often run into media that won’t play properly (typically x264 encoded material in 1080p). Once you try to play such media the entire unit typically freezes and become none responsive. I’ve tried to figure out what is the exact spec for the media files not working but I can’t for sure say. I have numerous examples though.

As soon as this happens I see no there way that “yanking out the power cord” (I do a reset/power cycle with the remote but that should be about the same to the filesystem as yanking out the power cord).

As this happens on a regular basis for me (once a week perhaps) since about a year back the situation with a failed update because of the un-clean file system it became a problem for me. I ran Crystalbuntu prior to OSMC and never had such a problem with that platform.

Hence - I believe quite a few people had issues with that december update that failed. Including myself. And I do have quite a bit of Linux knowledge but still didn’t manage (during my 2 hours session) to get my box up and running properly again. I did get it up and running but the manual update I did wiped all of my presets and configuration (for reasons I did not understand. I use MySQL for metadata etc. for 3 boxes in our house). I ended up doing a DD of one of my other units USB-stick to the broken one…

Kind of curious about what would happen if I did an auto-update now from the OSMC GUI now… :slightly_smiling:

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC

Sam

As long as your filesystem isn’t read only, it should do the same thing it did with my system.
That is to say, it will update and will keep working.

It not like i’m running different hardware. It’s a stock ATV1 with a CHD card installed.
I play 1080P h264 videos via NFS network share and it doesn’t freeze.
The only time I’ve had freezing issues is with streaming which points to server or internet issues.

The fact that your system is freezing with some files, is a separate issue, and should be tackled as such.
The link that Sam provided tells you how to give us more info about the files you are having a problem with.

So… again, the issue with that specific update was it wouldn’t fully complete, and update the kernel and files on the boot partition, due to some people having a read only boot partition.

That isn’t as likely to happen now since the January OSMC update added the functionality to automatically try fsck the boot parition.
BUT fsck is NOT a cure all. the real solution is to shut down your system cleanly.

FWIW: Unless I’m mistaken, Crystalbuntu, rarely, if ever, updated it’s HFS+ boot partition files. It WAS running an old version of linux.
OSMC on the other hand pulls some non-custom updates from Debian, which means that it’s fully up to date with security fixes etc.
That means the boot partition files are updated more often.

I think I only updated the CB kernel once, which means that element would remain rather static

Sam

thanks for the reply’s everyone!

i am lost, as this wont update thru auto update, i tried and again it failed… frownie face and everything again… im just kind of disapointed i have to redo my box for the 3rd time now, and leading to more frustration on my part perhaps?

maybe im doing something wrong again? maybe not? not sure?

here is the picture that popped up this time, i will say the update looked cleaner this time…

it might be too late to recover debug logs because this was a few days ago? dunno?

#frusteratedmonkey #denverbroncos #world champs

Toast! thank you, i appreciate your help! i apologize if we got off on the wrong foot, never my intention!

i use cyberduck as im on a mac…so i can ssh into the boxes i have and see the folders etc… terminal is where i have an issue, im not seasoned on code, but hopefully the link u gave me will help me become better as i use it! thanks again!