Can you Tell me if this is any good, and how I can use it?


#22

Hi,

Your current router should have section for the DHCP server, it should indicate a range or start and end pool IP addresses. For example

192.168.1.100 - 192.168.1.200.

DHCP is the system used when IPs are automatically assiged.

Thanks Tom.


#23

Thanks so much for all your help. This are two screenshots from the settings of the Calix modem/router.

Is this what you ment? Shell I change something here or on the mikrotik ?


#24

Hi,

I would do this:

Calix DHCP Settings:

Change Beginning IP Address to 192.168.1.10 and click Apply

On the Mikrotik LAN Configuration:

Change LAN IP to192.168.1.2

Thanks Tom.


#25

I did what you said on the calix and changed the things on the Mikrotik… see the picture. Did I change network correctly ? After this change, I was now able to connect to the Mikrotik with the IP and without the MAC. But as its visible from the picture I still can’t update the MikroTik because it says could not resolve the address

Also, @Tom_Doyle do you have a PayPal? I would like to send some beer money your way! Or are you part of the OSMC team ? Will you get the beer if I donate to the osmc paypal ?

Updated the picture with the DHCP network tab, shell I just delete this “rule” or change it to something ?


#26

Hi,

I think the reason its not working is that the Mikrotik is currently not getting an internet connection from The Calix. I think a different approach, may work. Change the WAN (gateway) Configuration:
gateway: ether1 to:

firewall: disabled:
NAT: disabled:
DHCP Client: enabled;

Now change the cable run from the Calix to ether1 rather than ether3.

I think you should be able to update now.

Please feel free to donate to OSMC.

Thanks Tom.


#27

I have the vero streaming youtbe and its connected to the mikrotik and im posting this right now on my PC that’s also connected to the mikrotik. So do you still think the mikrotik has no internet ?

Just asking before I start changing things


#28

Hi,

Ok before you change anything, could you please post a screenshot of the update failing.

Thanks Tom.

@k2u3

Looks like you may just need to set a dns server on the mikrotik, other users have had the issue:

https://forum.mikrotik.com/viewtopic.php?t=104896

Thanks Tom.


#29

I still believe it is a much cleaner approach to use the mikrotik as router (compared to it just being a switch) and having it act as dhcp and dns server for your LAN.


#30

I’m not against it at all…I have very little clue what I’m doing here so I’m just doing what @Tom_Doyle was instructing me to do. I don’t know how much of the thread you have read but I have a calix router/modem “Calix Giga center” First Tom suggested to try find something called “Modem Only mode” but it seems you cant do that. So he gave me some instructions on what to do.

Or are you just suggesting I do this:

@Tom_Doyle

I think I found a way to disable DHCP server state on the calix doses that make it “Modem Only” ?


#31

Yes, but I guess you would need to enable NAT. Also you would then need to enable the DHCP Server on the mikrotik (with different IP range than the Calix).


#32

I found the option to Disable DHCP server on the Calix does this make it any easier ?

@Tom_Doyle Tried changing dns server’s on the miktotik to the ones I see in the calix and also to the famous 8.8.8.8 but but didn’t work


#33

Hi,

I’ve been doing some googling, it looks like there should be a mode called Transparent Bridge mode on the calix.

If you enable this you need to setup the dhcp & wifi on the mikrotik.

If you choice to do this, once you’ve enabled Transparent Bridge mode; power off both the mikrotik & the calix. More the network cable in ether3 to ether1 on the mikrotik, power on the calix then the mikrotik.

Tom.


#34

Personally I wouldn’t change the Calix so that you can just use it without the Mikrotik even if you then end up with double NAT


#35

It seems I can’t find that anywhere in the settings. Did you by any chance find out where to select that mode ?


#36

Sent some beer money @sam_nazarko if you guys know each other IRL he owes you a beer


#37

No – I can’t stand these people.


#38

Every time OSMC guys meet up, they end up hating me.

@simonbrunton probably still hasn’t recovered from the last hangover several months ago.


#39

Good to know that “Business lunches” go the same way in all parts of the world ( or at least parts of europe )


#40

@Tom_Doyle @fzinken Thank you both but especially Tom for all your help so far on this totally non osmc related topic. Sadly I still can’t update the Mikrotik because it can’t resolve the address to their server and I can’t find the Transparent Bridge mode option… If you can give me a hint where to look for it I’d appreciate it…Or maybe That mode was made inaccessible by my ISP?

Personally I would love to use the Mikrotik’s wireless because I tested it and its much stronger then the Calix so if that’s an option I’ll be happy.

Generally I believe Mikrotik is the better product so If possible I’d like to use its features as much as possible and Calix’es as little as possible. The only question is how the calix is configured and If I will be able to change that or was that hardcoded into it by my ISP. ( I got the calix when I signed up for the fiber deal)

I also stress tested my connection and im getting roughly 113.5 MB/s in real life performance wich is the same as I got when I had just the calix so thats good.


#41

So as I writtten before my suggestion leave the Calix as is and don’t change it.
Then you will just use the Mikrotik in router mode behind. For that to work you would need to configure the Mirkotik to act as DHCP and DNS Server for your LAN. then connect the Calix on ether1 and WAN (gateway) ether1 set NAT and DHCP Client for ether1 port.