Cannot change static IP address for wireless network connection (WLAN)

If I try to establish a static WLAN connection in “My OSMC/Network/Wireless” on my new Vero V, my ‘FritzBOX! 6490 Cable (5 GHz)’ is found just fine, but after entering my password, I always get an IP address assigned like for instance

IP: and Subnet mask is always: 255.255.0. All other positions are empty. So, the internet connection try fails.

The first six numbers of the IP I get are always the same, the rest vary. If I try to change IP-address, subnet mask, standard gateway and primary DNS to static values according to my router/lokal network, those entered values are set back to the ones shown above instantly.

I am using IP addresses in my LAN like (Standard-Gateway/Fritzbox-Router), … PCs and other devices, Subnet Mask and for my Primary DNS. (Secondary DNS I leave empty).

All my wlan connections are created with: “Wi-Fi 5, 80 MHz, WPA2, 2 x 2”.

How can I get a working WLAN, if my entered values cannot be recognized and established?

BTW, the ethernet cable LAN connection works fine, but needed quiete a few tries to establish, and I think I had to prepare a LAN connection in the Fritzbox with the appropiate MAC-Address of my Vero V, before I could successfully made a connection to the internet.

Things are not quite as stable as they should be. :wink:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

@ Tom_Doyle

Thanks, Tom_Doyle, here is the requested link:

If I re-establish regular ethernet in the Vero V, the wlan-connection can be created in the Fritzbox-router and established in the Vero V , but with the above mentioned wrong IP-addresses, which cannot work in my network.

The moment I disable the cable ethernet connection in the Vero V, the wireless lan (WLAN) connection also gets disconnected in the Fritzbox router. Since I am about to use the Vero V in the living-room, where I have no ethernet cable installed, I have to have a working WLAN-connection. My Amazon Fire-Stick performs there flawlessly, so should the Vero V.

As I said above, I am unable to change those addresses in the Vero V. Every try to change them results in a reset to those non-working addresses.

So just to be sure of the steps you have done before you created this logs.

  1. Rebooted the Vero with Ethernet cable disconnected
  2. Waited till WLAN connected and the link-local (169.xxxx) IP is shown
  3. Connected the Ethernet to be able to create and upload the logs

@ fzinken

The Ethernet cable has to be connected to get an Internet connection with the correct addresses. If I start the Vero V without the Ethernet cable and activate the WLAN adapter, a WLAN connection will be established in the Fritzbox, as soon as I have entered my WLAN password. This connection is always a IP-address, even though the Vero V is in the state to create only a static WLAN connection.
If I try to change those values and enter “apply”, they will get reverted immediately.

Instead of clicking the setting in My OSMC to disable the wired connection just connect to the wireless network and then unplug the ethernet cable. Kodi may act a bit funny after that until you reboot. If it seems a bit locked up just give it a minute.

@ darwindesign

I left the wired connection intact, and lost my internet connection. Then I went to the wireless tab. There I disconnected first from the Fritzbox. In the Fritzbox-router I deleted the remaining wireless entry with the useless IP address.

Then I reconnected within the Vero V to the Fritzbox, in the static IP mode. But alas, again I got a useless IP-address, and then I tried to change it to, which resulted again, in the above IP-scheme. No dice.

I understand. Can you with both wired and wireless enabled in My OSMC and connected via wifi just using DHCP and not trying to set a static IP yet (ignoring the IP address shown for a moment) remove the ethernet cable and reboot. Does then then get you on the intended subnet?

@ darwindesign

If I do that, the moment I click on “change to DHCP” I get an critical system error, which should be shown in the following report:

Also, my LAN is conpletely static IP-configured, so I won’t change that.

So you have DHCP turned off in your router? If so, this seems to me like you are needlessly causing yourself grief. Why not just set a smaller DHCP range outside of what you use for your static clients? I’m assuming what is going on here is is that when you disable wired in My OSMC it is disabling both network interfaces. I think I remember one of the other team members mentioning this in backchannel communications and I don’t remember it being addressed. The seperate subnet I’m assuming is from tethering. If you do a fresh boot without the ethernet cable plugged in can you then set the static IP for your wireless lan?

@ darwindesign

No, after a fresh reboot of the Vero V I am still unable to set a static IP for my wireless lan. :frowning:

I got simply switched, again, to a IP-address with the subnet mask The other entries I made got deleted/cleansed. If this is not being fixed in the next week, I will sadly return my unit to its vendor, sorry. Because this is stuff which should simply work out of the box. I think you would agree on that.

Have you tried making a WiFi hotspot on your phone and connecting to it and seeing if DHCP works?

If you want to set a static IP for WiFi we can do this via the command line through SSH if you are familiar with it.

When a device has a IP-address with the subnet mask it usually means its IP address has not been assigned by the DHCP server. It has not been assigned an address at all, as if the DHCP server is not enabled. To assign the IP address the DHCP server needs to be running and know about the device MAC address (Ethernet or Wireless).

Does your router know about the two MAC addresses so that static IPs can be assigned ?

The DHCP server in a network still needs to be enabled with a static/fixed ip-address arrangement. You don’t disable it once the IP addresses have been assigned, as the IP address lease timeouts (usually 24 hours on a Fritzbox) still have to be maintained.

1 Like

I believe the OP has intentionally turned DHCP off in their router. I went ahead and setup a test network without DHCP and I found the issue the OP is reporting. It seems that neither the saving of the wireless connection (which essentially fails due to I assume incomplete connection details) nor connecting then specifying details manually after the fact stick. Setting the manual connection offline in My OSMC gets reset when you connect to the ssid.

I found that if you turn the DHCP server on, connect to this network, then manually change your IP, this works fine and you can turn your DHCP server off at that point and it survives a reboot and everything is tickety boo.

I don’t know if you want to call this a bug or a limitation. Either way I suppose the solution for now is to either turn DHCP back on at least for the initial setting or to manually establish the link with connman.

@ sam_nazarko

Well, I use two (my brother and I) Linux Mint 21.2 Cinnamon PC in a network through SFTP, but I am no tinkerer in that way at all. I just follow online manuals and install the required packages. I use SFTP mainly with Midnight Commander or Double Commander, not so much in the cli/shell.

But sure, I certainly would give it a try. What can happen? If anything goes wrong I could reinstall OSMC, or restore a backup made with OSMC, right?

I hope it not to be too hard, but I honestly thought it would be possible through the OSMC-GUI by now. Or better: this bug could be fixed by your team in the near future, of course. :wink:

Or like I previously stated you could just turn DHCP back on in your router long enough to configure the connection.

@ darwindesign

That’s right. All my network devices have a manually given - therefore static - IP address. And I intend to keep it that way, because of its reliability.

You don’t gain reliability by turning off your DHCP server. If you want to use static so IP’s don’t move the typical way to do so would be to set them as static in your DHCP server or else manually set them on each device outside of the DHCP range that your DHCP server is assigning addresses in. You seem to have run into a bug/limitation that either hasn’t come up previously due to someone disabling DHCP being so uncommon, or else people who make such a change typically know how to work around the extra messing around such a thing often causes on their own.


Furthermore, assigning a static IP address does not mean that the IP address is maintained across restarts. OSMC doesn’t save the connection details unless there’s a valid network connection. Only the MAC address is maintained and is hardcoded and will always be the same for the network device (Wireless or Ethernet) concerned. The DHCP server still needs to run to allow the assignment of FIXED IP addresses as devices ‘come and go’ across the local network.

Keep your DHCP running, with your static IP addresses.

1 Like