Cannot install any addons after upgrading to 2019.04-1

#1

Installation failed on every single add-on I try to install.

Second fresh install, then completing today’s update.

Skin Shortcuts, etc. All fails. Trying to customize the OSMC skin and this isn’t good. I don’t know what to do right now at this point.

Even going to available updates. I see xmltodict needs an update. Immediate fail too.

Everything fails

#2

What add-ons are you trying to install aside from Skin Shortcuts?
Have you tried refreshing the repository under Settings -> Add-ons?

A log of the failures may give some clues.

Sam

#4

Log file:

https://paste.osmc.tv/xayadogori

#5

That did the trick. Needed to update the repo.

#6

Your system was likely trying to install add-ons from the Kodi Krypton repository, which would not be compatible.

Sam

#8

We’re all good now :slight_smile:

Hey, I wonder if I can compile/build hyperion.ng now?

#9

As mentioned in PM, we’ll post some new instructions shortly. You can of course try to do so in the interim however.

#10

You’re the best. I don’t think I have ever experienced such good customer service and product support until I bought my Vero4k+.

You are a man of your word, sir. Thank you :smile:

4 Likes
#11

These will be for hyperion.ng as well as classic?

#12

Hyperion NG is the goal ideally, as it’s the successor.

Sam

#14

PLEASE use the </> tag for long runs of code if you are not going to use paste.osmc.io! Your posts that include build terminal output are CANCER for anyone reading the forum on mobile.

Thanks

1 Like
#15

Thank you for the tip. I had no idea.

No hard feelings?

1 Like
#16

Lesson learned, carry on :wink:

1 Like
#18

I think there will be more to the build than this – which will show the real issue.

Sam

1 Like
#19

So after the failing compile on hyperion.ng I ran the simple command ‘make’…got me somewhere.

Telling you, the only way I can get hyperion working is to using this:

git clone https://github.com/hissingshark/hyperion-vero4k.git

I can control with systemctl enable hyperion, restart, etc or I can use the java applet and then ssh into my json file and add

"framegrabber" :
{
        "width" : 64,
        "height" : 64,
        "frequency_Hz" : 10.0,
        "priority" : 890
},

"amlgrabber" :
{
        "width" : 70,
        "height" : 40,
        "frequency_Hz" : 24.0,
        "priority" : 799
},

restart hyperion and its gravy.
and just building from binary. source fails.

Albeit an old version of classic somehow installed with amlogic and all the goodies. It will get me by until hyperion.ng can get compiled and built on the Vero. I love the webconfig compared to the applet. Hyperion should not run better on an rPi vs a Vero. I wish it was that easy…compile and build for the rPi in a few minutes. This is going to be worth the wait. I am waiting for the day :slight_smile: hopefully soon.

Now, time to rebuild my massive Plex library on PlexKodiConnect beta. I have about 12,000 movies, over 5000 TV shows equaling roughly 142,000 episodes. Takes about an hour and a half lol

#20

Updating @hissingshark UI installer would be sweet too or just some well written shell scripts.

#21

How does one do that? Or check that it’s done…

#22

Do what?

Updates to make hyperion.ng ease of install is in the works! We will be notified once it’s complete.

#23

Sorry I replied to your post above but it doesn’t seem to work for some reason - how to update the repository.

#26

add on browser --> install from repo --> kodi add-on repo --> left arrow --> check for updates.

good?

I’m so dyslexic I thought your username was floatingwiki

Do another update from MyOSMC, I just did it