Cannot make ALSA + SoundWire to work

Since audio streaming through bluetooth is not currently working (see [Deprecated] [TESTING] Bluetooth audio streaming (A2DP) - #794 by sam_nazarko) I was searching an alternative way to listen to the OSMC playback wirelessly. I stumbled upon SoundWire, a nice android app that would capture the audio through ALSA and stream it to my phone, but… It’s not capturing anything. From what I can see, it doesn’t capture nothing at the source. I’ve just found this other thread: I finally found a way to stream audio from OSMC (RPi) to your smartphone (Android) over WiFi/LAN but it relays on a bluetooth audio too, which is not enabled right now…

What can I do?

Well as audio routing is not the easiest thing to do you might just want to wait for a Bluetooth fix from OSMC team. Try if the current provided fix works.

I’ve tried it, but unfortunately it doesn’t seem to work.

Connection to bluetooth headset is buggy, I was able to establish a connection only using bluetoothctland this sequence:

  • agent on
  • scan on
  • trust device_id
  • pair device_id
    (wait for connection to fail)
  • disconnect device_id
  • connect device_id

Even with the headset connected, no option appeared in Kodi to choose the headset as audio output.

Also, SoundWire is still not working; pulseaudio shows everything in order, but no audio is router trough it…