Cannot reinstall 4k from any medium

So i am struggling to reinstall the latest OSMC on my vero 4k. I had the same issue on the previous release. Since then I bought new A1 64Gb sdxc cards, tested them with f3 and bought a USB sdxc card reader. I also tried a 16Gb Kingston USB stick.

I used the latest balena etcher as well as the dd command, on both the sdxc cards and usb stick - nothing worked. OSMC boots to the ‘please stand by’ screen for a few seconds, then there is no video output. All external peripherals are removed except the power cable and HDMI cable.

Is there something i have to enable before rebooting? The last update I did was using the staging repository so perhaps that has disabled the reinstall feature?

I am reinstalling because I am now having boot loop issues with all HDDs I try using, as hinted in a previous topic. I always used to do fresh installs each release but after a 2 year break, i just ran the updates from the GUI (some of which had issues but seemed to recover after a reboot).

Re-installation worked fine in the past using sdxc cards using the normal process.

This would not be the case.

Can you try while connected to a different display? Maybe it’s simply not outputting a good resolution for this TV during the install process?

Can you show us a screenshot of the card / USB?

Same issue with a monitor and different HDMI cable. I believe one of the dd commands I did was incorrect though since OSMC seemed to ignore the media when i didn’t target the partitian; can someone confirm a working dd command?

sudo dd if=OSMC_TGT_vero3_20211225.img of=/dev/sdc1

I tried sdc and sdc1. The md5 hash of the zip was ok. I tried wiping the cards with gparted beforehand to fat32 and ext4.

Also just to make sure im not doing anything stupid, the power supply is definitely 5V 2.0A ?

Should be /dev/sdc, not /dev/sdc1.


Can you try dd, then insert card in to PC and take screenshot of contents?


FWIW I always use the SD Formatter if I have issues.

sudo dd if=OSMC_TGT_vero3_20211225.img of=/dev/sdc
[sudo] password for user: 
655360+0 records in
655360+0 records out
335544320 bytes (336 MB, 320 MiB) copied, 67.7566 s, 5.0 MB/s


ll /media/drush/C660-F927/
total 244396
drwxr-xr-x  2 user user      4096 Jan  1  1970 ./
drwxr-x---+ 3 root  root       4096 Feb 22 16:43 ../
-rw-r--r--  1 user user    112640 Dec 25 20:09 dtb.img
-rw-r--r--  1 user user 225580212 Dec 25 18:06 filesystem.tar.xz
-rw-r--r--  1 user user  24553472 Dec 25 20:09 kernel.img

Unfortunately I am on Linux so it doesn’t look like I can use SD Formatter

(This is sd card in the usb reader btw)

That looks OK.

Do you know which version of OSMC you were on before?

Before the GUI updates or the current? I did two GUI updates at least to get to 2021.12-1 so I cannot say for certain what the previous version was. Then I did the command line update for the staging repository. That was the last update.

To clarify, the Vero still turns on and works just fine (asides from the HDD boot loops) so the current version in My OSMC is ‘OSMC December 2021 2021.12-1’.

Okay. I’ve misunderstood you completely.

So your system does boot. That’s good.
But when a hard drive is attached – it hangs on the Please Stand By screen.

Unfortunately this has been a known issue with some drives – particularly Seagate, for years. I’ve not been able to reproduce the issue locally here to reproduce.

These commands might help fix reinstallation issues.

sudo /usr/sbin/fw_setenv osmc_defenv true
sudo reboot

Yes sorry, i realize I wasn’t specific enough. To clarify completely;

With HDDs attached, I get a boot loop; ‘Please stand by’, followed by no output, reboot, loops until hard power off or HDD detached.

With no peripherals attached but either a SDXC or USB stick with the OSMC img burned, i get ‘please stand by’ followed by no output and it hangs until hard power off.

As for the commands, I don’t see it in sbin but in bin

$ which fw_setenv

Still OK to run?


Thank you, still no joy.

Could it be the fact that I am trying to install the same image as what is already on the Vero?

Can I trigger a difference by deleting files manually via SSH?

Sam will deny this makes any difference, but have you tried plugging in power while holding down the reset switch with a toothpick (in the analogue audio jack)?

What a cool reset location.

Still no joy.

1 Like

Can you try on another display?
Or even try booting without an HDMI cable attached, and after about 10-15 minutes, come back and see if the OS has reinstalled.