Verk 4k in boot loop with HDD

I checked the other threads but didn’t find too much. I recently got a a new Western Digital Gold 12Tb HDD which is recognized fine when plugged in after OSMC loads but if I turn on the vero while the drive is plugged in, it makes it to the ‘please stand by’ screen and loops between that an a blue screen until turned off.

I enabled logs but not sure how useful they are since I never boot into OSMC with the drive attached before boot.

I recently wiped the vero and reinstalled the latest OSMC.

Let me know what other information I can provide

Do I assume correctly that is a 3.5" drive with its own power supply?

Do you have it connected via a Hub or directly? Did you tried the other USB port?

Its a 3.5" drive in an external powered HDD case. OSMC fails to boot if the HDD is connected to either vero USB port or to an external hub via the USB3 port

Tried both ports of the Vero?

@sam_nazarko any ideas what might be wrong?

Yes neither port on the vero seems to make a difference

Do I see a SD card is connected as well as the HDD? Does it work without that plugged in?

The (micro) SD card is just the card formatted with OSMC inside the vero, the only other attachment I use is the dongle for the OSMC remote, but even with everything removed and only the HDD attached, OSMC fails to boot

It’s hard to speculate why without UART output what could be causing this; and to get UART output would be involving for users.

I will see if I can reproduce with any drives I have locally.


It shouldn’t matter but anyway best to remove the card after successful installation.

It won’t make a difference.

Could you try again, perhaps the system stays alive when the hdd is connected later:

  1. boot with hdd disconnected (debug enabled, twice rebooted the system before)
  2. if you see the mediacenter desktop, wait a minute or longer
  3. connect the external disk

In case the system is still up and running, upload a new log set. Otherwise this method also does not work to get more information. Disconnect the hdd and reboot.

Can you also provide some information about the used USB enclosure? Is it for sure capabale to work with 12 TB sata hdds?

I just googled the make and sure enough, it only supports 10Tb. I’m just really surprised since it seems to work when plugged in, although I am not near 10Tb full. I will report back when I try and new enclosure…

I hope this hasn’t caused any weird corruptions :slightly_frowning_face:

Finally purchased a better quality HDD enclosure with no upper storage limit. Now I have no boot loop, faster loading and faster shutdown times.

Thank you everyone for the help and educating me.

1 Like

So unfortunately, despite buying a name-brand HDD enclosure with no capacity limit, it seems like this is still an issue for me. I can’t remember if it worked for a while, but we had a power outage while the device was connected to OSMC and the boot loop has returned. No issues when plugged in after boot.

If someone is willing to walk me through it, i can try and provide UART output. I can’t find much information on the web about UART in relation to HDDs.

Unfortunately UART output would require soldering to the board, which isn’t ideal.