Cannot run Zatto & Youtube

I’m using a recent version of Kodi:
osmc@osmc-Giles:~$ grep Kodi .kodi/temp/kodi.log | head -3
2021-02-11 19:22:48.981 T:1915731984 NOTICE: Starting Kodi (18.9). Platform: Linux ARM (Thumb) 32-bit
2021-02-11 19:22:48.981 T:1915731984 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
2021-02-11 19:22:48.982 T:1915731984 NOTICE: Kodi compiled 2020-11-26 by GCC 8.3.0 for Linux ARM (Thumb) 32-bit version 4.19.152 (267160)

Suddenly today, I cannot start Zatto and Youtube. I get the following errors:
Tattoo:
2021-02-11 19:02:54.956 T:1916219408 ERROR: Control 55 in window 10025 has been asked to focus, but it can’t
2021-02-11 19:03:08.063 T:1916219408 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.zattoobox/?ext=LiveTV&mode=watch&id=tsr2]

Youtube:
2021-02-11 19:13:23.116 T:1916219408 ERROR: Control 50 in window 10025 has been asked to focus, but it can’t
2021-02-11 19:13:39.171 T:1433551072 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–

2021-02-11 19:13:39.344 T:1916219408 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/play/?video_id=7rhFaInn5Ak]

I have no idea how to solve that. Any suggestion will be very appreciated.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Did you see this thread? Zattoo tv addon does not work

2 Likes

Yes I saw this thread but thought it should not be my problem. Both Zatto and Youtube was working fine until today. Suddenly both stopped to work. However, I tried and got an error during install from zip:
failed to install , invalid structure

I tried to uninstall tattoo and re-install it without success

It would be good to see some logs as suggested by @ooZee, so we can gain a further understanding.

Sorry for not doing so from the beginning. I enabled debug, rebooted OSMC and try to watch Youtube after a search and a second try to watch TV on zattoo.

The logs are on https://paste.osmc.tv/arowoyipit.

Whenever the Youtube addon breaks it is pretty much never OSMC’s fault.
Youtube typically changes something and when they do that the addon needs to be updated.
There are 2 places for you to check when the Youtube addon breaks:
Youtube addon forum thread
Youtube addon releases on GitHub

In this case you can see that there are plenty of people complaining about the same thing on the forums and the solution is to go GitHub and install the latest release.

1 Like

I finally succeeded with youtube with plugin.video.youtube-6.8.10.alpha1.zip

For zattoo, I downloaded a zip from GitHub - rbuehlma/pvr.zattoo: Kodi PVR-Addon for Zattoo and compiled it without problem following the Readme file. But when I load the zip file in pvr.zattoo/build/build/zips/pvr.zattoo+linux/pvr.zattoo-19.7.1.zip, I get the following error:

2021-02-14 12:12:34.405 T:1521209568 ERROR: CAddonInstallJob[pvr.zattoo]: The dependency on kodi.binary.global.main version 1.3.0 could not be satisfied.

This is my first experience building a zip so I don’t know if I loaded the right zip created file in the list below:
./xbmc/xbmc/filesystem/test/reffile.txt.zip
./xbmc/xbmc/filesystem/test/extendedlocalheader.zip
./xbmc/addons/webinterface.default/lib/soundmanager/swf/soundmanager2_flash_xdomain.zip
./pvr.zattoo/build/build/zips/pvr.zattoo+linux/pvr.zattoo-19.7.1.zip
./pvr.zattoo/build/pvr.zattoo-prefix/src/pvr.zattoo-build/_CPack_Packages/Linux/ZIP/addon/addon-pvr.zattoo-19.7.1-linux.zip
./pvr.zattoo/build/pvr.zattoo-prefix/src/pvr.zattoo-build/addon-pvr.zattoo-19.7.1-linux.zip

Any suggestion will be appreciated and the log file is here:
https://paste.osmc.tv/nonuhefeca

Good news: I succeeded compiling & installing pvr.zattoo-18.1.23.zip and it works fine now.