Cannot see my OSMC SAMBA 1 shares after latest update

Having had RPi + OSMC/KODI acting as a Samba 1 server for several years; after the latest update these shares are no visible longer to my Windows 10 PC or my 2 PVRs.

May not be relevant, but a year ago I updated OSMC and lost the Kodi GUI (mediaserver) and raised this report Update to 19.1 causes sad face loop on Kodi menu. I never did any more as I didn’t really use the GUI, it was only the share that was important, and that was still working OK.

A few days ago, on a whim, I performed an update (aptget update and dist-upgrade) to OSMC 2022.09-1 running KODI 19.4. The good news is that it fixed the GUI, the bad is that I can no longer see the samba 1 share.

Network is OK; I can ping and telnet into.
Windows still lists an OSMC share, but clicking it does not open it.
The RPI has a USB HDD attached, which is still visible and mounted in OSMC, but is no longer visible or accessible to Windows or my 2 PVRs.

Windows 10 has been kept up-to-date throughout , so any historical Samba 1 issues already have been dealt with.

Any suggestions to diagnose and fix this would be appreciated.

If you did a “console” upgrade, I bet you got a question to keep your own smb.conf or replace with the distributed one. A typo or a Y in the wrong place can explain the lack of shares?

Edit: corrected the filename

I don’t recollect seeing such a question, but you may be correct.

As far as I know, I did the original configuration as recommended by placing my configurations in smb-local.conf & smb-shares.conf.
I left smb.conf unchanged and added a smb-local.conf (which was an edited version of smb.conf, with the config file line commented out).
There is a smb.conf.original file (I may have created it, but cannot say for sure). it only differs in that smb.conf now contains the extra line " fruit:model = Macmini" whatever that means?

Okey, if you got an .original file it may well been changed, check if “include statement” isn’t remarked in new file =)

Anyway it was just a hunch. If you are gonna use it as a file server on a mixed network, I recommend:

Read instructions, if there isn’t a service installation in the deb package, check out the service file example in that repository.

The “config file” line is not commented in smb.conf, it contains the line " config file = /etc/samba/smb-local.conf".
The Web Discovery package says that it handles server discovery but not connection to server. However, I already know the IP. it is the connection that I am unable to establish. In fact, my PVRs only support Samba 1 using IP, user name and password, so would be unable to make use of the Discovery package.

Is there a way within OSMC of making sure the samba package is running and what it shares it is supporting?
I tried “sudo service samba status” and it returns

samba.service - Samba Server
Loaded: loaded (/lib/systemd/system/samba.service; enabled; vendor preset:>
Active: active (exited) since Thu 2022-10-06 23:36:47 BST; 6 days ago
Process: 7459 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
Main PID: 7459 (code=exited, status=0/SUCCESS)
CPU: 6ms

Oct 06 23:36:47 osmc systemd[1]: Starting Samba Server…
Oct 06 23:36:47 osmc systemd[1]: Finished Samba Server.

That looks like it has stopped, where do I find more info on what stopped it?

Problem solved…
I was looking at /var/log/samba/log.smbd and found lots of reports regarding widelinks and being unable to load a module

[2022/10/13 22:59:13.250524, 0] …/…/source3/smbd/vfs.c:379(smbd_vfs_init)
smbd_vfs_init: widelinks enabled and vfs_init_custom failed for vfs_widelinks module
[2022/10/13 22:59:13.250616, 0] …/…/source3/smbd/service.c:636(make_connection_snum)
make_connection_snum: vfs_init failed for service osmc
[2022/10/13 22:59:13.254588, 0] …/…/lib/util/modules.c:49(load_module)
Error loading module ‘/usr/lib/arm-linux-gnueabihf/samba/vfs/’: /usr/lib/arm-linux-gnueabihf/samba/vfs/ cannot open shared object file: No such file or directory
[2022/10/13 22:59:13.254819, 0] …/…/source3/smbd/vfs.c:185(vfs_init_custom)
error probing vfs module ‘widelinks’: NT_STATUS_UNSUCCESSFUL

An internet search eventually found Samba: No shares available after bullseye update which discusses this.
It talks about disabling wide links (but I currently use them so don’t want to disable them).
Alternatively, post #14 suggested

sudo apt-get install samba-vfs-modules

which fixed the problem for me.

Note that in the following post (#15) Xbian fixed this problem by adding the missing dependency on samba-vfs-modules; maybe OSMC should consider doing the same.