Update to 19.1 causes sad face loop on Kodi menu

I have just updated the Kodi on my OSMC/RPi to 19.1, but it has resulted in a sad face loop.

The system boots and brings up the Kodi GUI menu, but within a second or 2 it shows the sad face screen for 5 or 10 seconds before showing the Kodi menu again… and just keeps repeating.
I have network access and can initiate telnet access.

I have tried the following via telnet sessions, but with no improvement…

sudo apt-get install rbp2-mediacenter-osmc --reinstall

sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot

sudo systemctl stop mediacenter
mv ~/.kodi ~/.kodi-backup
sudo systemctl start mediacenter
A new .kodi is created but the problem remains. I have seen reference to the Addons27.db file; this is not recreated in the new .kodi.

Any suggestions?

$ grab-logs -A
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/aqazixiqow

Kodi log hastebin

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Unless you specifically need it done without sudo, you will see that I had already tried that and it produced the same result.

The sad face is caused by MESA issues.

You seem to have installed X11 and MESA packages, so these crashes are expected.

Thanks, sorry to say, I do not know what either of them are (other than knowing that they are graphics standards) and was not aware that I had installed either outside of standard OSMC/Kodi install and what can be selected from Kodi menus. How should I choose which I want and uninstall the other? If it helps; at the present I am only using the system as a file server and using the Kodi menus to keep the system up-to-date.

The simplest option presently would be to reinstall your system.

Thanks for the reply.
I will have to search for my original build notes. I know I had some difficulty getting it to auto-mount my USB HDD and then sharing it to my local network (at a low enough Samba level for my PVRs to access). So I need to find out which config files I changed.
Fortunately at present, that side of things is still working perfectly, so I won’t risk that re-install until I have more time on my hands.

Samba server config files would be in /etc/samba/

Thanks for that